Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
[hide] hack incl post thank you "addon" Details »
[hide] hack incl post thank you "addon"
Mod Version: 0.3.5, by itsid (Member) itsid is offline
Developer Last Online: Jun 2010 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.2 Rating: (69 votes - 4.59 average) Installs: 863
Released: 06 Nov 2006 Last Update: 09 Dec 2006 Downloads: 13868
Not Supported Uses Plugins Additional Files  

UPDATE
sid's [hide] hack 0.3.5

Hi again,

I've tried my best to build a [hide] hack that will fit to to
the wonderful POST THANK YOU HACK

but for sure you can use it without, then it'll work if user replies to a post with hidden content

You can coose in acp to show hidden content to admins mods or users of a certain usergroup (if you have useradmins or something) too.

It will show up some hint that will let your users know what to do (thank, answer, or even nothing)
by now with some small text, soon with a set of images

BUT
  • my english is way off what I want it to be, so please go ahead and edit the language file to your needs

NOW UPDATED

Thanks to Andreas of vbhacks-germany
  • no hidden content visible in archive
  • no php edits necessary no more
  • kicked out bitfield-code

    and further
  • no hidden content visible in printthread.php if not in showthread.php
  • now with a set of small images showing up as hint
  • and least updateurl in acp
have fun

cheers
'sid

ps Sorry for updating that fast

UPDATE 0.3.0
uninstall previous version before installing the update!
So, here's what you've all been waiting for *grin*
Tha ajaxified version of my hide hack.

BUT, this is rather bruteforcing ajax, so be warned
First: you could fully disable ajax for this script in ACP!
Now how it goes, it checks the length of pagecontent every three seconds (usersides, no worries about serverload here), and if it finds some new "content" like a filled thanks-box or a new post it calls all the posts that have hidden content (of this page only of course) and tries to refill the postbits,
this causes some sql-queries, almost as much as to totally reload the page itself.
AS soon as I find a more elegant method I will update again.
Nothing else was changed though since 2.6, only modified in handling the ajax-request.
If you encounter any problems with the ajax of this script, just deactivate,
no javascript at all then will be loaded from this script, and you'll have a "normal" version in hands.
(size is due to an pic-install-help-image )

UPDATE 0.3.5
reduced querys,
smarter installations code.

that's all

cheers
'sid

PS If you encounter any problems not seeing thanked posts hidden content after reload,
try this codechange

PPS Sorry, Support only for those who clicked "install"

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	hide1.jpg
Views:	11368
Size:	116.1 KB
ID:	55553   Click image for larger version

Name:	hide2.jpg
Views:	9038
Size:	101.7 KB
ID:	55554   Click image for larger version

Name:	hide3.jpg
Views:	4584
Size:	99.1 KB
ID:	55555   Click image for larger version

Name:	hide4.jpg
Views:	9302
Size:	111.1 KB
ID:	55556  

Click image for larger version

Name:	hide5.jpg
Views:	3232
Size:	95.0 KB
ID:	55557   Click image for larger version

Name:	hide6.jpg
Views:	3745
Size:	96.3 KB
ID:	55558   Click image for larger version

Name:	hide7.jpg
Views:	3093
Size:	97.3 KB
ID:	55559   Click image for larger version

Name:	hide8.jpg
Views:	3567
Size:	89.6 KB
ID:	55560  

Click image for larger version

Name:	en_hide_pot.gif
Views:	2907
Size:	8.2 KB
ID:	55587  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #736  
Old 05 Jun 2008, 15:20
enjoyquality enjoyquality is offline
 
Join Date: Jul 2007
Hi,

I have been using that hack vBulletin 3.7. I do not have any problem. It makes hide all the messages but I have added a button to the Text Editor. Then I am choosing the message/link which I have to do it hide and then clicking the button that I made but adding 2 hide code. You can see below the example ;



Can you tell me how can I solve the problem ?
Reply With Quote
  #737  
Old 07 Jun 2008, 02:14
joeeleven joeeleven is offline
 
Join Date: Feb 2008
ok here is

well i did all u guys were suggesting here and its working fine for me on 3.7.1
no problem so far i just imported the product, enable the ajax option in vBulletin Options>Posts: vB Code [hide] disable the thanks feature since i dont wanted and is not working, hope it help some ppl like me
now its just me or when u use that hide hack when u try to see the post its a litle bit slow?
Attached Files
File Type: xml ajax-product-sids_hide_v0.3.5-vborg-en.xml (26.6 KB, 176 views)
Reply With Quote
  #738  
Old 08 Jun 2008, 15:37
stinger2's Avatar
stinger2 stinger2 is offline
 
Join Date: Jul 2005
what is this if i may ask.......did you solve all problems....specially security token problem?
Reply With Quote
  #739  
Old 09 Jun 2008, 02:09
joeeleven joeeleven is offline
 
Join Date: Feb 2008
yes thats the working xml file with the security token fixed
Reply With Quote
  #740  
Old 09 Jun 2008, 21:06
vitrag24's Avatar
vitrag24 vitrag24 is offline
 
Join Date: Nov 2006
any plan to release for vb 3.7 as thanks is released and this one isnt compatible with updated thanks addon for vb 3.7?
Reply With Quote
  #741  
Old 09 Jun 2008, 21:09
vitrag24's Avatar
vitrag24 vitrag24 is offline
 
Join Date: Nov 2006
Originally Posted by joeeleven View Post
well i did all u guys were suggesting here and its working fine for me on 3.7.1
no problem so far i just imported the product, enable the ajax option in vBulletin Options>Posts: vB Code [hide] disable the thanks feature since i dont wanted and is not working, hope it help some ppl like me
now its just me or when u use that hide hack when u try to see the post its a litle bit slow?
is it compatible on vb 3.7.1 with thanks button?
as i want it integrated with thanks.
Reply With Quote
  #742  
Old 15 Jun 2008, 13:48
Roflstilzchen Roflstilzchen is offline
 
Join Date: Nov 2006
it is, just take the xml from post 737
Reply With Quote
  #743  
Old 15 Jun 2008, 17:29
atgv atgv is offline
 
Join Date: Dec 2007
Ok I was using this hack in 3.6.8 but after upgraded version to 3.7.1 I had to tried "vS-Hide Hack Resurrection (Limited Edition)"

Now I m trying the disable it and use this one again with joeeleven's above xml. however when i disable HH resurection certain boards come as blank page. I wanna use this tag again.. Any suggestion ? Thanks beforehand..
Reply With Quote
  #744  
Old 17 Jun 2008, 22:34
vitrag24's Avatar
vitrag24 vitrag24 is offline
 
Join Date: Nov 2006
Originally Posted by Roflstilzchen View Post
it is, just take the xml from post 737
but is it working integrated with thanks mod by abe1?
Reply With Quote
  #745  
Old 20 Jun 2008, 19:22
atgv atgv is offline
 
Join Date: Dec 2007
though nobody interested, wanna say that i fixed my problem by totally removing other hide hack (not disabling)


Originally Posted by vitrag24 View Post
but is it working integrated with thanks mod by abe1?
it works in my several boards with thanks mod, but in several boards when pressing thanks button it gives error message about:

1. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
2. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.

Last edited by atgv; 20 Jun 2008 at 19:42.
Reply With Quote
  #746  
Old 22 Jun 2008, 23:43
vitrag24's Avatar
vitrag24 vitrag24 is offline
 
Join Date: Nov 2006
Originally Posted by atgv View Post
though nobody interested, wanna say that i fixed my problem by totally removing other hide hack (not disabling)




it works in my several boards with thanks mod, but in several boards when pressing thanks button it gives error message about:

1. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
2. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.
i've updaated hide mod with that one..
rightnow it seems it's working.
Hope it'll work in future also.

BTW, previously it was showing an image showing to click on thanks to seen hidden content"
How to reappaer image again?
Reply With Quote
  #747  
Old 23 Jun 2008, 00:02
vitrag24's Avatar
vitrag24 vitrag24 is offline
 
Join Date: Nov 2006
Originally Posted by vitrag24 View Post
i've updaated hide mod with that one..
rightnow it seems it's working.
Hope it'll work in future also.

BTW, previously it was showing an image showing to click on thanks to seen hidden content"
How to reappaer image again?
i was wrong.
major bug in that modified mod too.
if user click on thanks he'll see hidden content but again if he opens same thread or refresh page he'll not see hidden content and as thanks has been pressed no option to click thanks again.

So plz someone release it for vb 3.7.

it's necessary mod for me..
Reply With Quote
  #748  
Old 23 Jun 2008, 05:31
SenatorS SenatorS is offline
 
Join Date: Sep 2005
Originally Posted by joeeleven View Post
well i did all u guys were suggesting here and its working fine for me on 3.7.1
no problem so far i just imported the product, enable the ajax option in vBulletin Options>Posts: vB Code [hide] disable the thanks feature since i dont wanted and is not working, hope it help some ppl like me
now its just me or when u use that hide hack when u try to see the post its a litle bit slow?
thx man working fine
Reply With Quote
  #749  
Old 23 Jun 2008, 11:23
bonmat86 bonmat86 is offline
 
Join Date: Dec 2003
I install this mod with Hide Hack 7.6
But when I click thanks button. The hidden content doesn't display untill I refresh the page.
Reply With Quote
  #750  
Old 29 Jun 2008, 21:03
xenon58 xenon58 is offline
 
Join Date: Dec 2005
i dont know if anyone have seen this problem or not, but in case someone has, I would like to know how to fix it.

i'm using this hack on 3.6.8 and everything works great, however, i have few people that are using firefox 3, and they are whining to me that this hack doesnt work for them. when they click the hide button or write hide tags themselves, it doesnt hide anything.

i really dont know what gives, as i'm using ie and ff 2 and it works like it should.

any pointers on how to fix this issue, would be greatly appreciated. thnx in advance.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 05:11.

Layout Options | Width: Wide Color: