Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Add New Facebook "Like" button to your threads Details »
Add New Facebook "Like" button to your threads
Mod Version: 1.2, by ericgtr (Coder/Designer) ericgtr is offline
Developer Last Online: Aug 2020 I like it Show Printable Version Email this Page

vB Version: 4.0.2 Rating: (32 votes - 4.84 average) Installs: 326
Released: 22 Apr 2010 Last Update: 22 Apr 2010 Downloads: 1040
Not Supported Re-usable Code  

Please remember to click Mark as Installed if you use this modification.

Facebook has just launched their latest "Like" button to developers to use on any site. What this does is utilizes the Advertising module to add the "Like" button to the first post of each thread. Please see screenshots to get an idea.

In your Admin CP go to Advertising > New Ad > Choose "Thread" from the dropdown and then select the first thread box. Give it a title (I called mine FB Like) leave "First Post Content" at default and paste in this code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Be sure to change YOURSITE.com to your URL including your forum.

The VBSEO team has instructions on how to make this work for their product here http://www.vbseo.com/f2/facebook-lik...95/#post265997

===========================================
Option 2 (different from above, do not use together) will show at top, see screenshot #3

In Postbit (or legacy) find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Add this after:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

For additional information on this button and different parameters please visit http://developers.facebook.com/docs/...e/plugins/like

=================================================

For those who have asked, here is the modification adds both the "Like" button and comments to a users profile http://www.vbulletin.org/forum/showthread.php?t=239424

=================================================
Additional locations to place this code:

For CMS, in vbcms_content_article_page add the code below this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

For pictures, in template album_pictureview add the code below this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

For Blog, in template blog_show_entry add at the very top.

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Screenshots

Click image for larger version

Name:	fb_like.JPG
Views:	8487
Size:	89.7 KB
ID:	116172   Click image for larger version

Name:	fb_like2.JPG
Views:	4380
Size:	11.7 KB
ID:	116173   Click image for larger version

Name:	fb_like3.JPG
Views:	8328
Size:	41.0 KB
ID:	116182  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #91  
Old 25 Apr 2010, 23:30
MedellinStyle MedellinStyle is offline
 
Join Date: Oct 2007
Hi

I want to ask, the script works fine, it displays fine on peoples wall on facebook, but in VBULLETIN, different to how many people clicks on LIKE, it still displays , LIKE 1.

Only 1 not acumulate, any help would be appreciated , thanks!
Reply With Quote
  #92  
Old 26 Apr 2010, 00:18
ericgtr's Avatar
ericgtr ericgtr is offline
 
Join Date: Apr 2003
Originally Posted by MedellinStyle View Post
Hi

I want to ask, the script works fine, it displays fine on peoples wall on facebook, but in VBULLETIN, different to how many people clicks on LIKE, it still displays , LIKE 1.

Only 1 not acumulate, any help would be appreciated , thanks!
It only shows how many of your friends clicked on it.

Please click install.
Reply With Quote
  #93  
Old 26 Apr 2010, 14:03
YankForum's Avatar
YankForum YankForum is offline
 
Join Date: Mar 2010
Real name: alij
tnx installed
Reply With Quote
  #94  
Old 26 Apr 2010, 15:06
AndrewSpearin AndrewSpearin is offline
 
Join Date: Dec 2009
Real name: Andrew Spearin
I have this installed and working fine for forum posts, but how do I go about adding it for CMS articles, blog posts, and albums/pictures?
Reply With Quote
  #95  
Old 26 Apr 2010, 15:24
ericgtr's Avatar
ericgtr ericgtr is offline
 
Join Date: Apr 2003
Originally Posted by AndrewSpearin View Post
I have this installed and working fine for forum posts, but how do I go about adding it for CMS articles, blog posts, and albums/pictures?
Here's some suggestions.

For CMS, in vbcms_content_article_page add the code below this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

For pictures, in template album_pictureview add the code below this:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This gives you the idea, I haven't added it to the blog yet but it's just a matter of locating the right template.
Reply With Quote
  #96  
Old 26 Apr 2010, 16:58
AndrewSpearin AndrewSpearin is offline
 
Join Date: Dec 2009
Real name: Andrew Spearin
Thanks, I added this code:

<!-- Facebook Like -->
<iframe src="http://www.facebook.com/plugins/like.php?href=http://www.npac.ca/2010/{vb:link thread, {vb:raw thread}, {vb:raw pageinfo_post}}&amp;layout=button_count&amp;show_faces=false&amp;width=450&amp;a ction=like&amp;colorscheme=light" scrolling="no" frameborder="0" allowTransparency="true" style="border:none; overflow:hidden; width:450px; height:30px"></iframe>
<!-- / Facebook Like -->

in: vbcms_content_article_page

after: <vb:if condition="$comment_block"> ... </vb:if>

Example: http://npac.ca/2010/content.php/121-QA-with-Rod-MacIvor

I click like, it shows up with the proper article title on my Facebook profile, however it links to the corresponding forum post for the article: http://www.npac.ca/2010/showthread.p...th-Rod-MacIvor

The 'like' does appear in both the forum post and article though.

How can I make it link straight back to the article? I'm not familiar with the {vb:link} stuff, so I don't really know what else to try instead.

Thanks again for your help!
Reply With Quote
  #97  
Old 26 Apr 2010, 17:25
movslow movslow is offline
 
Join Date: Aug 2008
FYI, I had the error, and realized you need the trailing / on the end of the url.

Added that, worked liked a charm, this was in Postibit Legacy.
Reply With Quote
  #98  
Old 27 Apr 2010, 03:49
fluidswork's Avatar
fluidswork fluidswork is offline
 
Join Date: Apr 2010
Real name: Arnab Bhadra
Awesome mod i will try it ..............
Reply With Quote
  #99  
Old 27 Apr 2010, 07:40
junaid junaid is offline
 
Join Date: Oct 2005
Is possible to add like thanks button or same locations?
__________________
My forum
Reply With Quote
  #100  
Old 27 Apr 2010, 08:06
junaid junaid is offline
 
Join Date: Oct 2005
I want code for button count 16x16
could you provide me code
__________________
My forum
Reply With Quote
  #101  
Old 28 Apr 2010, 00:14
hoadiem hoadiem is offline
 
Join Date: Aug 2007
will this work with 4.0.3
Reply With Quote
  #102  
Old 28 Apr 2010, 16:50
Ranger375 Ranger375 is offline
 
Join Date: Jun 2007
yeah it works with 4.0.3
Reply With Quote
  #103  
Old 30 Apr 2010, 10:47
Red Spider's Avatar
Red Spider Red Spider is offline
 
Join Date: Jan 2006
im struggling to get this working correctly as per the screenshots in OP.

When i click "like" it on my fb newsfeed it just says "xxx likes xxx forum"... does NOT say "xxx likes xxx on xxx forum" as per the screenshot. any help?
Reply With Quote
  #104  
Old 30 Apr 2010, 14:36
Crazyfruitbat Crazyfruitbat is offline
 
Join Date: Apr 2009
that works great in postbit legacy - front page articles would be great now
__________________
My site: www.sanctuary4gamers.com My Twitter and if you like video games, my podcast
Reply With Quote
  #105  
Old 30 Apr 2010, 16:26
ericgtr's Avatar
ericgtr ericgtr is offline
 
Join Date: Apr 2003
Originally Posted by Red Spider View Post
im struggling to get this working correctly as per the screenshots in OP.

When i click "like" it on my fb newsfeed it just says "xxx likes xxx forum"... does NOT say "xxx likes xxx on xxx forum" as per the screenshot. any help?
That usually means something isn't right with your forum path, I would double check it.

Originally Posted by Crazyfruitbat View Post
that works great in postbit legacy - front page articles would be great now
I have a location for that a little while back here http://www.vbulletin.org/forum/showp...3&postcount=95
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:33.

Layout Options | Width: Wide Color: