Register Members List Search Today's Posts Mark Forums Read

Closed Thread
 
Mod Options
  #1  
Old 02 May 2005, 05:31
Aurous Aurous is offline
 
Join Date: Apr 2004
Bug: "Use Automatic Warnings from Private Messages?" option

Manage Warning Options ->
Use Automatic Warnings from Private Messages ->
"No" Selected


When I select this option as "No", the user still gets warned for using bad words when sending a Private Message. Using the latest 3.4.8 v

Aurous
Comments
  #2  
Old 02 May 2005, 16:19
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
I have to assume that you have not perform the changes properly. As far as I can say, that should work fine. Here is that part of the private.php file, that handles the warning.

In private.php find:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Below that, there should be something as shown below:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I hope you get it straighened out.

Rgds
__________________

John
SV1CEC
  #3  
Old 04 May 2005, 09:59
Aurous Aurous is offline
 
Join Date: Apr 2004
actually thats exactly what I have, dont know whats wrong :S I think it doesnt register the option settings from "Yes" to "No" in the warning options page. Although I do see it says "No" in the settings.
  #4  
Old 04 May 2005, 11:50
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
Set the option to yes, and see if it saves it. If it does, then change it to No, it should save it too.

As you can see from the code, the whole section which issues the warning, is enclosed in a conditional, which checks if $vboptions['warn_automaticpm'] == 1, that is if the option is set to yes. If it is set to no, then that whole section never gets executed.

Rgds
__________________

John
SV1CEC
  #5  
Old 04 May 2005, 16:44
Aurous Aurous is offline
 
Join Date: Apr 2004
Originally Posted by sv1cec
Set the option to yes, and see if it saves it. If it does, then change it to No, it should save it too.

As you can see from the code, the whole section which issues the warning, is enclosed in a conditional, which checks if $vboptions['warn_automaticpm'] == 1, that is if the option is set to yes. If it is set to no, then that whole section never gets executed.

Rgds
hmm I will check that out, another problem that I am having right now is that everytime someone sends a PM to me, I get 2 copies of it instead of one :ermm:
  #6  
Old 04 May 2005, 19:36
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
Check your private.php file. Something is wrong there.

Rgds
__________________

John
SV1CEC
  #7  
Old 04 May 2005, 21:38
Aurous Aurous is offline
 
Join Date: Apr 2004
Originally Posted by sv1cec
Check your private.php file. Something is wrong there.

Rgds
Please lock this thread, it was an error from my end, didnt make the changes properly, sorry for all the trouble and I am glad you were able to give fast and great support to your hack, amazing!
  #8  
Old 04 May 2005, 21:57
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
Actually you got me scared to death. Tonight, someone from my forums told me that he had received double PM's as well. And I spend about 3 hours trying to get in touch with him and clarify the issue. In any case, I'll look into it more, but please let me know if you get twins PMs again.

Rgds
__________________

John
SV1CEC

Last edited by sv1cec; 04 May 2005 at 23:30.
Closed Thread



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 04:06.

Layout Options | Width: Wide Color: