Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
WS vBulletin Tweet Poster Details »
WS vBulletin Tweet Poster
Mod Version: 4.1.0, by Mosh (Coder) Mosh is offline
Developer Last Online: Jun 2013 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (90 votes - 4.66 average) Installs: 592
Released: 19 Feb 2010 Last Update: 30 Jun 2013 Downloads: 3227
Not Supported Uses Plugins Additional Files Re-usable Code Translations  

Please click Mark as Installed if you are using this hack.

What Does This Hack Do?

I use v4.1.0 of this hack at Wolfshead Solutions and have had no issues at all.

Depending on the options you select in the AdminCP, you can:
  • Automatically create a new tweet when you create a new thread only (including hashtags if selected)
  • Automatically create a new tweet when you post a new reply/quick reply to a thread only
  • Automatically create a new tweet when you create a new thread and post a new reply/quick reply

These tweets are live updates.... the instant you or your members post a new thread or a new reply/quick reply in a WS vBulletin Tweet Poster enabled forum, a tweet is made at the same time. These tweets will only be posted if they are 140 characters or shorter (this is automatically checked) and the new thread or new reply/quick reply is not sent the moderation queue.... so instead of throwing errors, in these cases this hack will not even attempt to tweet the thread/post.

As of v4.0.003, this hack is very, very loosely based on Buro9's vBulletin To Twitter hack (there is not one line of original untouched code left from his hack in this hack, and his hack is based on Basic authentication). I have totally rewritten his hack to made it into a product to use OAuth authentication to post to Twitter and have added extra functionality, which includes is.gd, TinyURL.com & Metamark as alternative url shortening services, as well as options to tweet replies to threads as well as tweet new threads and to add Hashtags.

What is required before installing this hack?

Your server needs the following options installed on it for this hack to work. This hack will check the requirements for you and will not install this hack if they are not.
  1. cURL with OpenSSL compiled into your php - http://curl.haxx.se/, http://php.net/manual/en/book.curl.php
  2. JSON support compiled into your php - http://www.json.org/, http://php.net/manual/en/book.json.php

Once you have server requisites from above covered, you will then need the following accounts setup before you can install this hack:
  1. You need to have a normal Twitter account details to post to - http://twitter.com
  2. You will need to register a new Twitter Application (while logged with your normal Twitter account) - http://dev.twitter.com/apps/new
  3. You will need the items below for step 4 of the attached install instructions:
    1. Note down the "Consumer Key" and "Consumer Secret" (Under App Details)
    2. Note down the "Access Token" and "Access Token Secret" (under My Access Token on the App details screen)
  4. If you want to use bit.ly url shortening (Optional)
    1. You need to have registered with bit.ly to obtain a username and your API Key - http://bit.ly
  5. Then install this hack by following the "Installation/Upgrade Instructions" attached.

TWITTER DEMO: There is no longer a demo available.

What Do You Get?

The settings in the AdminCP options are:
  • Turn this hack on or off
  • Enter your twitter "Consumer Key" and "Consumer Secret"
  • Enter your twitter "Access Token" and "Access Token Secret"
  • Select which url shortening service to use, is.gd, TinyURL.com, Metamark, bit.ly or none (default is bit.ly)
  • Enter your bit.ly username and API key
  • Option to include all, include selected or exclude selected forums when posting to twitter
  • Enter which forums to include or exclude when posting to twitter
  • Select if you want to use your thread prefixes when posting a new thread to twitter
  • Select if you want to post your new threads to twitter or not
  • Select if you want to allow user or admincp defined hashtags (or no hashtags at all)
  • Enter admincp defined hashtags
  • Select if you want to post your replies/quick replies to twitter or not
  • There is a link to edit the new reply/quick reply prefix (default is Re:)
  • Date prefix to add to new reply/quick reply to make it unique to not be detected as a duplicate by twitter

Frequently Asked Questions

Question 1:
It doesn't work! Help!!!
Answer:
That does not help others help you. Please explain exactly what the issue is, give as much information as possible and that may aid others in helping you.

Question 2:
I don't know how to setup a Twitter Application! Help!!!
Answer:
Enter the following details when creating your application:
  • Application Name: I advise your website url (for instance I used "wolfshead-solutions.com")
  • Application Website: Enter the full url to your site (for instance I used "http://www.wolfshead-solutions.com")
  • Application Type: Set to "Client"
  • Default Access type: Set to "Read & Write"
Stay logged into your Twitter account, as the first time you tweet from your forum you will need to authorise the domain.

Question 3:
I think I have set up everything correctly, the thread and/or post is created with no issues, there are no errors, but nothing is posted to twitter. Help !!!
Answer:
On the Details tab of your Twitter Application (at https://dev.twitter.com), check the following:
  • Under the OAuth settings section, check Access level is set to Read and write not Read-only
  • Under the Your access token section, check Access level is set to Read and write not Read-only

If either of the above settings is Read-only, then you need to do the following:
  • Revoke access for the current application on your normal twitter account
  • Delete your current application
  • Create a brand new application with exactly the same information as the application you have just deleted.
  • Under the Settings tab, check the Access level under the Application type
    is set to Read and write not Read-only before you create the Access Token

Question 4:
I am using vBulletin 3.8.7 and the user hash tag field is not showing.... what can I do?
Answer:
Follow the instructions in this post.

Question 5:
Can you please add the ability to tweet RSS feeds, CMS articles, Blogs, calendar events etc?
Answer:
This hack tweets live to twitter, and as none of the requests above are guaranteed to be live (ie they can be set to be published later), I will never be adding the any of the above to this hack and that will never change.

Question 6:
Can I use this hack with vBulletin 4.1.4 which has the new CKEditor, and the hashtag field be visible to my members (if selected in the AdminCP options)?
Answer:
Yes, this hack is already compatible. If you select Only User defined Hashtags or Both User and AdminCP defined Hashtags in the AdminCP Options for this hack, the hashtag field will be displayed to your members.

Question 7:
I see "Basic authentication is not supported on line XXX" or /statuses/update.xml Could not authenticate you. Unauthorized on line XXX errors
Answer:
It means you still have either v4.0.001 or v4.0.002 of this hack installed, and the solution is to upgrade to v4.1.0 or above of this hack, which uses OAuth Authentication.

Question 8:
I see "Fatal error: Cannot redeclare class OAuthException in [path]/includes/twitteroauth/OAuth.php on line 8" error
Answer:
Edit the OAuth.php file in the twitteroauth folder. Find all instances of OAuthException and change them to OAuthException_tw. That should fix it up.

Question 9:
I see a "You must be authenticated to access shorten" or INVALID_LOGIN on line xxx in /xxxxx/xxxxx/xxxxx/includes/bitly.php error message.... what do I do?
Answer:
Ensure you have entered your bit.ly username & API key correctly. If that does not fix it, then select is.gd, TinyURL or Metamark in your AdminCP Options instead of bit.ly for url shortening.

Question 10:
I see an "INVALID_JSON" error
Answer:
Select is.gd, TinyURL or Metamark in your AdminCP Options instead of bit.ly for url shortening.

Question 11:
bit.ly does not work (gives error messages), what can I do?
Answer:
Select is.gd, TinyURL or Metamark in your AdminCP Options instead of bit.ly for url shortening.

Question 12:
I see an error that says "Warning: curl_setopt_array() [function.curl-setopt-array]: CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set in [path]/bitly.php"
Answer:
Looks like that is a safe_mode issue... the below should fix it (but is not guaranteed that it will, but it should). In bitly.php, find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change it to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

If that does not fix it, then select is.gd, TinyURL or Metamark in your AdminCP Options instead of bit.ly for url shortening.

Question 13:
As I do not have to register with is.gd, how to I view click statistics with the generated link?
Answer:
Simply add a hyphen (dash) to the end of the shortened URL, and instead of being redirected to the original long address automatically, you'll be taken to a preview page telling you where the link goes and gives you the click statistics for the url.

For example: You have been given the shortened link http://is.gd/8HdYu and want to check where it goes. Copy/paste it into your browser's address bar and then add a hyphen, making the link http://is.gd/8HdYu-. Now simply visit that address, and instead of being taken directly to the original URL, you'll be taken to a preview page on the is.gd site which will tell you the link's destination along with the click statistics.

Question 14:
Threads with titles that have special characters in them (such as ) do not tweet, what do I do?
Answer:
Sorry, but it looks like an issue with the Twitter (OAuth) class file by Abraham Williams and not with this hack at all.

I have checked his bug tracker and this issue has been reported twice and has not been fixed yet by the author, please see:
You might want to reply to both of the bug reports to see if you can get the author to fix his Twitter class any quicker.

Question 15:
This hack has been working fine then stopped working on Tuesday 11th June 2013 and I did not make any changes, what do I do?
Answer:
Twitter updated their API to version 1.1 on 11/6/2013, so any versions of this hack below v4.1.0 will have stopped working. The solution is to upgrade to v4.1.0 of this hack.

If it still does not work, then you will probably need to do the following, then the hack should start working again within 24 hours:
  • Revoke access for the current application on your normal twitter account
  • Delete your current application
  • Create a brand new application with exactly the same information as the application you have just deleted.
  • Under the Settings tab, check the Access level under the Application type
    is set to Read and write not Read-only before you create the Access Token

vBulletin Version Compatibility

This hack can be used with vBulletin versions 4.0.0 - 4.2.1.

This has been tested with vBulletin v3.8.x and works fine, it should also work with v3.7.x and earlier versions (but has not been tested).



Hack Support/Feature Requests

IMPORTANT: This hack is no longer supported, but I have marked it as re-usable code, so it can be developed further (remember to acknowledge me as orignal author of this hack).



Install/Upgrade/Uninstall Instructions

There are no file or template changes at all and is fully phrased. You just need to upload 5 files (in 2 folders), import 1 product and alter the correct vBulletin Options in the AdminCP, and then it will work from then on.

The readme.txt instructions file is included in attached .zip file.


Version History

v4.1.0 - Sunday 30th June 2013 (Final Version Ever)
-- Updated: Installation/Upgrade/Removal Instructions file
-- Updated: OAuth.php & twitteroauth.php files to use the new Twitter API 1.1 (old API 1.0 no longer works)
-- Removed: all references to "account/rate_limit_status", as this has been removed from the Twitter API 1.1
-- Removed: Two plugins to aid in diagnosing problems with this hack (as I no longer support this hack, and have now left the vBulletin community)

v4.0.6 - Saturday 29th January 2011
-- Changed: Hack name
-- Updated: Installation/Upgrade/Removal Instructions file
-- Updated: Screenshots
-- Fixed: New Threads, Replies & Quick Replies in twitter enabled forums are only tweeted when they will not end up on the moderation queue
-- Fixed: Hashtags now work in vBulletin v3.8.x (hack tested and working.... not tested on v3.7.x nor v3.6.x but should also work)
-- Added: Install code to ensure all server requirements are met and all folders and files have been uploaded before the hack will install
-- Added: AdminCP Options to allow for both User & AdminCP defined Hashtags for new threads in twitter enabled forums
-- Added: Two plugins to aid in diagnosing problems with this hack (disabled by default)

v4.0.5 - Saturday 27th November 2010 (first released to Wolfshead Solutions on Wednesday 27th October 2010)
-- Changed: Version number formatting
-- Updated: Installation/Upgrade/Removal Instructions file
-- Updated: Screenshots
-- Added: AdminCP Options to include/exclude forums
-- Added: Hashtags for new threads in twitter enabled forums
-- Added: 2 plugins to cater for new hashtag feature
-- Added: AdminCP Option to also use the Metamark url shortening service
-- Added: Version History file
-- Removed: AdminCP Option for tli.td url shortening service (now requires api key)

v4.0.004 - Saturday 18th September 2010 (first released to Wolfshead Solutions on Wednesday 18th August 2010)
-- Updated: Installation/Upgrade/Removal Instructions file
-- Updated: Screenshots
-- Fixed: Tweets for new replies now correctly use the AdminCP's timezone offset setting along with DST settings for the timestamp
-- Added: AdminCP Options to also use the TinyURL and tli.tl url shortening services
-- Added: Automatic check to see if tweet is longer 140 characters or not (and post tweet if not)
-- Added: Automatic truncate tweet title text in the tweet if the tweet (including the URL) exceeds 140 characters
-- Added: Automatic check to see if number of hourly calls to the Twitter OAuth API has been exceeded or not (and post tweet if not)
-- Added: Ability to use vBulletin "Friendly URLs" (available in vBulletin 4 and later only) or just plain URLs
-- Added: All files needed for this hack in one package (no longer necessary to download other class files separately any more)

v4.0.003 - Friday 2nd July 2010
-- Updated: Installation/Upgrade/Removal Instructions file
-- Updated: Screenshots
-- Updated: 3 plugins to now use OAuth instead of Basic authentication when posting to Twitter
-- Added: AdminCP Option to not use url shortening at all
-- Added: 4 new AdminCP Options for Twitter "Consumer Key", "Consumer Secret", "Access Token" and "Access Token Secret"
-- Removed: 2 AdminCP Options for Twitter "Username" and "Password"

v4.0.002 - Monday 1st March 2010
-- Fixed: When multiple forums selected in AdminCP Options, threads or posts were not twittered at all

v4.0.001 - Friday 19th February 2010
-- Initial vBulletin v4.0.x Release


Thanks

Thanks go out to Buro9 who marked his original hack Re-usable Code. Thanks also go out to Dragonsys for pointing me in the right direction to converting this hack to use OAuth authentication, and also to Videx who bugged me about updating this and I have noticed is doing a lot to support this hack.


Show Your Appreciation

Although not required, if you have enjoyed the benefits of this hack, and would like show your appreciation for my efforts, then please feel free to click on the Support Developer link and donate any amount you feel is appropriate.


Donations

I would like to thank the following people for their kind donations:

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	phpinfo-curl.png
Views:	2938
Size:	6.2 KB
ID:	112588   Click image for larger version

Name:	phpinfo-json.png
Views:	2378
Size:	4.6 KB
ID:	112589   Click image for larger version

Name:	is.gd-preview.png
Views:	6409
Size:	86.2 KB
ID:	112591   Click image for larger version

Name:	tweets.png
Views:	3156
Size:	52.9 KB
ID:	122096  

Click image for larger version

Name:	admincp-options.jpg
Views:	1689
Size:	101.5 KB
ID:	126208   Click image for larger version

Name:	new_thread_3xx.png
Views:	2330
Size:	102.3 KB
ID:	126209   Click image for larger version

Name:	new_thread_4xx.png
Views:	2385
Size:	68.9 KB
ID:	126210  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Integration with vBulletin vBulletin Tweet Poster! Milad vBulletin 3.8 Add-ons 681 12 Mar 2016 22:42
Mini Mods Tweet-This (vBulletin Style) Sparrow-Sean vBulletin 4.x Template Modifications 31 27 Jul 2010 20:11

  #796  
Old 31 Mar 2014, 03:21
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Originally Posted by Reef Man View Post
Nobody??
Did you try directly contacting the person that had the trouble? I mean, assuming they didn't post the solution somewhere later (you didn't link so we couldn't look if we wanted to).

In general, it seems to me that if you properly uninstalled the mod (including deleting any uploaded files and undoing any manual template changes) then you really can't be having the error.
Reply With Quote
  #797  
Old 31 Mar 2014, 19:06
Reef Man Reef Man is offline
 
Join Date: Nov 2006
Yes, I already sent a PM. Just still waiting for an answer. I already uninstalled everything as author indicated, but error is still there.
Reply With Quote
  #798  
Old 31 Mar 2014, 19:11
Reef Man Reef Man is offline
 
Join Date: Nov 2006
Originally Posted by Videx View Post
Did you try directly contacting the person that had the trouble? I mean, assuming they didn't post the solution somewhere later (you didn't link so we couldn't look if we wanted to).

In general, it seems to me that if you properly uninstalled the mod (including deleting any uploaded files and undoing any manual template changes) then you really can't be having the error.
Maybe I lost this, but what are the templates changes involved? I dont remember change any, but maybe that could be the problem.
Reply With Quote
  #799  
Old 31 Mar 2014, 19:17
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
Originally Posted by Reef Man View Post
Maybe I lost this, but what are the templates changes involved? I dont remember change any, but maybe that could be the problem.
Hard to say. When custom styles are involved admins can edit all kinds of stuff. Try reverting some templates.?
Reply With Quote
  #800  
Old 31 Mar 2014, 19:23
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
It appears that you still have a plug in trying to use thelink shortner file bitly.php


I would upload all the files, reinstall and then uninstall again. Also go through the plug in manager to see what may be left over related to this mod.

Are you sure you removed all the files and the plug in completly? Something is calling for bitly.php still. You could probably just upload that file to get rid of the error for now until you figure it out.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #801  
Old 31 Mar 2014, 19:29
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Do you have a Twitter button or something that would use the link shortener file?

Just reupload that bitly.php file if you are unsure of what edits were done..

To verify it is a template try a default theme with no edits and see if you still get the error. If you do then it is definitely a plug in.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.


Last edited by RichieBoy67; 18 May 2014 at 16:51.
Reply With Quote
  #802  
Old 31 Mar 2014, 22:03
TheLastSuperman's Avatar
TheLastSuperman TheLastSuperman is offline
 
Join Date: Sep 2008
Real name: Michael Miller Jr
Cool

Originally Posted by Reef Man View Post
Good day,
I need help to take out an error that I am getting.

I installed this mod It was working great, but after upgrade vbulletin, it stop working, so I uninstalled, but after that, everytime I post a new topic, I am getting this error:


Can you help me to Id what is causing it as the mod was totally uninstalled?
I followed the instructions from the author to uninstall.
I touched vb support but the answer was "We do not help with modifications via the ticket support. "
We disable all the mods by the config.php, including this line:


Then the error stoped.
I already saw someone else here has the same problem and I want to know how do you solve it as this is the only mod installed in my forum that uses bit.ly.

Thanks in advance.
Originally Posted by RichieBoy67 View Post
It appears that you still have a plug in trying to use thelink shortner file bitly.php


I would upload all the files, reinstall and then uninstall again. Also go through the plug in manager to see what may be left over related to this mod.

Are you sure you removed all the files and the plug in completly? Something is calling for bitly.php still. You could probably just upload that file to get rid of the error for now until you figure it out.
That's what I was thinking... seems as if a file is no longer there and when it tries to access the file the error is produced. I suggest uploading all the mod files again as RichieBoy suggested earlier.
__________________
Daddy Does Dios and Figs!
https://www.linkedin.com/in/thelastsuperman

Search - Use the search feature to find similar issues/answers.
Information - Include screenshots, copy/pasted error codes, url etc.
Fixed - Please return to your thread/post and let us know how it was fixed!
Thanks - For participating! Click the "Like" on a post if someone helped you!
Reply With Quote
  #803  
Old 01 Apr 2014, 16:59
Reef Man Reef Man is offline
 
Join Date: Nov 2006
Originally Posted by RichieBoy67 View Post
It appears that you still have a plug in trying to use thelink shortner file bitly.php
I would upload all the files, reinstall and then uninstall again. Also go through the plug in manager to see what may be left over related to this mod.
Are you sure you removed all the files and the plug in completly? Something is calling for bitly.php still. You could probably just upload that file to get rid of the error for now until you figure it out.
Thanks. Yes I removed all the files and in the plug in manager there is no more that other plugins different.

Originally Posted by RichieBoy67 View Post
Do you have a Titter button or something that would use the link shortner file?
Just reupload that bitly.php file if you are unsure of what edits were done..

To verify it is a template try a default theme with no edits and see if you still get the error. If you do then it is definitely a plug in.
Nothing else calling bit.ly as I dont have something to publish on twitter after this mod get broke

Originally Posted by TheLastSuperman View Post
That's what I was thinking... seems as if a file is no longer there and when it tries to access the file the error is produced. I suggest uploading all the mod files again as RichieBoy suggested earlier.
I upload all again, and install plugin. Obviously does not work. Then I uninstall and take out all the files uploaded.

Error persists.

Warning: require_once(bitly.php) [function.require-once]: failed to open stream: No such file or directory in ..../newthread.php(279) : eval()'d code on line 146

Fatal error: require_once() [function.require]: Failed opening required 'bitly.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/reefman/public_html/newthread.php(279) : eval()'d code on line 146
It is inmportant to mention that this error just occur when I am trying to post a new thread, not on replies.

Any other idea?
Reply With Quote
  #804  
Old 02 Oct 2014, 03:45
cnczone cnczone is offline
 
Join Date: Mar 2003
I'm getting the same problem.
Reply With Quote
  #805  
Old 06 Jan 2015, 19:01
Marv Marv is offline
 
Join Date: Jun 2002
I am using this one on a german board and it seems, unfortunal, this mod cant handle the german special chars (, , etc). Anyone an idea?

Last edited by Marv; 13 Jan 2015 at 18:14.
Reply With Quote
  #806  
Old 13 Jan 2015, 18:26
Marv Marv is offline
 
Join Date: Jun 2002
Question 14:
Threads with titles that have special characters in them (such as ) do not tweet, what do I do?
Answer:
Sorry, but it looks like an issue with the Twitter (OAuth) class file by Abraham Williams and not with this hack at all.

I have checked his bug tracker and this issue has been reported twice and has not been fixed yet by the author, please see:You might want to reply to both of the bug reports to see if you can get the author to fix his Twitter class any quicker.
Since the coder of the mentioned OAuth class stated last week, this issue wouldnt be reproducable anymore with the current codebase - is anyone willing and able to fix this issue in this tweet mod? I would if I could, but that goes over my head.
Reply With Quote
  #807  
Old 11 Nov 2015, 11:45
PleaseHelp PleaseHelp is offline
 
Join Date: Jan 2012
Amazing Mod that is very simple to use and works very well.

One issue: this Mod uses the bit.ly API Key which is being deprecated in favor of OAuth.

Are there any plans to update this Mod to use OAuth with bit.ly so that when they cease to accept the API Key, it will still work?
Reply With Quote
  #808  
Old 09 Dec 2015, 01:53
trollshrooms's Avatar
trollshrooms trollshrooms is offline
 
Join Date: Sep 2011
I would like to know if there is plans to update the mod aswell.
For OAuth, and Adfly support.
__________________
vBulletinWarcraft is lyfe.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:34.

Layout Options | Width: Wide Color: