Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Picture and Album Gallery Details »
Picture and Album Gallery
Mod Version: 1.09, by HCGB (Coder) HCGB is offline
Developer Last Online: Oct 2012 I like it Show Printable Version Email this Page

vB Version: 4.1.0 Rating: (162 votes - 4.85 average) Installs: 1360
Released: 10 Mar 2010 Last Update: 12 Jan 2011 Downloads: 7814
Not Supported Uses Plugins Auto-Template Additional Files Re-usable Code Translations  

Picture and Album Gallery for vB4


This is a simple mod written out of frustration with the lack of such a basic feature in vb4 (and vb3, etc....)

Features:
Adds a Gallery drop-down menu to the nav bar OR to the navtab which allows browsing AND searching of all pictures and albums on your site.

The search function searches the album title, album description, picture caption AND username.

Note: If guest permission AdminCP->Usergroups->UserGroup Manager->Unregistered/Not Logged In->Can View Albums is "yes" then they will be able to browse album and picture thumbnails - they may NOT be able to view the full-size pictures. To hide the gallery menu from guest see Settings below.

The gallery and menu is phrased.

Tested with Vbulletin 4.0.2/3 (note: earlier versions have not been tested and are not supported) AND vBadvanced 4 beta1.

Settings:
None are needed - it does what it says on the tin .

AdminCP->Options->User Profile:Album Options "Pictures Per Page" and "Albums Per Page" control the number of thumbnails displayed per page in each gallery type.

If you get images overlapping the borders then you have inconsistent thumbnail sizes - you need to:
AdminCP->Maintenance->Update Counters->Rebuild Attachment Thumbnails

If you want to hide the Gallery menu from guests then edit the Gallery navbar (or navtab) popup menu plugin and change $allowguests = from true to false

Installation
  1. Unzip the download package and copy the contents of the UPLOAD folder into your forum folder.
  2. Go to the VB AdminCP->Plugins & Products click "Manage Products". The click "Add/ImportProduct" at the bottom of the page.
  3. Click "Browse" button and point to the product-gallery-(etc).XML file included in this ZIP package.
  4. Click "Import"
  5. Once the gallery import is complete, click "Add/Import Product" again and select EITHER product_gallery_navtab-xxx.xml OR product_gallery_navbar-xxx.xml depending on where you want the gallery menu to appear (navbar or navtab).
... all done

Updates

To update from an older version you MUST uninstall the product (admincp->manage products: delete Picture and Album Gallery). Then re-install as above.

v1.08
tested on vb4.0.3
v1.07
Fixed navtab menu - picture and album URLS swapped

Converted navtab/bar into products to make installation easier.
v1.06
Due to popular demand added navtab drop down menu (with help from
TimberFloorAu )
Cleaned up code and templates
v1.05
Phrased menu items - upgrade is not required unless you use other languages.

v1.04b
fixed database connection issue

deleted unused template from product xml
v1.03b
Changed permissions to allow guests to view thumbnail galleries

Added phrasing for main gallery code.
Removed navbar template - replaced by plug-in code
Changed album display template from albumbit to album_latestbit (it works better!)
Various template mods to clean up display
v1.02b
Wasn't remembering search query between pages.


This is my first "proper" product so comment/criticism/etc is welcome

John

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	albs.jpg
Views:	20192
Size:	86.0 KB
ID:	113797  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Social Group and Album Enhancements Album Picture Clicks to Next Picture in Album Abe1 vBulletin 3.7 Template Modifications 24 15 Mar 2011 03:45

  #796  
Old 31 Mar 2014, 19:32
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
Thanks for the reply mate.

No Vbseo installed and yes I tried disabling all the mods in the config.. no dice. I completely removed this mod and reinstalled as well.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #797  
Old 31 Mar 2014, 22:06
Videx's Avatar
Videx Videx is offline
 
Join Date: Feb 2007
My last guess would be some obscure server permission error. If it's a hosted server, contact your host. I think in the latest version of vb you can get full error reporting to come back on and maybe that will give you a clue.
Reply With Quote
  #798  
Old 31 Mar 2014, 22:15
RichieBoy67's Avatar
RichieBoy67 RichieBoy67 is offline
 
Join Date: Apr 2004
Real name: Richie
I have a dedicated server. I have tried a couple things there but have tested albums on another Vbulletin forum I host and they work fine there on ie.

I am certain this is something simple I am over looking. I am going to enable the errors though to see what is going on but I see nothing in error logs out of the ordinary.
__________________

Let us take care of your forum, seo, seo reports, maintenance, what ever you need.

Reply With Quote
  #799  
Old 12 Apr 2014, 06:58
K4GAP K4GAP is offline
 
Join Date: Mar 2008
Works great on 4.2.2 right out of the box.
__________________

Reply With Quote
  #800  
Old 09 Jun 2014, 16:36
SoHelpMe SoHelpMe is offline
 
Join Date: Apr 2014
[QUOTE=VertoPB;2452551]Hi,

Second step:
Create a new menu in the navbar: AdminCP->Options->Navigation Manager->Forum->Add menu / Title: Gallery - Show Permission Name: member (or leave this field empty if you want anyone, registered or not, can see it)

---I am trying to follow the instructions from VertoPB above from page 52 of this topic and my vB 4.2.2 is insisting on having a URL entry for this Gallery menu/tab item. How do I get past this?

Last edited by SoHelpMe; 09 Jun 2014 at 16:41.
Reply With Quote
  #801  
Old 11 Jun 2014, 23:30
addamroy addamroy is offline
 
Join Date: Sep 2010
I was all disappointed when I realized this only displays pictures from albums, and doesn't display attachment images from posts

Why is this? Will this ever be a feature?
__________________
Amazing Post-bit Legacy Hacks HERE http://www.vbulletin.org/forum/membe...ort=date#hacks
Reply With Quote
  #802  
Old 10 Dec 2014, 18:50
concepts's Avatar
concepts concepts is offline
 
Join Date: May 2005
Real name: Jamale
Amazing Work!
__________________

Achieving Superior Aesthetic Conditioning
Reply With Quote
  #803  
Old 09 Jan 2015, 17:30
BirdOPrey5's Avatar
BirdOPrey5 BirdOPrey5 is offline
 
Join Date: Jun 2008
Real name: Joe D.
Has anyone ever made a mobile template for this?
__________________
-Joe
Former vb.org Moderator. Retired.

@BirdOPrey5 | All Things BOP5 | Joe's Ultimate Off Topic
Note - I no longer making new VB mods, sorry.
Reply With Quote
  #804  
Old 16 Feb 2015, 03:02
hurricane_sh hurricane_sh is offline
 
Join Date: Oct 2004
This plugin seems to cause this problem: http://www.vbulletin.com/forum/forum...=1424058722134
Reply With Quote
  #805  
Old 18 Feb 2015, 17:29
Toorak Times's Avatar
Toorak Times Toorak Times is offline
 
Join Date: Jan 2011
Hi guys, this won't let me upgrade from 108 to 109, any ideas anyone?
Reply With Quote
  #806  
Old 10 Mar 2015, 19:04
djcaseanova djcaseanova is offline
 
Join Date: Apr 2006
LOL Any chance this would work on vB5 ????
Reply With Quote
  #807  
Old 25 Mar 2015, 15:40
htscpl's Avatar
htscpl htscpl is offline
 
Join Date: Sep 2003
Location: Houston
Real name: Henry
Question

Just installed this product a few days ago yeah, slow on the upgrade , anyway, seemed to work ok but then at the top of my album page started getting this warning:
Warning: Only variables should be assigned by reference in ..../album.php on line 1871

Searched this thread but didn't find the answer or missed it (sorry for that) if someone can point me in the right direction or help out many thanks!
Reply With Quote
  #808  
Old 18 Aug 2015, 17:22
eboggs_jkvl eboggs_jkvl is offline
 
Join Date: Feb 2005
I installed the latest version on my 4.2.3 Suite.

It says it installed in the admin cp but I see no tab appearing on my cms or my forum.

I do see the product in my Navigation Manager and it says it is active but no tab appears on the top of the CMS/Forum screens.

Does this product work on 4.2.3 Suite?

Of course there is the ever obvious old man doing something stupid possibility but let's not go there!

Elmer

Last edited by eboggs_jkvl; 18 Aug 2015 at 21:08.
Reply With Quote
  #809  
Old 06 Oct 2015, 09:12
friendlymela's Avatar
friendlymela friendlymela is offline
 
Join Date: Dec 2012
Real name: Zeeshan Shams
good one
Reply With Quote
  #810  
Old 13 Feb 2016, 02:25
gmhoward gmhoward is offline
 
Join Date: Mar 2008
Originally Posted by eboggs_jkvl View Post
I installed the latest version on my 4.2.3 Suite.

It says it installed in the admin cp but I see no tab appearing on my cms or my forum.

I do see the product in my Navigation Manager and it says it is active but no tab appears on the top of the CMS/Forum screens.

Does this product work on 4.2.3 Suite?

Of course there is the ever obvious old man doing something stupid possibility but let's not go there!

Elmer
You will need to make a link in the Navigation Manager of the AdminCP

AdminCP > Settings > Navigation Manager

Add a link and call it whatever you wish, such as albums

Mine looks like this:

http://www.fooguild.com/forums/albumall.php?=>blank;6 2 10 18 15

I believe those numbers are the usergroups which have access.

It's been a while since I have messed with this so I hope it helps.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:58.

Layout Options | Width: Wide Color: