Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 10 Apr 2014, 05:20
The_Hawk The_Hawk is offline
 
Join Date: Aug 2009
Thread Title Restrictions

Is there anyway to stop a user using particular characters in a thread title?

In my case use of the % sign causes my dbseo friendly names to end with a bad link and result in an error:

Bad Request

Your browser sent a request that this server could not understand.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Reply With Quote
  #2  
Old 10 Apr 2014, 09:21
bzcomputers's Avatar
bzcomputers bzcomputers is offline
 
Join Date: Apr 2012
Originally Posted by The_Hawk View Post
Is there anyway to stop a user using particular characters in a thread title?

In my case use of the % sign causes my dbseo friendly names to end with a bad link and result in an error:
You just need to fix your DBSEO settings. The "%" symbol will not break links if it is setup correctly.

Without seeing your settings I can't tell you exactly what is wrong with your current settings, but I suggest you post this issue you are having in the DBSEO mod page here ob vB.org or on DragonByte's website (if you want the fastest service).
Reply With Quote
  #3  
Old 10 Apr 2014, 10:53
The_Hawk The_Hawk is offline
 
Join Date: Aug 2009
I posted over there too figuring either option would be fine.

I've taken your advice and looked a little close and I've tried adding in this under the "Custom Character Filter" for dbSEO which appears to work alright. Just wondering if this is the best solution or not??

% => percent


For reference, there is no other character filters at the moment (should there be?)
Reply With Quote
  #4  
Old 10 Apr 2014, 11:21
bzcomputers's Avatar
bzcomputers bzcomputers is offline
 
Join Date: Apr 2012
Originally Posted by The_Hawk View Post
I posted over there too figuring either option would be fine.

I've taken your advice and looked a little close and I've tried adding in this under the "Custom Character Filter" for dbSEO which appears to work alright. Just wondering if this is the best solution or not??

% => percent


For reference, there is no other character filters at the moment (should there be?)
No, on a default install there won't be any there.

What do you have for the setting right above the custom character filters - "Filter Non-Latin Characters"?
Reply With Quote
  #5  
Old 11 Apr 2014, 00:01
The_Hawk The_Hawk is offline
 
Join Date: Aug 2009
For reference, this install was an upgrade from vbSEO so I have used the import settings function.

In any case, that setting is currently on "Keep Non-Latin Characters".
Reply With Quote
  #6  
Old 11 Apr 2014, 04:17
bzcomputers's Avatar
bzcomputers bzcomputers is offline
 
Join Date: Apr 2012
Originally Posted by The_Hawk View Post
For reference, this install was an upgrade from vbSEO so I have used the import settings function.

In any case, that setting is currently on "Keep Non-Latin Characters".
I also previously ran vbSEO.

I think you'll find either of the other two options for this setting:

2) Remove Non-Latin Characters
or
3) Replace Non-Latin Characters

will also fix your issue.
Reply With Quote
  #7  
Old 11 Apr 2014, 05:15
The_Hawk The_Hawk is offline
 
Join Date: Aug 2009
I'm sure this is a rare occurrence so the impact of any changes would be minimal, but the question is how did vbSEO handle this?

The idea being to match the friendly URL that vbSEO would have used to ensure any links out int he wild would continue to work... but like I said, it would be a rarity so it's not a huge issue.
Reply With Quote
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Remove thread title in navbits if you have large thread title installed VietSoil vBulletin 2.x Full Releases 17 30 Oct 2002 02:07



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 08:30.

Layout Options | Width: Wide Color: