Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 19 Jun 2018, 09:38
Inna Inna is offline
 
Join Date: Jul 2016
Anything wrong with my functions?

Hello, do you see anything wrong or modified in my functions.php?
My client forum is no running 4.2.1 and asked me to upgrade to 4.2.5.
I've done everything normally, but when I upload and replace all of 4.2.5 files, some characters are removed from the forum.
For example, "Welcome to this forum, you may send reply" changes to "Wecme o his fru, yu ay sed rely"
Up to this step, I did not run upgrade script, and only I've uploaded and replaced files.
I revert changes to the last status.
Another time I did upload and replace each file individually to see why this happens.
I figured out /includes/functions.php is having issue.
Although I uploaded the latest vb version from member's area, I'm not sure why it behaves likes this.
Would you please check it out?
Also class_core.php, init.php and function.php of includes folder should have the same version.
All are attached.
Regards
Attached Files
File Type: php class_core.php (147.1 KB, 0 views)
File Type: php functions.php (241.0 KB, 0 views)
File Type: php init.php (24.4 KB, 0 views)
Reply With Quote
  #2  
Old 19 Jun 2018, 11:24
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
1. If you upload the 4.2.5 files but don't run the upgrade script, I'm not surprised you might encounter some problems. Not sure why you would want to do this.

2. What version of PHP is this site running?
Reply With Quote
  #3  
Old 19 Jun 2018, 12:34
Inna Inna is offline
 
Join Date: Jul 2016
That's why I asked.
There's no matter whether I run the upgrade or not run, it just removes some letters.
Even when the upgrade is completed and I increase PHP version, still the problem exists.
Now I'm running PHP version 5.3 and due to this matter I want to upgrade.
Reply With Quote
  #4  
Old 19 Jun 2018, 12:43
djbaxter djbaxter is offline
 
Join Date: Aug 2006
Location: Ottawa, Canada
I believe vBulletin 4.2.5 requires a minimum of PHP 5.6 so you will need to upgrade.

I suggest you

* upgrade to PHP 5.6 or 7.1
* re-download vBulletin 4.2.5
* upload a fresh copy of all the 4.2.5 files to your server
* run the upgrade
* if you still have problems, post at https://www.vbulletin.com/forum/foru...roubleshooting for support
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:51.

Layout Options | Width: Wide Color: