Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Attachmentstyle, choose where to place your Attachments Details »
Attachmentstyle, choose where to place your Attachments
Mod Version: 1.00, by MrNase (Member) MrNase is offline
Developer Last Online: Sep 2010 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.0.3 Rating: (0 vote - 0 average) Installs: 13
Released: 03 Oct 2004 Last Update: Never Downloads: 3
Not Supported Is in Beta Stage  

Hello,

Some of you have used eBay before. On every auction you can select where the pictures you have uploaded should be displayed.
Since many of us use the vB attachment function to publish pictures there should be the possibility of doing exactly the same thing with your attachments.

This hack allows you (and your users) to select wether the attachments should be displayed:

* At the end of your posting (vB3 default setting)
* Above your posting
* At the left hand side of your posting

This hack is using phrases so it's very easy to translate.
The setting can be changed for every post so you can decide which one is the best for your attachments.

Why is this hack 'beta'?
Well, it works.. But is has only been tested by me
It has no installer yet and the markup could be a bit better but I hope you'll help me with that.

Is there an Online Demo?
No I don't think so but I'll provide you with screenshots


Have fun with it and please help me fixing errors so that this hack can be moved to 'Full Releases' as soon as possible


THIS HACK IS BETA..! PLEASE BACKUP YOUR DATABASE :devious:



Changes:
* Instructions are updated to v.02 and nexialys' Fix is in. Thank you
* Instructions are updated again and the current version is V0.3

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	screenshot1.jpg
Views:	340
Size:	57.4 KB
ID:	20982   Click image for larger version

Name:	screenshot2.jpg
Views:	377
Size:	76.1 KB
ID:	20983   Click image for larger version

Name:	screenshot3.jpg
Views:	304
Size:	54.5 KB
ID:	20984   Click image for larger version

Name:	screenshot4.jpg
Views:	335
Size:	63.6 KB
ID:	20985  

Click image for larger version

Name:	screenshot5.jpg
Views:	312
Size:	39.6 KB
ID:	20986  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Comments
  #2  
Old 03 Oct 2004, 22:15
Natch's Avatar
Natch Natch is offline
 
Join Date: Nov 2002
This is a very good idea: well structured...

Nice job!
__________________
Natcher00
... is the Admin @ MobileForces.org - Official Community for a cult Vehicle based FPS - the only place for support!
... also he's Penfold to Dark_Wizard's Danger Mouse in development of vBWar
http://www.mobileforces.org/sig.jpg
{DaniWeb: Learn HOW-TO mod_rewrite your vB board}
Reply With Quote
  #3  
Old 03 Oct 2004, 23:31
Bryan Ex's Avatar
Bryan Ex Bryan Ex is offline
 
Join Date: Feb 2004
Location: Canada
I was anoyed by that exact issue just last night. Right on!
Reply With Quote
  #4  
Old 03 Oct 2004, 23:33
nexialys
Guest
 
@Mr Nase.. the default language id is not 0, but -1...

so it is
Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #5  
Old 03 Oct 2004, 23:39
FleaBag's Avatar
FleaBag FleaBag is offline
 
Join Date: Dec 2001
This is awesome - when I finally upgrade I'll install!
Reply With Quote
  #6  
Old 04 Oct 2004, 05:47
MrNase's Avatar
MrNase MrNase is offline
 
Join Date: May 2003
Real name: Dominik
Thank you nexialys, I updated the instructions.
Reply With Quote
  #7  
Old 05 Oct 2004, 18:25
jugo jugo is offline
 
Join Date: Feb 2004
Beautiful!!!

/me Installs and does a backflip.
__________________
NovaWarfare.com - Bringing back the Game - http://www.NovaWarfare.com

Website Hosting - Game Server Hosting - http://www.freaks-network.com
Teamspeak Status Block for vBAdvanced / PHP-Nuke / php Include

PM me if you need hacks installed or simple template modifications...I'm cheap..
Reply With Quote
  #8  
Old 11 Oct 2004, 17:48
NuclioN's Avatar
NuclioN NuclioN is offline
 
Join Date: Aug 2002
This error after a new post:

Invalid SQL:
INSERT INTO thread(title, lastpost, forumid, open, replycount, postusername, postuserid, lastposter, dateline,
iconid, visible, attach, attachstyle, similar)
VALUES
('test334', 1097513223, 22,
1, 0, 'name', 1,
'name', 1097513223, 0, 1,
1, '')

mysql error: Column count doesn't match value count at row 1
Reply With Quote
  #9  
Old 12 Oct 2004, 14:41
MrNase's Avatar
MrNase MrNase is offline
 
Join Date: May 2003
Real name: Dominik
Are you sure you made the database modification?

You need to do that by using the following query:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

And (important!!):
You may have to replace post with vb3_post or something like that according to the database prefix you have chosen during the installation.
Reply With Quote
  #10  
Old 12 Oct 2004, 14:43
NuclioN's Avatar
NuclioN NuclioN is offline
 
Join Date: Aug 2002
Yes, the db modifications are correct. Also i've no prefix for the tables.

In editpost.php there are 2 lines of this code:
attach = attach + $newattachments

The first one is for 'UPDATE " . TABLE_PREFIX . "thread SET..'

The second one is in here:

UPDATE " . TABLE_PREFIX . "post
SET title = '" . addslashes(htmlspecialchars_uni($edit['title'])) . "',
pagetext = '" . addslashes($edit['message']) . "',
allowsmilie = $edit[allowsmilie],
showsignature = $edit[signature],
iconid = $edit[iconid],
attach = attach + $newattachments
WHERE postid = $postid
");

Last edited by NuclioN; 12 Oct 2004 at 14:47.
Reply With Quote
  #11  
Old 12 Oct 2004, 14:50
MrNase's Avatar
MrNase MrNase is offline
 
Join Date: May 2003
Real name: Dominik
Well ok, give me a couple of minutes. Iam rewriting the instructions


The Instructions are up-to-date. You should read them again, I changed the lines for functions_newpost.php and editpost.php and now it should work for you.
You are right, you need to replace the second one both in editpost.php and functions_newpost.php (where it says: INSERT INTO " . TABLE_PREFIX . "post and not INSERT INTO " . TABLE_PREFIX . "thread)

Excuse me, I thought nobody would edit the files with a simple texteditor which has no numbered lines

Last edited by MrNase; 12 Oct 2004 at 15:01.
Reply With Quote
  #12  
Old 12 Oct 2004, 15:28
NuclioN's Avatar
NuclioN NuclioN is offline
 
Join Date: Aug 2002
Ok tnx I'll try it and report asap
Reply With Quote
  #13  
Old 12 Oct 2004, 15:32
xug xug is offline
 
Join Date: Oct 2001
Real name: KCi
Very cool job :thumbsup:
Reply With Quote
  #14  
Old 12 Oct 2004, 15:42
NuclioN's Avatar
NuclioN NuclioN is offline
 
Join Date: Aug 2002
Hm..same errors remain in new post and reply ..
Reply With Quote
  #15  
Old 12 Oct 2004, 20:00
MrNase's Avatar
MrNase MrNase is offline
 
Join Date: May 2003
Real name: Dominik
Well I checked the instructions twice and I couldn't find any error. The others didn't say it doesn't work so I don't know what has gone wrong with your installations.

Do you have a backup of editpost.php and functions_newpost.php? Take the old files and modify them again to make sure you have the right code. You could even send those files to me and I'll take a look at it. Use dienase [at] gmail.com please
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:31.

Layout Options | Width: Wide Color: