Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 09 Dec 2018, 16:56
w00fy w00fy is offline
 
Join Date: May 2011
SSL problem

Hello,

I am running 4.2.2 Apache v2.4.25 and my host installed an ssl certificate for me yesterday on my vps it look like that part is okay, https://www.sslshopper.com/ssl-check...e=legitfta.com

Reading the posts I changed the forum url and rebuilt styles, it seems the css go missing as soon as I change the url to https, once I change back to http the forum is normal.

Please see the screen captures and let me know if anyone can point me in the right direction on how to solve this please.

Thanks
Attached Images
File Type: jpg LegitFTA_-_2018-12-09_09.24.10.jpg (24.6 KB, 14 views)
File Type: jpg LegitFTA_-_2018-12-09_09.27.50.jpg (8.2 KB, 5 views)
Reply With Quote
  #2  
Old 09 Dec 2018, 17:06
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
If your storing your css as files (Store CSS Stylesheets as Files?), change to ssl, remove the files from ftp vbulletin_css, disable the storage option in vb admincp & save, then re-enable that option & save.
Reply With Quote
  #3  
Old 09 Dec 2018, 17:45
w00fy w00fy is offline
 
Join Date: May 2011
Hi,

Yes they are stored as files, how do I change to ssl?

disable the storage option in vb admincp & save? not sure I understand this part?

Sorry very novice at this.
Reply With Quote
  #4  
Old 09 Dec 2018, 20:23
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
If they are stored as files, disable that option in the admincp.

FTP into server & go to clienscript/vbulletin_css & delete all the files that start with *style*

set your forum URL to https & save

Enable the css styles as files option & save
Reply With Quote
  #5  
Old 10 Dec 2018, 11:25
w00fy w00fy is offline
 
Join Date: May 2011
Thank you,

There are folders and files that start with style, do I delete all?
Attached Images
File Type: png Screenshot from 2018-12-10 04-22-01.png (71.1 KB, 9 views)
Reply With Quote
  #6  
Old 10 Dec 2018, 15:27
z3r0's Avatar
z3r0 z3r0 is offline
 
Join Date: Apr 2005
Location: Lancashire, UK
I've just looked at your site and checked the F12 tools console while loading it over https and the main issue seems to be that your all the stuff loaded from your clientscript folder is being blocked because it is being loaded from http rather than https.

You could try a quick fix of adding a new replacement variable to your skin.

replacement1.png
__________________
Better VB.org search
Reply With Quote
  #7  
Old 10 Dec 2018, 22:17
w00fy w00fy is offline
 
Join Date: May 2011
Thank you
z3r0,

I did try that before and checked it again, when I do this the site will load but not fully, Most Popular Forums will just say loading shoutbox the same, and still not secure.
Reply With Quote
  #8  
Old 10 Dec 2018, 23:30
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
delete all of them named style
Reply With Quote
  #9  
Old 11 Dec 2018, 07:44
z3r0's Avatar
z3r0 z3r0 is offline
 
Join Date: Apr 2005
Location: Lancashire, UK
Originally Posted by w00fy View Post
Thank you
z3r0,

I did try that before and checked it again, when I do this the site will load but not fully, Most Popular Forums will just say loading shoutbox the same, and still not secure.
I see it's mostly loading now, but there is still a few mixed content errors in the console, mainly e365mods/holiday/font/wwflakes.ttf - If you know what that is either edit it to be https or turn it off (snowflake mod?)

As soon as you can get rid of the mixed content errors the site will show secure.

Also, your site is in the forum directory however you have a lot of 404's in the console as some images are being referenced from the root of your domain.
__________________
Better VB.org search
Reply With Quote
  #10  
Old 11 Dec 2018, 23:20
w00fy w00fy is offline
 
Join Date: May 2011
I appreciate you time and thank you.

I disabled the e365 plugin, basically my xmas lights for the forum, and the site is now showing green bar and secure on most major browsers,

I would like to use those xmas lights as my members like them,

Any idea where I might find the location to change the url to https if it's that simple.

And thank you for joining my site I seen you at 4am Calgary time just before heading off for work.

Any other tips would be appreciated.

Rob
Reply With Quote
  #11  
Old 12 Dec 2018, 08:01
z3r0's Avatar
z3r0 z3r0 is offline
 
Join Date: Apr 2005
Location: Lancashire, UK
I see it's looking much better now, if you have a link to the e365 mod I'll have a look at the code and see where to fix it.

I would also add the following to your headerincludes template, it will allow modern browsers to update insecure requests (http to https) wherever it can.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Better VB.org search
Reply With Quote
  #12  
Old 12 Dec 2018, 10:44
w00fy w00fy is offline
 
Join Date: May 2011
Looks like it's in the graveyard now.
https://www.vbulletin.org/forum/show...hlight=holiday
Reply With Quote
  #13  
Old 12 Dec 2018, 13:20
z3r0's Avatar
z3r0 z3r0 is offline
 
Join Date: Apr 2005
Location: Lancashire, UK
In that case, have a search of your templates for wwflakes.ttf and if found update the url it's on, I do think though that it will be in a plugin so you'll need to look through the e365 mod plugin's and edit the containing url accordingly.
__________________
Better VB.org search
Reply With Quote
  #14  
Old 12 Dec 2018, 22:28
w00fy w00fy is offline
 
Join Date: May 2011
Thanks again,

I found the zip on my pc..hope it's okay to upload here.
Attached Files
File Type: zip e360 holiday 2.0.2.zip (1.75 MB, 2 views)
Reply With Quote
  #15  
Old 13 Dec 2018, 09:38
z3r0's Avatar
z3r0 z3r0 is offline
 
Join Date: Apr 2005
Location: Lancashire, UK
I've scanned through the files and there is no direct http reference to the file that was causing the mixed content message.

Have you updated the forum url in your admincp options to https? if not it could be pulling it in from there.
__________________
Better VB.org search
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:34.

Layout Options | Width: Wide Color: