Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Change Author And Creation Date Of Posts And Articles Details »
Change Author And Creation Date Of Posts And Articles
Mod Version: 3.0.3, by Yellow Slider (Member) Yellow Slider is offline
Developer Last Online: Sep 2013 I like it Show Printable Version Email this Page

This thread is in the Modification Graveyard.
vB Version: 4.1.10 Rating: (56 votes - 4.64 average) Installs: 444
Released: 29 Apr 2010 Last Update: 30 Jun 2013 Downloads: 2296
Not Supported Uses Plugins Auto-Template Translations  

Info:
This modification lets you change the author of posts and articles.
In addition, it lets you change the creation date of posts.
The option to change the author appears in:
- Post New Thread.
- Post New Reply.
- (Advanced) Edit Thread/Post.
- Create/Edit Article.

The option to change the creation date of a post appears in:
- (Advanced) Edit Post.

Requirements:
The CMS part of this mod requires vB 4.1.10+.


Installation & Settings:
Installation takes about 1-2 minutes.
You can set which usergroups are allowed to use the feature via the ACP.

Version History:
1.0 29.04.2010: Initial release.
2.0 12.05.2010: Added ability to change creation date of posts.
2.1 05.06.2010: The mod now automatically updates forum and thread counters.
2.2 03.05.2011 CMS integration has been removed and will be restored in the future. No template edits needed and the fields have been improved. Also fixed some special characters issues, it should now word flawlessly.
3.0 27.05.2012 CMS integration has been restored.
3.0.1 27.05.2012 Fixed incorrect time in posts.
3.0.2 27.05.2012 Fixed time offset issue.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	1.PNG
Views:	1996
Size:	28.4 KB
ID:	128759   Click image for larger version

Name:	2.PNG
Views:	2185
Size:	35.7 KB
ID:	128760  

Show Your Support

  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #31  
Old 14 May 2010, 22:38
elmstr elmstr is offline
 
Join Date: Dec 2004
Thanks for the update! Installed and working fine.

The Plug-in shows still V 1.0 (from the new XML)...
Reply With Quote
  #32  
Old 16 May 2010, 15:07
darkobg darkobg is offline
 
Join Date: Nov 2006
Thank youuuuuuuuuuuuuuu
Reply With Quote
  #33  
Old 19 May 2010, 03:23
FReeSTER FReeSTER is offline
 
Join Date: Jun 2006
thank you for tthe upgrade but can you please add the changing time and date in new threads and replies.

Thank you very much
Reply With Quote
  #34  
Old 19 May 2010, 04:44
chipc0i chipc0i is offline
 
Join Date: May 2008
how change many threads' author in same times?

Last edited by chipc0i; 19 May 2010 at 06:11.
Reply With Quote
  #35  
Old 21 May 2010, 07:10
asuccar asuccar is offline
 
Join Date: Dec 2009
Can you please help...

I installed everything exactly as your instructions indicate (i've quadruple checked everything)...when i create an article the author field does appear and I select 'display author' but BUT when i save the article the author still shows up with my username.

Can you suggest anything?
Reply With Quote
  #36  
Old 21 May 2010, 09:09
rmd708 rmd708 is offline
 
Join Date: Feb 2006
I installed everything exactly as your instructions indicate (i've quadruple checked everything)...when i create an article the author field does appear and I select 'display author' but BUT when i save the article the author still shows up with my username.
The author name must exist in the user database.
Reply With Quote
  #37  
Old 21 May 2010, 17:13
Budget101 Budget101 is offline
 
Join Date: Jul 2008
Originally Posted by asuccar View Post
Can you please help...

I installed everything exactly as your instructions indicate (i've quadruple checked everything)...when i create an article the author field does appear and I select 'display author' but BUT when i save the article the author still shows up with my username.
I also had this issue-

check your permissions settings- does the username your trying to use have "permission" to post an Article . . .

changing the permissions for that group worked for me. GL
Reply With Quote
  #38  
Old 22 May 2010, 00:45
asuccar asuccar is offline
 
Join Date: Dec 2009
I checked all my permissions...ok.

For the articles, can't i just add any name?
Reply With Quote
  #39  
Old 22 May 2010, 04:04
ArchAngelz ArchAngelz is offline
 
Join Date: May 2010
Quite strange, when I download and install the product, it shows as v1.0
Reply With Quote
  #40  
Old 22 May 2010, 04:14
ArchAngelz ArchAngelz is offline
 
Join Date: May 2010
I've tried this out and it seems that making posts in the name of another person does NOT give that other person the post count of the post just created; is this intended or is it a bug?
Reply With Quote
  #41  
Old 25 May 2010, 14:25
sportsfroma2 sportsfroma2 is offline
 
Join Date: Aug 2006
Thanks for this!

stupid Question- If I only wanted the ability to change the author of the articles for the CMS (my Impex Port left some authors blank), I only need to do that template edit, right?

Thanks!
Reply With Quote
  #42  
Old 25 May 2010, 15:38
sportsfroma2 sportsfroma2 is offline
 
Join Date: Aug 2006
darn it wouldn't work for me in the CMS the field is there, I enter my own username (I'm an admin, have all the rights for the CMS and stuff), but it doesn't stay when I save/apply
Reply With Quote
  #43  
Old 25 May 2010, 15:42
sportsfroma2 sportsfroma2 is offline
 
Join Date: Aug 2006
oh and PS- the product identifies itself as version 1.0, not 2.0
Reply With Quote
  #44  
Old 26 May 2010, 17:51
ispots ispots is offline
 
Join Date: Nov 2007
Does anyone else have an issue where the edited time vs the posted time are off by a few hours??

Date (mm/dd/yyyy): 5 / 26 / 2010
Time (hh/mm/ss): 10 : 38 : 20
Message originally posted by LagunaBlue on 05-26-2010 at 01:38 PM:
Reply With Quote
  #45  
Old 27 May 2010, 03:56
vilhiem vilhiem is offline
 
Join Date: May 2010
Will this work on the Forums ... or only on CMS pages ...?

Thanks!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:30.

Layout Options | Width: Wide Color: