Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
[AJAX] Helpful Answers - Allow users to rate individual posts Details »
[AJAX] Helpful Answers - Allow users to rate individual posts
Mod Version: 2.4.2, by Ted S (Coder) Ted S is offline
Developer Last Online: Dec 2016 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (63 votes - 4.78 average) Installs: 589
Released: 16 Jan 2010 Last Update: 12 Aug 2012 Downloads: 3831
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

Helpful Answers has been used to record over 6 MILLION times on more than 2,000 forums. If you're not using HA your users are looking for it!

Every day your users contribute hundreds if not thousands of posts making it hard for new members and guests to separate out the best answers from those that are less helpful. The Helpful Answers System offers your members a quick way
to rate individual posts as either helpful or not allowing future visitors to understand the value of each post.

Designed to be flexible, HA has over 30 configurable settings:
  • Use image or text ratings AJAX or traditional links.
  • Offer yes/no or scaled 1-10 point ranking.
  • Turn off negative ratings for a positive only system.
  • Decide which forums are open for helpful answer ratings.
  • Audit the system and identify top users and potential abusers.
  • Ban specific members from using the system.
  • Customize the message shown after a post is rated.
  • Show a page with the top helpful posts.
  • Show rating stats on a user's profile.
  • Hide posts that rate "too low"
  • Template driven so you can customize it all for your forum.
For advanced users template conditionals and variables let you further extend the functionality to color highlight good or bad posts, include ratings in userís profiles and much more.

Modification Installation [Must Read]:


Step 1: Upload the addon files found in the upload/ folder to your forum directory
Step 2: Install the plugin through your vB Administration area
Step 3: Configure settings & enable the mod in individual forums


You must configure settings & enable forums before voting will show up.

Anonymous Stats Tracking (optional):

By default this addon will pass basic rating data (positive or negative) to a 3rd party site for statistical purposes. Only the most basic data is captured (the vote and your site name) and no user information or specific forum details are logged, not even an IP address. You can disable this through the admin.


Mod Philosophy -- Drive Your Own Success:

All of my mods are inspired by my work in digital marketing and are designed to drive registrations, interaction or other engagement activities the core platform does not address.

Each is designed to fit a general need by providing a starting point but it's on you to decide how to make things work to their best possible outcome. Feel free to suggest what you'd like to see next but don't wait to have what everyone else has; figure out what your forum needs and customize away.

Download Now

Only licensed members can download files, Click Here for more information.

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	1-16-2010 1-11-43 PM.jpg
Views:	12437
Size:	41.6 KB
ID:	110159   Click image for larger version

Name:	admin-stats1.gif
Views:	8437
Size:	15.5 KB
ID:	110160   Click image for larger version

Name:	admin-stats2.gif
Views:	6905
Size:	11.3 KB
ID:	110161  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases [AJAX] Helpful Answers - Post Rating System (plus many sub-features) Ted S vBulletin 3.8 Add-ons 1801 02 May 2016 09:34
Add-On Releases [AJAX] Helpful Answers - Allow users to rate individual posts Ted S vBulletin 3.7 Add-ons 196 19 Oct 2010 05:17

  #496  
Old 13 Jul 2010, 02:03
Ted S Ted S is offline
 
Join Date: Dec 2003
For those members having issues on 4.0.4 please try the attached XML file and let me know if this resolves your issues while still holding all of the functionality you expect from this mod.

Thank you!
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #497  
Old 13 Jul 2010, 08:26
linuxututs linuxututs is offline
 
Join Date: Oct 2009
Thanks Mate,

Upgrade killed my ad on first post though.

Thanks,
Reply With Quote
  #498  
Old 13 Jul 2010, 12:25
maidos maidos is offline
 
Join Date: Jul 2006
hm even with the new xml it doesnt seem to be working
Reply With Quote
  #499  
Old 13 Jul 2010, 12:30
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Hi Ted - that worked - only problem is none of the settings in the admincp seem to be affecting anything - for example, the rating display only displays as text despite the setting in the admincp.
__________________
John

Last edited by tpearl5; 13 Jul 2010 at 13:30.
Reply With Quote
  #500  
Old 13 Jul 2010, 15:23
bposner bposner is offline
 
Join Date: Feb 2009
Originally Posted by tpearl5 View Post
Hi Ted - that worked - only problem is none of the settings in the admincp seem to be affecting anything - for example, the rating display only displays as text despite the setting in the admincp.

I have the same issue, the program shows up, the helpfulanswers.php displays database, the profile seems to be updated, but no graphics, nor no 10 point scale when enabled.

We're gettin' closer
Reply With Quote
  #501  
Old 13 Jul 2010, 20:04
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by tpearl5 View Post
Hi Ted - that worked - only problem is none of the settings in the admincp seem to be affecting anything - for example, the rating display only displays as text despite the setting in the admincp.
What setting do you have for this?
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #502  
Old 13 Jul 2010, 20:05
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by bposner View Post
I have the same issue, the program shows up, the helpfulanswers.php displays database, the profile seems to be updated, but no graphics, nor no 10 point scale when enabled.

We're gettin' closer
So you're just getting the simplified voting option?
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #503  
Old 13 Jul 2010, 20:15
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Originally Posted by Ted S View Post
What setting do you have for this?
I've tried all settings for the rating display and it doesn't change. I also tried turning on 'Manual Template Placement' because I wanted to move it higher anyway, and there was no effect.
__________________
John
Reply With Quote
  #504  
Old 13 Jul 2010, 21:02
bposner bposner is offline
 
Join Date: Feb 2009
Originally Posted by Ted S View Post
So you're just getting the simplified voting option?
Assuming you mean just text, yes.
As stated the AdminCP options don't seem to have an effect, changing to 10 point, or any non default options, don't seem to grab hold.
Thanks for your time.
Reply With Quote
  #505  
Old 14 Jul 2010, 03:43
Ted S Ted S is offline
 
Join Date: Dec 2003
Ok, fixed the voting options... looks like 4.0.4 requires all variables to be localized, very strange thing to change without making huge mention but so be it.

Let's give 2.3.2 beta2 a run...
Attached Files
File Type: xml product-helpful_answers.xml (80.1 KB, 5 views)
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #506  
Old 14 Jul 2010, 03:50
sticky sticky is offline
 
Join Date: Sep 2003
Originally Posted by Ted S View Post
Ok, fixed the voting options... looks like 4.0.4 requires all variables to be localized, very strange thing to change without making huge mention but so be it.

Let's give 2.3.2 beta2 a run...
Is this just a 4.0.4 compatibility update or does it include the proposed updates?
Reply With Quote
  #507  
Old 14 Jul 2010, 03:52
bposner bposner is offline
 
Join Date: Feb 2009
Nice, thanks for the quick turnaround, will try tomorrow morning when in office (I'm on Pacific Time) .
Reply With Quote
  #508  
Old 14 Jul 2010, 04:45
Ted S Ted S is offline
 
Join Date: Dec 2003
Originally Posted by sticky View Post
Is this just a 4.0.4 compatibility update or does it include the proposed updates?
Just 4.0.4 at this point. Once that's solved I'll return to updates.
__________________
New features released for Product Review Forums 1.3 (4.0)
Helpful Answers (3.8) (4.0) | Limited Guest Viewing (3.8) (4.0)
Reply With Quote
  #509  
Old 14 Jul 2010, 13:24
pete_brady pete_brady is offline
 
Join Date: Mar 2002
looking good, thanks
__________________
thumped.com
Reply With Quote
  #510  
Old 14 Jul 2010, 13:35
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Thanks Ted - Other things are working now, but I still can't get the Post Block to show up.
__________________
John
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 00:16.

Layout Options | Width: Wide Color: