Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 09 Sep 2009, 15:44
sparklywater sparklywater is offline
 
Join Date: Jun 2008
Parsing smilies in a message

I'm trying to use the following code to parse smilies in a message / text, but the smilies don't appear. What am I doing wrong?


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Reply With Quote
  #2  
Old 09 Sep 2009, 16:28
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
You set the $append_custom_tags value to true and I think you want to pass disablesmilies set to false. I'm not positive about that, but true it. (See the functions in includes/class_bbcode.pp around line 160.)
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #3  
Old 11 Sep 2009, 05:47
sparklywater sparklywater is offline
 
Join Date: Jun 2008
I've tried setting $append_custom_tags to true and disable_smilies to false, but the smilies still don't appear. Other types of bbcode formatting is working, such as bold text / font size, it's just the smilies that don't work. I'm trying to get them to appear inside a page in the AdminCP (a file in the admincp/ folder).
Reply With Quote
  #4  
Old 11 Sep 2009, 15:27
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
It's hard to know if you did it correctly since you didn't paste the text you added.

You may want to post up all the code so someone can test it if they want to help out.
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #5  
Old 11 Sep 2009, 17:08
sparklywater sparklywater is offline
 
Join Date: Jun 2008
I changed disable_smilies settings to false in the file class_bbcode.php.

This is how i changed the original code to set $append_custom_tags to true but it didn't work:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


The following is the complete code for the AdminCP file. The part near the middle/top half shows where I made the $append_custom_tags change.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Last edited by sparklywater; 11 Sep 2009 at 17:15.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:58.

Layout Options | Width: Wide Color: