Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Thread Thumbnail Details »
Thread Thumbnail
Mod Version: 1.1, by jasonmerchant (Member) jasonmerchant is offline
Developer Last Online: Jun 2009 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (21 votes - 4.81 average) Installs: 208
Released: 21 Sep 2007 Last Update: 21 Sep 2007 Downloads: 1391
Not Supported Uses Plugins Template Edits  

This plugin is the newest version of the Thread Thumbnail plugin

This plugin will display the first attachment as a thumbnail on forumdisplay.php

New Features:
  • If there are attachments that are not images, it will skip them and go to the first image attachment.
  • Optional - you can now display thumbnails on search results.



Installation:

In your AdminCP, go to Plugin System, Download/Upload Plugins and import the xml document.

Be sure to change the forum ids in the $thumbsforums array to the forum ids you want to enable thumbnails in.

The plugin comes with the Search Thumbnails enabled. If you do not want to have thumbnails show up in the search results, make sure you deactivate it.

If you would like thumbnails to display in the search results, you will need to replace your search.php page with the one in the zip file. Unfortunately vBulletin forgot to include a hook variable where it is necessary for this to work. I have added 1 line to search.php with the hook variable. There is no way around this until vbulletin adds it themselves.

Next you will need to modify your threadbit template:

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace With:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You will also need to upload an image to display if there are no image attachments here: $stylevar[imgdir_misc]/nothumb.jpg(ex: http://www.mysite.com/forums/images/misc/nothumb.jpg). I've made a simple one you can use or you can make your own. By default thumbnails are confined in a 100x100 px area, I found that it looks good to make the "no image" image about 100x83 px.

_____________________________________________________

Add-ons (Optional)

UserCP option to turn the thumbnails on/off on a per user basis

Go into your admincp and click User Profile Fields->Add New User Profile Field.

Select "single selection radio buttons", click continue.

For title put "Thread Thumbnails", for description put "This will allow you to turn the thumbnails of threads on and off."

For options, enter "On" and "Off".

Skip down to Display Page and choose "Options: Thread Viewing".

In your threadbit template(assuming you already applied the template changes above):

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Replace with:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

You need to replace field5 with the field name of the profile field you created earlier.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	attachment.jpg
Views:	5493
Size:	36.5 KB
ID:	70123  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Thread Thumbnail jasonmerchant vBulletin 3.5 Add-ons 196 04 Jan 2009 09:26

  #316  
Old 23 May 2009, 00:01
smsoom smsoom is offline
 
Join Date: Sep 2008
Copy and paste the postbit_attachmentimage template contents into the postbit_attachmentthumbnail template (overwrite the current postbit_attachmentthumbnail contents). And leave thumbnail creation on.
I do this and it works fin to show fullsize of attachmentimage in posts with thumbnail creation switched to on.
but
when I do this to insert attachmentimage in the post, I get the thumbnail image??



can somebody help me what to do?

thank you jasonmerchant for this plugin.
Reply With Quote
  #317  
Old 24 May 2009, 18:57
somailhm somailhm is offline
 
Join Date: May 2009
thank you
Reply With Quote
  #318  
Old 02 Jun 2009, 14:44
kalisekj kalisekj is offline
 
Join Date: Dec 2006
Hi I just LOVE this Mod, Thank You So Very Much you saved me a ton of work and made my movie web site look like it should. WooHoo! Only 1 problem I am having is that its showing the full size of the poster instead of a thumbnail,, did I miss something somewhere?
Reply With Quote
  #319  
Old 02 Jun 2009, 15:58
kalisekj kalisekj is offline
 
Join Date: Dec 2006
Wink

Originally Posted by theOZer View Post
Adding Thread Thumbnails to Tag Search

Here's my New & Improved threadbit template change to thread thumbnail both regular searches and Tag searches. Your current TT code may differ from mine, for sure.
What do you mean TT code may differ? I made all the changes but alas all I see is the no post icon , I am sure I missed something. Any Help?

Good Thing is that the Forum Search and The Forums Still show the thumbnails albeit all of them are the full size, wish I could change that.

Last edited by kalisekj; 02 Jun 2009 at 20:41.
Reply With Quote
  #320  
Old 08 Jun 2009, 00:47
ghostpt ghostpt is offline
 
Join Date: Oct 2007
Work excellent on 3.8.1 with vbSEO.

Thanks.
Reply With Quote
  #321  
Old 18 Jun 2009, 18:07
6piston's Avatar
6piston 6piston is offline
 
Join Date: Apr 2005
hi theOZer and neverbored
sorry to bother you guys again,

This is regarding the search result thumbs be it the new post / regular search and threads by users. I really need to get it working actually

I have been reading your replies over and over again and editing the search.php countless of times using the one from the zip and the default one i have and then editing it with your code and I still can't get the thumbnails to display correctly on the search results.

I have also tried your Thread Thumbnail - all forums plugin xml code theOZer and then disabling the stand Thread Thumbnail plugin and still no good.

I got it HALF working and this is what i found:
-New post thumbnails work but only in 2nd page
-Certains terms when searched will display thumbnails in the search result, other terms when search will not display any thumbs at all and looks just like the default search result page.
-Find all Threads by User when clicked on certain members will display thumbnails in search result. other members not at all, like default.

Have anyone had this before?

Thanks!
Tom
Reply With Quote
  #322  
Old 18 Jun 2009, 19:03
Arkham's Avatar
Arkham Arkham is offline
 
Join Date: Nov 2001
Originally Posted by 6piston View Post
hi theOZer and neverbored
sorry to bother you guys again,

This is regarding the search result thumbs be it the new post / regular search and threads by users. I really need to get it working actually

I have been reading your replies over and over again and editing the search.php countless of times using the one from the zip and the default one i have and then editing it with your code and I still can't get the thumbnails to display correctly on the search results.

I have also tried your Thread Thumbnail - all forums plugin xml code theOZer and then disabling the stand Thread Thumbnail plugin and still no good.

I got it HALF working and this is what i found:
-New post thumbnails work but only in 2nd page
-Certains terms when searched will display thumbnails in the search result, other terms when search will not display any thumbs at all and looks just like the default search result page.
-Find all Threads by User when clicked on certain members will display thumbnails in search result. other members not at all, like default.

Have anyone had this before?

Thanks!
Tom
Have you rebuilt the attachment counters? Try adding a new thread with an img attachment and see if the new one works. I've run into situations where sometimes existing threads with existing thumbs don't show up.

Don't replace the search.php file entirely -- just edit your existing vB version's search.php and add the single line (or 2, including the comment line). I think it's around line 2600-ish. You shouldn't have to fiddle with the search.php much.
Reply With Quote
  #323  
Old 19 Jun 2009, 00:59
theOZer's Avatar
theOZer theOZer is offline
 
Join Date: Mar 2007
Real name: Dennis "theOZer" Osborne
6piston,
which vB version?
vB templates or other?
other issues, like, are you running just vB or do you run vBSEO, whatever?
If you have Manage Attachments turned on, and if in the first thread post and the user used vB Manage Attachments to load an image this mod will display that attachment's thumbnail, if coded to do so. The mod's trick is an outer join that relies on the fact that there's a thread first post id that can find/grab the associated attachment postid, enabling the outer join, piggybacking the attachment's row info onto the select.
Create a testvb. Do all your testing there.
After I set up a clean/virgin vB383 testvb, I put together a 'My Way to Install Thread Thumbnails' write up as I updated this testvb to use thread thumbnails in forums/new posts, searches, and tag searches. PM me if you'd like a pdf of this write up.
Ciao, Oz
Reply With Quote
  #324  
Old 19 Jun 2009, 07:36
6piston's Avatar
6piston 6piston is offline
 
Join Date: Apr 2005
Originally Posted by Arkham View Post
Have you rebuilt the attachment counters? Try adding a new thread with an img attachment and see if the new one works. I've run into situations where sometimes existing threads with existing thumbs don't show up.

Don't replace the search.php file entirely -- just edit your existing vB version's search.php and add the single line (or 2, including the comment line). I think it's around line 2600-ish. You shouldn't have to fiddle with the search.php much.
hi Arkham

Do yours work fully? Then i gotta try your way right now.

I'll also try to use a fresh copy of 3.7.2 search.php again and include the lines.
Let me get this right:
-Fresh 3.7.2 search php
-Add the 2 Jason lines that is included in the TT's Zip's search.php

Thanks!

Originally Posted by theOZer View Post
6piston,
which vB version?
vB templates or other?
other issues, like, are you running just vB or do you run vBSEO, whatever?
If you have Manage Attachments turned on, and if in the first thread post and the user used vB Manage Attachments to load an image this mod will display that attachment's thumbnail, if coded to do so. The mod's trick is an outer join that relies on the fact that there's a thread first post id that can find/grab the associated attachment postid, enabling the outer join, piggybacking the attachment's row info onto the select.
Create a testvb. Do all your testing there.
After I set up a clean/virgin vB383 testvb, I put together a 'My Way to Install Thread Thumbnails' write up as I updated this testvb to use thread thumbnails in forums/new posts, searches, and tag searches. PM me if you'd like a pdf of this write up.
Ciao, Oz
hi theOZer thanks for the reply!

it's 3.7.2

I do have VBSEO. The thread thumbnails in my selected forums run beautifully right from the start. so i'm not sure if it's anything to do with VBSEO

My main goal is to get the
-regular searches with thumbnails to work in those selected forums.
-find all users' threads to also display the thumbs

Just in case it makes any difference, some of my search links aren't the default ones, for example, my "new post" links only display relevant new posts from certain forums:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I did try it without excluding the forums and it's the same.

I will also create a test site to do this

Please do PM me the pdf file you made. i;m sure it'll help me much! great job getting all of it to work and more
Reply With Quote
  #325  
Old 19 Jun 2009, 15:36
unforgotten unforgotten is offline
 
Join Date: Jul 2006
I have a question, when I have these forum permissions set for the unregistered not logged in user group:

Can View Forum: Yes
Can View Thread Content: No

Unregistered users can not see the thumbnail, is there a way they can see see the thumbnail even if they can't access the topics, thanks!!
Reply With Quote
  #326  
Old 19 Jun 2009, 23:41
theOZer's Avatar
theOZer theOZer is offline
 
Join Date: Mar 2007
Real name: Dennis "theOZer" Osborne
After a little testing, my educated guess is apparently not. If you can't see the thread and the attachment is part of that thread, hmmmm.
If you have set up thumbnails to display in forum thread lists, new posts, searches, and tag searches hopefully that will be enough encouragement to make someone join, become a member of your forum, so they can see that thumbnailed image fully.
Reply With Quote
  #327  
Old 21 Jun 2009, 15:12
unforgotten unforgotten is offline
 
Join Date: Jul 2006
well is there a way maybe for the attachments to be hosted outside the thread so they can preview it?
Reply With Quote
  #328  
Old 28 Jul 2009, 03:18
Greeksgal Greeksgal is offline
 
Join Date: Jul 2006
Does this work with 3.8.3?
Reply With Quote
  #329  
Old 28 Jul 2009, 04:03
MissKalunji's Avatar
MissKalunji MissKalunji is offline
 
Join Date: Aug 2003
Real name: Mj Bain
yes.
__________________
____________
BossLady
Reply With Quote
  #330  
Old 28 Jul 2009, 12:10
Cerbero1000 Cerbero1000 is offline
 
Join Date: May 2005
Hi guys,
I can't see thumbs in search page only (added 2 line code on my 3.7.5 search.php).
In forumdisplay all works fine.
Can you help me?
thanks
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 12:23.

Layout Options | Width: Wide Color: