Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
VBGooglemap Member Edition Details »
VBGooglemap Member Edition
Mod Version: 3.0.1, by stonyarc (Member) stonyarc is offline
Developer Last Online: Aug 2013 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (50 votes - 4.50 average) Installs: 1032
Released: 05 Aug 2006 Last Update: 21 Aug 2007 Downloads: 5782
Not Supported DB Changes Uses Plugins Template Edits Additional Files  


Version 3.0.1 is currently available

This is the tested port of my 3.5.x version h(http://www.vbulletin.org/forum/showthread.php?t=99920)

You can now nominate hacks yourself for hacks of the month. There is a link on the right of hacks on top of the files.

Function
This will display the members of the Bulletin Board based on their lattitude and longitude coordinates on a googlemap.

Don't forget to hit install !!!!!!!
Please read the guide before asking for support !!!!!!!

Feel free to support this mod and make a paypal donation to [email protected]

INSTALL

Detailed installation instructions and screenshots in the included pdf file.

Current Features



NOTE:
VBGooglemap 3.0.0 contains the vulnerability fix. Please upgrade immediately. Version 3.0.0. also contains all features from 2.5.X

As always you use modifications at your own risk.

VBGooglemap Member Edition 2.5.x brings you a lot of new features. Itís vital that you uninstall any previous version before upgrading/installing version 2.5.x.

Upgrading from version 2.5.0 is easier. Instruction are available in the guide.

As the uninstall function will not remove your googlemap data in the database but only the templates and files you can safely remove an older version. As a precaution you should always take a backup. This should be done on each major change you make to your bulletin board.

IF YOU ARE RUNNING VERSION 1.0.3, 2.0.X AND YOU CHANGED TEXT DIRECTLY IN THE TEMPLATES YOU NEED TO SAVE YOUR CHANGES AS VERSION 3.0.0. REQUIRES YOU TO UINSTALL PREVIOUS VERSIONS.

This has taken quite some work and still will take a lot more. Please give credit where credit is due. You cannot remove any notice without prior written permission.

Changes in this version

SEE FIRST POST FOR FULL ROADMAP AND HISTORY

Planned Features
- TBD

Volume warning

high volume of users may slow down the load. Currently a load counter is included.

Languages

Thanks to Wachtmeister there is a German translation available to you all. Feel free to use it.

The translation will be updated on each new version.

Special

- Read the attached PDF for more information. The pdf is also included in the zip file.
- You'll need a googlemap key for your domain. Get your own key for your domain view http://www.google.com/apis/maps/signup.html for more information.
A googlemap key is only valid for a specific domain. You'll need a specific google account to create one.
All is explained on the googlemap link indicated above.
- Set the file permissions on the marker.xml file to 777
- The googlemap script can handle non-registered users. They will only see the main map and won't be able to enter information. This is reserved for logged in users (detected automatically)
- usergroup permissions are available in the backend
- To change location just drag the map while holding the left mouse key or by using the zoom and key functions on the left
- First time loading of the map may take a few seconds longer because of Google API hosting



Special Xbox Live version
http://www.xboxlivenation.com/community/gamermap.php

Credits

This has taken quite some work and still will take a lot more. Please give credit where credit is due. You cannot remove any notice without prior written permission. Instructions are included in the pdf file.
Special credits to Google, Pyg for the javascript tips.



FAQ

The FAQ is included in the pdf file.

INSTALL



Feel free to support this mod and make a paypal donation to [email protected]



(c) 2007 Stonyarc

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
VBGooglemap Member Edition stonyarc vBulletin 3.5 Add-ons 1715 23 Apr 2013 16:58

  #1036  
Old 30 Jan 2011, 22:29
Gamelobby's Avatar
Gamelobby Gamelobby is offline
 
Join Date: Jul 2007
Originally Posted by HondaATC View Post
Tip for those using this:

I had my markers disappear on me the other day. I couldn't figure out why. I loaded markers.xml in my browser and got a parse error with a copy of what line exactly was showing it. Turns out a user had posted a link to an attachment into his thumb tack, and the character messed it up. I removed the image link, deleted markers.xml via FTP, and then added myself back on, and markers.xml regenerated with the correction, and then the page loaded correctly showing all nearly 200 markers.
1. Removed the img link where..? (in the mod itself or from xml)
2. Deleted xml from FTP, (then uploaded it again later or mod recreated it by itself.?)
3. Added yourself back on in mod or to xml.? (my info never went away)


Thanks.
i think i did what you said, but it didn't work for me, is why im asking.
Reply With Quote
  #1037  
Old 30 Jan 2011, 23:14
HondaATC HondaATC is offline
 
Join Date: May 2004
Its been sometime since I did this but as I recall:

The tacks are stored in two places. One in a mysql table that actually propogates the xml file. I either edited the table directly in phpmyadmin or went to the settingsin admincp for this mod and found the user that had posted the link and removed it that way. It seems like there was a moderate users option or something for it, that had a list of all the users there location and comment data. Wherever that was, I deleted the info causing the the information that was causing the error in the xml from the database. And my own info from the database. Then I deleted the markers .xml completely, and I readded myself from the web interface, the modified database table re generated a correct xml file and it worked.

This was about 6 months ago so I can't remember entirely
Reply With Quote
  #1038  
Old 01 Feb 2011, 03:05
haninja haninja is offline
 
Join Date: Jan 2008
I'm getting 'InfoTabs' is undefined when I click on a marker. Anybody encounter this? And I don't see the popups.
Reply With Quote
  #1039  
Old 26 Feb 2011, 06:47
eh69 eh69 is offline
 
Join Date: Feb 2009
Im using php 5.3.5 and xcache. I have error too:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

This error is missing when I click "flush cache" in vBOptimise, but missing on for one refresh. Next is showing again.

Or error is missing when I comment this line in vbgooglemap.php:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Map is showing - its not correct key problem.

Second problem - markers is dont adding to my marker.xml file, its looking that:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Im using iso8859-2 enconding on my site.


EDIT
I found fix for that.

1. find this line

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and replace with this line

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

2. in googlemap admin cp disable small map preview
__________________
Forum Alfa Romeo Giulietta, 159, MiTo, 156, 147, 166, 145, 146, 155, 164, 33, 75, GTV, GT, Brera, Alfetta ;D

Last edited by eh69; 26 Feb 2011 at 06:57.
Reply With Quote
  #1040  
Old 10 Mar 2011, 13:13
vwdforum vwdforum is offline
 
Join Date: Jun 2006
I've tried to use this in vb 4.1.2 but it doesn't work, anyone using it now?
__________________
www.vwdforum.com
residual income
Reply With Quote
  #1041  
Old 10 Mar 2011, 17:47
kylek kylek is offline
 
Join Date: Oct 2003
Real name: Kyle
Yes, have it running on two sites using 4.1.2. Did you try the updated package found here - http://www.vbulletin.org/forum/showp...&postcount=989
__________________
Reply With Quote
  #1042  
Old 15 Mar 2011, 21:00
Sworm Sworm is offline
 
Join Date: Feb 2008
Has this mod tryed on 3.8.x versions?
Reply With Quote
  #1043  
Old 20 May 2011, 09:15
Jezlad's Avatar
Jezlad Jezlad is offline
 
Join Date: Apr 2007
I'm getting a popup that reads...

This web site needs a different Google Maps API key. A new key can be generated at http://code.google.com/apis/maps/signup.html.
Any ideas?
Reply With Quote
  #1044  
Old 26 Sep 2011, 21:50
HondaATC HondaATC is offline
 
Join Date: May 2004
OK. I just had to mess with this again to get the markers working. Instructions for anyone that is having issues.

Go to your website and load markers.xml in your browser window (http://www.yourforum.com/forum/markers.xml)

You should see an error about a parsing error. It'll give you some information like a line, and if you read the code you'll see a username. Copy this.

Load the AdminCP, VbGoogleMap ME Full Settings. Use ctrl + F to search for the username you got from the error in your browser window. Select that user and delete them.

Login to your ftp account, find markers.xml and delete it.

Make a BLANK new file called markers.xml in your favorite text editor. Upload it where the original was you just deleted.

CHMOD this new markers.xml to 777

Go to the Members map, click on"Your Entry/New Marker"

Scroll down, click update the information.

Load markers.xml again in your browser window. If you have another parse error, repeat the entire process (including deleting and re-uploading a blank markers.xml file).

If you deleted the last entry that was causing the problem, you should see the full list of all the entries, in Firefox the file will look different and it'll start with:

<markers><!-- (c) 2006 StonyArc -->

At which point you can go back to your members map, and it'll load all the markers! It might take a few tries to get all the ones removed causing the problem, but when you do it'll start working right again. Its important to delete the markers.xml file via FTP and upload a new one, because it'll be re-populated from the database with the changes you've made. If you DONT remove and upload the blank file, the markers.xml file WONT be repopulated by the changes you made in the database and you'll have the same problem.

Anything with an "&" I found to be an issue with the script whether it was in the name, the comments, or in the image link associated with it.
Reply With Quote
  #1045  
Old 27 Sep 2011, 08:54
Ncturnal Ncturnal is offline
 
Join Date: Feb 2005
All of that is completely unnecessary. When you go tot the markers.xml file and find the username that is causing the parsing error, simply edit that user's entry and remove whatever is causing the issue. I'd recommend turning of the description field as that has been a bigger source of issues. Special characters are usually the cause, such as ' and <. A ' in the username will cause problems, so in some cases you may have to rename a user.
Reply With Quote
  #1046  
Old 30 Sep 2011, 20:20
HondaATC HondaATC is offline
 
Join Date: May 2004
Its my experience deleting from the markers.xml file is not enough as there is a database table where the names and locations are stored, and as soon as a new entry is added it will re-populate the xml file with the old one unless you delete it from the database as well.
Reply With Quote
  #1047  
Old 30 Sep 2011, 21:03
Ncturnal Ncturnal is offline
 
Join Date: Feb 2005
Originally Posted by HondaATC View Post
Its my experience deleting from the markers.xml file is not enough as there is a database table where the names and locations are stored, and as soon as a new entry is added it will re-populate the xml file with the old one unless you delete it from the database as well.
No one said anything about deleting it from the markers.xml file, in fact there's nothing there to delete. The sole purpose of going to the markers.xml file is to find out which user's entry is causing the problem so you can go and edit their entry, which fixes it in the database. While your method may work, it is still convoluted and unnecessary.
Reply With Quote
  #1048  
Old 19 Nov 2011, 09:32
dariyos dariyos is offline
 
Join Date: Nov 2011
hello, got n script error on showing my entry or showing the entries of the users: Skript: http://maps.gstatic.com/intl/de_ALL/...api/main.js:36

____________
vbulletin 4.1.7
Reply With Quote
  #1049  
Old 28 Nov 2011, 13:10
patracy patracy is offline
 
Join Date: Feb 2006
Has anyone had issues with the "show on map" link simply dumping the user back to the main view of the map? I've tried tweaking the zoom setting in the CP. But it just shows the main map view. I see the link is formed correctly.
Reply With Quote
  #1050  
Old 19 Dec 2011, 18:26
Derwin's Avatar
Derwin Derwin is offline
 
Join Date: Jan 2009
Has anyone got this updated and working in the vbulletin 4 software?

If not, is there any other program that can be used in vb4? I'm wanting something that will show the members username on the map, and not just a pin, just like this program.

Unfortunately, I've installed this and it is not working on vb4. I get the following errors:

Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: vbgooglemapme_legend in [path]/includes/functions.php on line 4293

Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: vbgooglemapme_display_map in [path]/includes/functions.php on line 4293

Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: vbgooglemapme_menavbar in [path]/includes/functions.php on line 4293

Warning: fetch_template() calls should be replaced by the vB_Template class. Template name: navbar in [path]/includes/functions.php on line 4293

Parse error: syntax error, unexpected T_STRING in /home/clubnook/public_html/forum/vbgooglemapme.php(583) : eval()'d code on line 1

Fatal error: Call to undefined function construct_forum_jump() in /home/clubnook/public_html/forum/vbgooglemapme.php on line 585
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:26.

Layout Options | Width: Wide Color: