Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
vB Nexus, Facebook & Google multiple login integration Details »
vB Nexus, Facebook & Google multiple login integration
Mod Version: 1.00, by ibautocommunity (Coder) ibautocommunity is offline
Developer Last Online: Oct 2018 I like it Show Printable Version Email this Page

vB Version: 3.8.3 Rating: (17 votes - 4.47 average) Installs: 154
Released: 13 Aug 2009 Last Update: 13 Aug 2009 Downloads: 1926
Not Supported DB Changes Uses Plugins Auto-Template Additional Files Re-usable Code Translations External Content Is in Beta Stage  

vBulletin Nexus
Current project release: BETA
This works on vBulletin 3.7.X - 3.8.4

This product will allow visitors to join your community using their Facebook, Google, Yahoo or AIM account; and will allow your existing members to associate an existing forum account with one of the services - such as Facebook.

Please read the documentation and follow it exactly before requesting installation help. Please note, if you have heavily modified styles that are missing hooks - this product will not work and require additional installation steps.

DEMO: http://www.carblog.com/vbnexus

Basic Instructions for your forum's users: http://carblog.com/vbnexus/user-guide/

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #61  
Old 14 Aug 2009, 22:47
Skyrider Skyrider is offline
 
Join Date: Feb 2006
Can someone explain to me how this works exactly? I've seen this before on other sites, and it doesnt matter if I login using my AIM or Facebook. I still had to register/login on the site itself to actually do things. In this case, I am logged in with AIM, but I still have to register on the forums to post.

EDIT:
It seems to work for Facebook, just the AIM login doesn't work it seems.
Reply With Quote
  #62  
Old 14 Aug 2009, 22:56
jesusdlg jesusdlg is offline
 
Join Date: Apr 2006
What a great add-on, thank you!

Does anyone knows what file do I need to edit to translate this phrase?

"New! Use your Facebook, Google, AIM & Yahoo accounts to securely log into this site, click logo to login"

Thanks in advance and congratulations for this add-on

Jesus
Reply With Quote
  #63  
Old 14 Aug 2009, 23:03
Skyrider Skyrider is offline
 
Join Date: Feb 2006
PS:

I can't seem to log in on your demo forum using my gmail (google mail) email. When it goes to the next page and shows on which nickname I can use on the forums.. I can't press the "login" button, nothing is happening.
Reply With Quote
  #64  
Old 15 Aug 2009, 00:56
cheat-master30's Avatar
cheat-master30 cheat-master30 is offline
 
Join Date: Mar 2007
Location: Information Classified
Real name: cheat-master30
I'm thinking of trying this, but one quick question (to mod author):

I already have the Facebook Connect mod installed, would I install that first, then add this, or install that after installing this mod? Basically, are there any conflicts in tables and such like?
__________________
Proud vBulletin supporter (cheat-master30 at official forum)
DS Ultimate- A Great Nintendo DS forum-
My Nintendo DS forum covering Mario Kart DS, Super Mario 64 DS and the like. Powered by the amazing vBulletin 3.7 software.
Reply With Quote
  #65  
Old 15 Aug 2009, 01:31
Ohiosweetheart Ohiosweetheart is offline
 
Join Date: Dec 2005
Real name: Peggy
This could be a bug or perhaps it just conflicts with the auto tag mod?

I started a new thread on my site, named it another test thread. The content on the thread was simply testing nexus.

I couldn't post the thread because this was in the tag box -
<br /><strong>Warning</strong>: array_merge() [<a href='function.array-merge'>function.array-merge</a>]: Argument #1 is not an array in <strong>[path]/includes/init.php(304) : eval()'d code</strong> on line <strong>613</strong><br />testing,nexus
Once I removed it from the box, of course, the thread posted fine.

EDIT: I disabled the auto tagging mod and it works fine now. So there's a conflict between these mods there somewhere, I'm guessing.
But still no prompt to publish the post to Facebook.

Last edited by Ohiosweetheart; 15 Aug 2009 at 01:50.
Reply With Quote
  #66  
Old 15 Aug 2009, 01:48
Ohiosweetheart Ohiosweetheart is offline
 
Join Date: Dec 2005
Real name: Peggy
Sorry again for the double post. I see now why there's no prompt to publish to FB. In my userCP, The settings for the FB control panel keep reverting back to no. I keep ticking yes and SAVE, go back and they're all set to No again.

I did check in the feed settings in vBulletin Options / vB Nexus Configuration, and everything there is set to Yes.

Any ideas?
Reply With Quote
  #67  
Old 15 Aug 2009, 01:56
Shamil. Shamil. is offline
 
Join Date: Sep 2008
For those getting the facebook error message about the bundle, you need to "Create Feed Template" in the Facebook applications page. You will be given a bundle ID. Keep it safe, because we can't currently edit the default bundle IDs causing the error.
Reply With Quote
  #68  
Old 15 Aug 2009, 02:26
Cableguy69 Cableguy69 is offline
 
Join Date: Apr 2008
Hi IB, first off great mod.

unfortunately this is only half working working on 2 of my skins and not at all on my main skin. I tried to adapt the code from the post you made below but failed. Would you be able to take a look for me please?

http://www.revolution-forums.com

Originally Posted by ibautocommunity View Post
This is the code that you need to place into your template, where you currently have the facebook button displayed on the right. Please note that you have to adjust this html, because your template is CSS DIV based, and this is a table block - so it might not work.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Last edited by Cableguy69; 15 Aug 2009 at 02:33.
Reply With Quote
  #69  
Old 15 Aug 2009, 02:39
ZiG ZiG is offline
 
Join Date: Oct 2002
Real name: Zig
im getting a fatal error when i attempt to configure the facebook feeds:

Fatal error: Uncaught exception 'FacebookRestClientException' with message 'All one line story templates must be nonempty' in /home/rdyup/public_html/forums/vbnexus/facebook/facebookapi_php5_restlib.php:3017 Stack trace: #0 /home/rdyup/public_html/forums/vbnexus/facebook/facebookapi_php5_restlib.php(747): FacebookRestClient->call_method('facebook.feed.r...', Array) #1 /home/rdyup/public_html/forums/admincp/global.php(243) : eval()'d code(66): FacebookRestClient->feed_registerTemplateBundle(Array, Array, NULL, Array) #2 /home/rdyup/public_html/forums/admincp/global.php(243): eval() #3 /home/rdyup/public_html/forums/admincp/index.php(24): require_once('/home/rdyup/pub...') #4 {main} thrown in /home/rdyup/public_html/forums/vbnexus/facebook/facebookapi_php5_restlib.php on line 3017
not sure what the reason for this is, but only 1 template is filled in...and thats the signup template.

{*actor*} just became a member of <a href="{*bburl*}">{*bbtitle*}</a>.
could that be the reason? could someone else post the rest of the default feed templates for me plz?
Reply With Quote
  #70  
Old 15 Aug 2009, 02:44
ZiG ZiG is offline
 
Join Date: Oct 2002
Real name: Zig
just a suggestion also for this mod (great mod btw)
if someone is connected via facebook/google/yahoo/aim could possibly be reflected in the postbit...
Reply With Quote
  #71  
Old 15 Aug 2009, 03:14
AWS's Avatar
AWS AWS is offline
 
Join Date: Nov 2001
Real name: Bob
I created a new usergroup so I could track users that login via this hack. I changed the setting to the new usewrgroup id. Users who sign in go to the default registered users group and not in the usergroup I created.

A bug maybe?
Reply With Quote
  #72  
Old 15 Aug 2009, 03:44
nascartr nascartr is offline
 
Join Date: Jun 2008
Originally Posted by nascartr View Post
Marked as installed. Where can users set their preferences as far as posting message to Facebook from topics and replies plus receiving notifications on Facebook of new PM's?

I also tried to skip adding a post to my Facebook and got a page not found error.

For example, if I reply to a post in my Show and Tell forum it tries to redirect when submitting a post to Facebook or skipping to http://diecastcrazy.com/community/sh...75364013%22%7D
Any idea? Maybe VBSEO is causing the problem?
Reply With Quote
  #73  
Old 15 Aug 2009, 04:10
Wseries Wseries is offline
 
Join Date: May 2008
I really want to be able to use this mod but before I install a couple of questions if I may.

1. I am only interested in Facebook integration. Is it possible to disable the others?

2. Are people that use this mod to join my forum shown, and asked to agree to, my Forum Rules? If not, can I request this be added in a future version? This is really important to me. Thanks.
Reply With Quote
  #74  
Old 15 Aug 2009, 05:52
Theo-zzzz's Avatar
Theo-zzzz Theo-zzzz is offline
 
Join Date: May 2007
Originally Posted by AWS View Post
I created a new usergroup so I could track users that login via this hack. I changed the setting to the new usewrgroup id. Users who sign in go to the default registered users group and not in the usergroup I created.

A bug maybe?
Same problem here..
__________________
Make Money Online & SEO Forum
Reply With Quote
  #75  
Old 15 Aug 2009, 07:49
justitaly.eu justitaly.eu is offline
 
Join Date: Nov 2006
Originally Posted by ibautocommunity View Post
Guys, it is "uber" important to have the following hook in your customized styles, in the footer template you must have this hook:

$template_hook[footer_links]
Otherwise things are not going to work.

To the person running MYSQL4 - you are missing out - should upgrade to mysql5 or request that your hosting provider upgrade their software; it's 2009!
I already have the $template_hook[footer_links] so this does not resolve my problem.

any other ideas?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:14.

Layout Options | Width: Wide Color: