Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
  #1216  
Old 27 Jan 2010, 16:39
netshaq netshaq is offline
 
Join Date: Jan 2010
Lynne,

How would I do this with the new version vb4

thanks
Steve
__________________
NETSHAQ.COM/forum/content.php
Reply With Quote
  #1217  
Old 27 Jan 2010, 17:18
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
Originally Posted by netshaq View Post
Lynne,

How would I do this with the new version vb4

thanks
Steve
Check the vB4 Articles forum - there is an article for this in there (actually, it is also in my profile page since I was the one who put the updated copy of this article there).
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #1218  
Old 29 Jan 2010, 15:47
scottct1 scottct1 is offline
 
Join Date: Mar 2002
Not working for me...

I get the following error message

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /usr/home/satellit/public_html/thelist/test.php on line 43

The global.php file is located at ././global.php

Line 43 is... eval('$navbar = "' . fetch_template('navbar') . '";');

Running vbulletin 3.8.4

Any ideas?

--------------- Added 29 Jan 2010 at 15:58 ---------------

Not working for me...

I get the following error message

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /usr/home/satellit/public_html/thelist/test.php on line 43

The global.php file is located at ././global.php

Line 43 is... eval('$navbar = "' . fetch_template('navbar') . '";');

Running vbulletin 3.8.4

Any ideas?

--------------- Added 29 Jan 2010 at 16:29 ---------------

Not working for me...

I get the following error message

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /usr/home/satellit/public_html/thelist/test.php on line 43

The global.php file is located at ././global.php

Line 43 is... eval('$navbar = "' . fetch_template('navbar') . '";');

Running vbulletin 3.8.4

Any ideas?

--------------- Added 29 Jan 2010 at 16:53 ---------------

Not working for me...

I get the following error message

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /usr/home/satellit/public_html/thelist/test.php on line 43

The global.php file is located at ././global.php

Line 43 is... eval('$navbar = "' . fetch_template('navbar') . '";');

Running vbulletin 3.8.4

Any ideas?

Last edited by scottct1; 29 Jan 2010 at 16:53. Reason: Auto-Merged DoublePost
Reply With Quote
  #1219  
Old 30 Jan 2010, 20:33
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Whoa, quadruple post!
Originally Posted by scottct1 View Post
Not working for me...

I get the following error message

Parse error: syntax error, unexpected T_CONSTANT_ENCAPSED_STRING in /usr/home/satellit/public_html/thelist/test.php on line 43

The global.php file is located at ././global.php

Line 43 is... eval('$navbar = "' . fetch_template('navbar') . '";');

Running vbulletin 3.8.4

Any ideas?
Er, okay, the error is at line 43 of your test.php file, not your global.php file. You probably deleted a quote or something when putting in your template name.

Also, I don't know what you mean when you say where global.php is located, but unless you have some very customized file locations, there was no reason to edit the line refering to global.php. require_once('./global.php'); shouldn't need to be changed.
__________________
Reply With Quote
  #1220  
Old 31 Jan 2010, 16:42
amcd amcd is offline
 
Join Date: Oct 2004
././global.php is the same as ./global.php which is also the same as ./././././././././././././././global.php

. refers to the current directory and .. refers to parent directory.
__________________
eXBii.com - Indian community
no XB no fun know XB know fun !
Reply With Quote
  #1221  
Old 17 Feb 2010, 23:05
edytwinky edytwinky is offline
 
Join Date: Sep 2007
Originally Posted by Gary King View Post
1) correct
2) replace $bbuserinfo[usergroupid] == 6 with $bbuserinfo[usergroupid] == 7 or $bbuserinfo[usergroupid] == 8 or $bbuserinfo[usergroupid] == 9
3) Replace eval('print_output("' . fetch_template('TEST') . '");'); with your PHP stuff.
In while file do I edit to allow the article to be viewed by only certain usergroups?
Reply With Quote
  #1222  
Old 18 Feb 2010, 05:49
gcc.programmer gcc.programmer is offline
 
Join Date: Feb 2010
Hello:

I'm a vB noob, trying to create a static page w/ vB 3.8.4 I placed the test.php file in the forums folder, and created the template as a new template in the admincp, but am getting a "page not found" when I type in the url for the page. Obviously, I'm not doing something right!

Could someone offer me some advice?

Thanks.
Reply With Quote
  #1223  
Old 18 Feb 2010, 09:16
cellarius's Avatar
cellarius cellarius is offline
 
Join Date: Aug 2005
Real name: Sven
If you're getting a 404, you either did not upload the file, did not upload to the correct place, did not enter the correct URL or have a typo.
__________________
Please note that there will be no further updates to my addons, especially they will not be upgraded for vB5. I'm leaving vB, since IB choose to go the banana-way yet again.

http://www.roma-antiqua.de
Reply With Quote
  #1224  
Old 22 Feb 2010, 18:25
gcc.programmer gcc.programmer is offline
 
Join Date: Feb 2010
Problem Resolved

LOL!

The site I was working on is not my own, and though I thought I was in the right place, the owner has over 100 web properties, and at this point has lost track of many of them. Luckily, the servers he uses are managed. When I spoke with them, I found that the document root I was using, though it looked correct, was not in fact the correct one.

Thank you, Cellarius for taking the time to respond to me.
Reply With Quote
  #1225  
Old 01 Mar 2010, 07:25
Abdullah SZ Abdullah SZ is offline
 
Join Date: Mar 2008
Now if you want to show who is browsing this new page of yours, just open up includes/functions_online.php and find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Below, add:
I can't find it.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

(Be sure to change the values to your own!)
I know the first test is file name, what about the second one?
Reply With Quote
  #1226  
Old 02 Mar 2010, 17:33
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Originally Posted by Abdullah SZ View Post
I can't find it.
It's not in there anymore. Just look for the area with that same syntax structure. There are a bunch of blocks of code with that same format.

I know the first test is file name, what about the second one?
Same name. In his tutorial all lowercase tests are the file name and all uppercase TESTs are the template name.
__________________
Reply With Quote
  #1227  
Old 20 Mar 2010, 16:57
SoloX SoloX is offline
 
Join Date: Jun 2002
Hi all ...

Which templates do I need to include to get a list of latest threads?
Similar to what we get by going to /forums/search.php?do=getnew

I am sure his has been asked before but I could not find an answer.

Thanks
Reply With Quote
  #1228  
Old 20 Mar 2010, 19:33
Simon Lloyd's Avatar
Simon Lloyd Simon Lloyd is offline
 
Join Date: Aug 2008
Real name: Simon
This question has nothing to do with this mod, however dump this in your new template:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Change YOURSITE.COM, the forum ID's and the 15 to as many threads as you would like to show!
__________________
Kind regards,
Simon Microsoft Office Help
My Mods: Find my modifications here
Please do not pm me for support unless i have invited you to!
Reply With Quote
  #1229  
Old 21 Mar 2010, 09:53
Dan! Dan! is offline
 
Join Date: May 2008
Real name: Daniel Orman
I've followed your guide and its worked pretty well, apart from I have the following error at the top of my page:

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 55

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 107

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 111

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 119

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 130

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 134

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 142

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 211

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/init.php on line 389

Deprecated: Assigning the return value of new by reference is deprecated in /home/socialop/public_html/includes/class_core.php on line 2552
any ideas at all?
__________________
Thanks,
Daniel Orman
Web Development Guy
Reply With Quote
  #1230  
Old 21 Mar 2010, 20:22
Simon Lloyd's Avatar
Simon Lloyd Simon Lloyd is offline
 
Join Date: Aug 2008
Real name: Simon
Originally Posted by Dan! View Post
I've followed your guide and its worked pretty well, apart from I have the following error at the top of my page:



any ideas at all?
Are you trying to use it on VB4.0.x?, i imagine thats why you are getting the error.
__________________
Kind regards,
Simon Microsoft Office Help
My Mods: Find my modifications here
Please do not pm me for support unless i have invited you to!
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 22:15.

Layout Options | Width: Wide Color: