Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Hide Images from Guests Details »
Hide Images from Guests
Mod Version: 4.0, by ForumsMods (Coder) ForumsMods is offline
Developer Last Online: Jan 2016 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (7 votes - 4.71 average) Installs: 114
Released: 28 Dec 2010 Last Update: Never Downloads: 609
Not Supported Uses Plugins Code Changes Translations  

Hide Images from Guests

Description:
Allows you to show a message to guests instead of images in posts.

Installation:
  1. Import "product-hideimg_guests.xml" as a product, overwrite if it's already installed
Where to set option:
Settings-> Options-> Thread Display Options (showthread)-> Enable Hide Images from Guests

Languages:

- English

History:
28-12-10: v4.0 First Release

This hack is created for your use free of charge. No payment is requested. However, if you would like to donate money for the work I put in to this hack, a donation would show your appreciation.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	1.png
Views:	861
Size:	8.8 KB
ID:	124895   Click image for larger version

Name:	2.png
Views:	1263
Size:	15.3 KB
ID:	124896  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Show Thread Enhancements Hide Images from Guests ForumsMods vBulletin 3.8 Add-ons 20 27 Oct 2013 14:16

  #31  
Old 16 Dec 2013, 09:17
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
Is there a way to change this hack, so that you show a default image instead of a text message, to guests? I would certainly appreciate it, since I had such a hack in my old 3.0.xx site and I miss it.
__________________

John
SV1CEC
Reply With Quote
  #32  
Old 18 Dec 2013, 22:22
Acido Acido is offline
 
Join Date: Apr 2003
This is not working for vb 4.2.2
Can someone give a hand? I'm trying the code in different hooks, but still can't make it work
Reply With Quote
  #33  
Old 19 Dec 2013, 18:15
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
Works fine for me in 4.2.2. What is the problem you have?
__________________

John
SV1CEC
Reply With Quote
  #34  
Old 19 Dec 2013, 18:47
Acido Acido is offline
 
Join Date: Apr 2003
It is hidding just a small number of images. Must images on posts of the threads are ignoring this hack. I'm looking for another mod that can give conflict, but none of them are using that hook ( postbit_display_start )
Reply With Quote
  #35  
Old 19 Dec 2013, 18:52
Wajow-community Wajow-community is offline
 
Join Date: Dec 2009
Doesn't work for vbulletin 4.2.1??
Reply With Quote
  #36  
Old 19 Dec 2013, 19:37
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
Acido, can you post a link to a page where some images are hidden and some are not?
__________________

John
SV1CEC
Reply With Quote
  #37  
Old 19 Dec 2013, 20:27
Acido Acido is offline
 
Join Date: Apr 2003
Thanks sv1cec

Working Thread

Not Working Thread

Hope it help.
Reply With Quote
  #38  
Old 19 Dec 2013, 21:49
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
What I can see from your links is that you are using a different style than the default vBulletin one. Try creating a new style, using the default vB templates and see how that works. Also, please tell me if the pictures that are NOT shown, are attachments or externally linked pictures. It appears that the pictures shown are attachments (stored in your own server, not in Photobucket, or an other web server). Is the same true for the ones not shown?
__________________

John
SV1CEC
Reply With Quote
  #39  
Old 19 Dec 2013, 21:58
Acido Acido is offline
 
Join Date: Apr 2003
Originally Posted by sv1cec View Post
What I can see from your links is that you are using a different style than the default vBulletin one. Try creating a new style, using the default vB templates and see how that works. Also, please tell me if the pictures that are NOT shown, are attachments or externally linked pictures. It appears that the pictures shown are attachments (stored in your own server, not in Photobucket, or an other web server). Is the same true for the ones not shown?
I'm sure it's no a Style issue. The default style have the same effect with the imagen. But i notice that the problem is with the attachments.. Not with external images. This is a link with the default style: Thread

Edit: is not working with external images too... Thread
Reply With Quote
  #40  
Old 20 Dec 2013, 08:35
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
Well, I checked my site and sure enough, visitors do not see photographs. Have a look here:

http://forum.m1911.org/showthread.ph...w-RIA-Tactical


In the first post, there are three images, stored in Photobucket and there are three attachments shown as thumbnails. Obviously the external images do not show, and from the list of the attachments you can't open one of them. So I guess it is something else, specific to your site.
__________________

John
SV1CEC
Reply With Quote
  #41  
Old 20 Dec 2013, 09:01
Acido Acido is offline
 
Join Date: Apr 2003
Thanks for your help sv1cec. I was checking the plugin, and it is giving troubles with the preg_replace function. Works with any thing that i want insert into the post, but that function is not working on my installation. May be it's another hack giving conflicts, or my php version (5.3.3-7+squeeze16)

I stop to work with this mod because i choose another method to control the images in my site. So i unistall it. May be in the future i'll back to this mod.

Thanks!
Reply With Quote
  #42  
Old 20 Dec 2013, 12:15
Wajow-community Wajow-community is offline
 
Join Date: Dec 2009
How it can work with vbulletin 4.2.1??? I have installed butt doesn't work.
Reply With Quote
  #43  
Old 20 Dec 2013, 13:23
sv1cec sv1cec is offline
 
Join Date: May 2004
Real name: John
As I said, it works with 4.2.2. Have you set the "hideimg_enabled" setting to Yes? I don't remember where exactly that can be found, but it should be somewhere. The plugin checks if you have set that, if not it won't work.

Ah yes, here: Settings-> Options-> Thread Display Options (showthread)-> Enable Hide Images from Guests
__________________

John
SV1CEC
Reply With Quote
  #44  
Old 21 Dec 2013, 10:09
Wajow-community Wajow-community is offline
 
Join Date: Dec 2009
Originally Posted by sv1cec View Post
As I said, it works with 4.2.2. Have you set the "hideimg_enabled" setting to Yes? I don't remember where exactly that can be found, but it should be somewhere. The plugin checks if you have set that, if not it won't work.

Ah yes, here: Settings-> Options-> Thread Display Options (showthread)-> Enable Hide Images from Guests
Yes i have set it on butt don't work with vbulletin 4.2.1.. what can i do to make it work?
Reply With Quote
  #45  
Old 17 Feb 2014, 19:38
aspen0 aspen0 is offline
 
Join Date: Apr 2003
It isn't working for me anymore either, it had been working, but it stopped with the 4.2.2 upgrade.

I've tried it with a default style as well, doesn't seem to help at all.

This is a very important thing to have if you run Google adsense, they've been very strict lately with user uploaded photos.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 14:21.

Layout Options | Width: Wide Color: