Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
External Link Titles, retrieve descriptive titles for URLs Details »
External Link Titles, retrieve descriptive titles for URLs
Mod Version: 1.1.1, by magnus (Member) magnus is offline
Developer Last Online: Feb 2012 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.x Rating: (17 votes - 4.71 average) Installs: 172
Released: 07 May 2007 Last Update: 24 Jul 2007 Downloads: 1107
Not Supported Uses Plugins  

Keywords: SHOWTHREAD, external, link, titles, URLs, SEO

Description:
Retrieves descriptive titles for external posted links. Allows for better link recognition and, in theory, could help increase page SEO.

Details:
I recall this being requested somewhere, so I decided to take a stab at it. This is yet another feature offered in vBSEO.

For those unaware of what this actually does.. by default, when a URL is posted without a description it looks like:
http://www.vbulletin.com

With this modification enabled, it will now look like:
vBulletin.org Forum - The Official vBulletin Resource!

Nicer, eh?



Installation:
  1. Download and import product-linktitles.xml via the Product Manager.
  2. Enable the modification via AdminCP > vBulletin Options > External Link Titles Options (it is disabled by default)
  3. ???
  4. Profit!

Notes:
There's really no magic here, it polls for titles using the cURL() function. If for some reason your host does not have cURL() enabled, you're out of luck.

From time to time you may notice the occasional link that does not get titled -- this is due to either the fact that the url is not active or it either timed out waiting for a response. By default, the system will wait for 5 seconds before timing out. If you wish to modify the timeout, you may do so via the AdminCP.



Comments:
As with all my hacks, this modification is provided free of charge. However, if you find this product useful and have money burning a hole in your pocket, feel free to make a small donation, I won't mind.. really.

Version History:
  • 1.0.0 - Initial release, here's to hoping...
  • 1.1.0 - Added the ability to blacklist specific domains from having link titles retrieved (configurable via the AdminCP)
  • 1.1.1 - Wrapped returned titles in html_entity_decode(); to return properly decoded HTML characters.

Currently Known Bugs:
  • None

* Please note that this modification was developed on a forum with a userbase of 1 (myself). I've tested it for basic functionality but I cannot guarantee functionality or behavior on your forum. So, please -- make backups before installing this product!

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #76  
Old 19 Dec 2007, 14:47
Satz Satz is offline
 
Join Date: Dec 2007
no errors nothin , simply dont work after doing the installation

if i post the link , its good for mods here to treat me with an infraction
Reply With Quote
  #77  
Old 19 Dec 2007, 16:17
TrioxX TrioxX is offline
 
Join Date: Dec 2007
Link to your board?
Reply With Quote
  #78  
Old 19 Dec 2007, 19:15
Satz Satz is offline
 
Join Date: Dec 2007
ok here comes another infraction

www.wareztalk.com/forum < very new forum , so dont gimme an infraction it is just the domain name

Last edited by Satz; 20 Dec 2007 at 05:34.
Reply With Quote
  #79  
Old 19 Dec 2007, 21:33
rwoscott's Avatar
rwoscott rwoscott is offline
 
Join Date: Jan 2007
Real name: Scott
Satz, To ask a silly question, have you enabled it, via the admincp?


Installed. Works great. Thanks.
Reply With Quote
  #80  
Old 20 Dec 2007, 18:37
magnus's Avatar
magnus magnus is offline
 
Join Date: Apr 2002
Originally Posted by Satz View Post
no errors nothin , simply dont work after doing the installation

if i post the link , its good for mods here to treat me with an infraction
The modification is disabled by default. Verify that you enabled it, as per the instructions:
2. Enable the modification via AdminCP > vBulletin Options > External Link Titles Options (it is disabled by default)
Reply With Quote
  #81  
Old 22 Jan 2008, 23:30
TasariMerkezi TasariMerkezi is offline
 
Join Date: Nov 2007
Real name: MuGi & SouLHuNTeR
thanks man
Reply With Quote
  #82  
Old 11 Feb 2008, 17:45
safakuygur's Avatar
safakuygur safakuygur is offline
 
Join Date: Sep 2007
thanks..
__________________
My Site: www.sanalda1numara.org -->Turkish vbullet
Reply With Quote
  #83  
Old 14 Feb 2008, 12:56
iyihost's Avatar
iyihost iyihost is offline
 
Join Date: Feb 2008
thanks
__________________
Happy
Reply With Quote
  #84  
Old 10 Mar 2008, 19:38
BuRaCh BuRaCh is offline
 
Join Date: Aug 2006
Real name: Burak Akyıldız
very good hack
thanks..
Reply With Quote
  #85  
Old 11 Apr 2008, 18:35
BuRaCh BuRaCh is offline
 
Join Date: Aug 2006
Real name: Burak Akyıldız
i am very like this hack
woult you when release for vb 3.7x?
Reply With Quote
  #86  
Old 11 Apr 2008, 18:56
magnus's Avatar
magnus magnus is offline
 
Join Date: Apr 2002
Have you tried it with 3.7? It may work.
Reply With Quote
  #87  
Old 11 Apr 2008, 20:11
theFAILURE's Avatar
theFAILURE theFAILURE is offline
 
Join Date: Jan 2005
Didnt work on my board, running 3.6.7 PL1

Link to site is in sig.
__________________
http://theScamBaiter.com
Fighting Scammers Worldwide for Fun and Justice
Reply With Quote
  #88  
Old 15 Apr 2008, 18:56
NeuroLancer's Avatar
NeuroLancer NeuroLancer is offline
 
Join Date: Feb 2008
Real name: John
Originally Posted by magnus View Post
Have you tried it with 3.7? It may work.
it does work in 3.7 thanks
Reply With Quote
  #89  
Old 19 Apr 2008, 02:24
fly fly is offline
 
Join Date: Oct 2003
Can anyone think of a way to make this NOT work for links back to the forum itself?
Reply With Quote
  #90  
Old 28 Apr 2008, 21:50
ArnyVee's Avatar
ArnyVee ArnyVee is offline
 
Join Date: Mar 2008
Is there a reason why I would get this message?

Unable to add cookies, header already sent.
File: /home/avarona/domains/waltdisneyboards.com/public_html/includes/class_core.php
Line: 3075

I received it after I installed this mod and tested it in a post.

Edited: I also received some curl message (went by too fast to see it) as well. I guess that I'll wait for this one down the road sometime.

Last edited by ArnyVee; 28 Apr 2008 at 22:03.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:12.

Layout Options | Width: Wide Color: