Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
KX - Debug Mode Details »
KX - Debug Mode
Mod Version: 1.0.4, by Ziki (Coder) Ziki is offline
Developer Last Online: Nov 2015 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (9 votes - 4.89 average) Installs: 50
Released: 23 Jul 2011 Last Update: 27 Aug 2012 Downloads: 299
Not Supported Uses Plugins  

This modification was brought to you by
KXDesign
http://www.kxdesign.com/


~Modification name
Debug Mode

~Modification description
This modification enables debug mode in forums,admincp and modcp.This version is different from all debug mode modification as this plugin version supports the query explain feature .A must have for every vBulletin developer.Works from 3.5.x to 4.x.x.

~Modification options
  • Turn on/off globally
  • Only show for admins
  • Turn on/off in administrator control panel
  • Administrator ID
  • Turn on/off in moderator control panel
  • Moderator ID
  • Show template name in comments only to admins
~Modification info
File uploads: 0
Template edits: 0
File edits: 0
Plugins: 5
SQL Queries: 0
Phrases: 15
Settings: 7

Install time: 3 sec
Install level: Easy

~Modification installation
Step 1: Import product

~Modification Changelog
  • 1.0.0 - Initial release
  • 1.0.2
    1. Changed staff viewing permission from can_moderate() to users with admin permission, to make sure it also works with custom groups with admin rights
    2. New option to hide template name in HTML comments for people without admin rights
  • 1.0.3 - Debug Mode works now in CMS
  • 1.0.4 - Explain feature now works even if debug mode is disabled in the forums

~Modification copyright
This may not be distributed,released or claimed as your work without author's permission.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
ZH - Debug Mode Ziki vBulletin 3.5 Add-ons 19 15 Sep 2008 11:23

Comments
  #2  
Old 23 Jul 2011, 11:57
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
~Reserved~

Didn't find a similar mod for 4.x.x, so I re-released it
__________________
My free mods~click here
Reply With Quote
  #3  
Old 23 Jul 2011, 15:25
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
I meant one that uses the vBulletins default debug system, without file edits.
__________________
My free mods~click here
Reply With Quote
  #4  
Old 23 Jul 2011, 15:31
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
I've been using the 3.8 version of this mod on vb 4 for quite a while now and it has always worked fine. I'll go ahead and switch to this one, although when comparing the files they are almost identical.

Thanks.
Reply With Quote
  #5  
Old 23 Jul 2011, 16:09
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Where does the explain feature work? Only on the forums? It doesn't work in the Admin CP.
Reply With Quote
  #6  
Old 23 Jul 2011, 16:53
eTiKeT™'s Avatar
eTiKeT™ eTiKeT™ is offline
 
Join Date: Aug 2008
Real name: Serhat
İnstalled...
Reply With Quote
  #7  
Old 23 Jul 2011, 18:54
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
Originally Posted by Boofo View Post
I've been using the 3.8 version of this mod on vb 4 for quite a while now and it has always worked fine. I'll go ahead and switch to this one, although when comparing the files they are almost identical.

Thanks.
Yeah, it's pretty much the same, I just imported it into vb4, checked if everything works and exported again

Originally Posted by Boofo View Post
Where does the explain feature work? Only on the forums? It doesn't work in the Admin CP.
It doesn't? It works fine for me, even in the Mod Cp. Tried it now on fresh vB4 installation :-/
__________________
My free mods~click here
Reply With Quote
  #8  
Old 23 Jul 2011, 20:29
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by Ziki View Post
It doesn't? It works fine for me, even in the Mod Cp. Tried it now on fresh vB4 installation :-/
What were you doing in the Admin CP when you used it? Maybe I'm not in the right area.
Reply With Quote
  #9  
Old 23 Jul 2011, 21:28
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
Originally Posted by Boofo View Post
What were you doing in the Admin CP when you used it? Maybe I'm not in the right area.
Well I opened it up right away from the forum and then clicked the first explain link I saw next to the debug stats. Worked on every page I tried, even the sidebar.
__________________
My free mods~click here
Reply With Quote
  #10  
Old 23 Jul 2011, 22:22
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by Ziki View Post
Well I opened it up right away from the forum and then clicked the first explain link I saw next to the debug stats. Worked on every page I tried, even the sidebar.
Then you didn't open it up first in the Admin CP. That is where I tried it first.
Reply With Quote
  #11  
Old 24 Jul 2011, 06:00
ozzy47's Avatar
ozzy47 ozzy47 is offline
 
Join Date: Aug 2009
Real name: Chris
Excellent mod, installed and 5 stars.
Reply With Quote
  #12  
Old 24 Jul 2011, 09:35
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
Originally Posted by Boofo View Post
Then you didn't open it up first in the Admin CP. That is where I tried it first.
Went straight to admincp and still works for me, no matter what page I try :-/, I even installed a new forum on localhost to try it on and it still worked. Can you try it on a different forum?
__________________
My free mods~click here
Reply With Quote
  #13  
Old 24 Jul 2011, 11:03
Boofo's Avatar
Boofo Boofo is offline
 
Join Date: Mar 2002
Real name: Rob
Originally Posted by Ziki View Post
Went straight to admincp and still works for me, no matter what page I try :-/, I even installed a new forum on localhost to try it on and it still worked. Can you try it on a different forum?
I only clicked on it in the Admin CP. I never clicked on it in the fourms.
Reply With Quote
  #14  
Old 24 Jul 2011, 11:58
Ziki's Avatar
Ziki Ziki is offline
 
Join Date: Nov 2005
Yeah, I meant to try it on a different vB installation The explain feature works fine on my board even in the admincp.
__________________
My free mods~click here
Reply With Quote
  #15  
Old 29 Jul 2011, 19:19
Raeven Raeven is offline
 
Join Date: Aug 2010
Very useful indeed . Installed and Nominated .
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:10.

Layout Options | Width: Wide Color: