Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs Details »
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs
Mod Version: 2.5.6, by The Geek (Coder) The Geek is offline
Developer Last Online: Jan 2019 I like it Show Printable Version Email this Page

vB Version: 3.8.0 Rating: (192 votes - 4.75 average) Installs: 1968
Released: 20 Jan 2009 Last Update: 09 Dec 2009 Downloads: 12880
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

From the makers of the letters O and Yea comes the hottest 'must have mod' of the season: AME 2.5 - The Return of The Hot Mama.

Thanks everyone for making AME 2.5 Mod of the Month

AME is the multi award winning modification that smartly scans new and edited posts for URLs from a customisable variety of web sites (i.e. YouTube or Amazon or about 200 others). If it finds a match, AME will 'transform' the URL into inline embedded media without your users ever having to even think about it.

It was important for me to create a system that did not need updating (and subsequent reinstalling) every time one of the sites it supported decided to change the way it displayed its media (which is all the fricken time). Therefore I built a system in which the 'definitions' for each site could be imported, exported, tweaked and shared on a whim. This way, you only have to import the definitions that you want. It also allows the vB community to get creative and share definitions that I wouldn't of thought of!

Which sites are supported?

Included in the default installation is YouTube and Amazon. At time of posting this, I believe that there are over 180 sites supported that have been created by the vBulletin community. These range from sites that stream videos to Amazon referral links to locally hosted music and video files.

Check out the 'add ons' section of this post below to see availible add-ons.

For a total list of features and an FAQ, see click here.
For a post on troubleshooting, click here.

Though not tested on any version of vBulletin lower than 3.7.4, in theory it should work on versions 3.5 and higher (just dont quote this bit!).

Big thanks goes out to all those in the community that have supported this mod. Especially Digital Jedi who gives great support on this mod and has created over 160 definitions for this system alone!


Installation/Upgrade
  • Upload the contents of the forums folder into your forums directory and import the product-ame.xml file into your product manager (if upgrading, choose 'yes' to overwrite previous installation).
  • After installation, make sure that the system is on (admincp->AME CP->Settings)
  • Then you may want to try to rebuild old URLs via the tools option.

Change Log
nJoy

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	newpost.jpg
Views:	6632
Size:	26.4 KB
ID:	93148   Click image for larger version

Name:	newpost_result.jpg
Views:	9496
Size:	61.9 KB
ID:	93149  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases DJ's AMEs :: Media Definitions for AME 2.5 :: More Video, Twitter, Pinterest... Digital Jedi vBulletin 3.8 Add-ons 2086 05 Sep 2018 15:05
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 22:44
Show Thread Enhancements AME 2.0 -Auto Media Embedding for posts, blogs, visitor and group messsages The Geek vBulletin 3.7 Add-ons 954 25 May 2014 09:58
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 05:45

  #16  
Old 20 Jan 2009, 17:11
The Geek's Avatar
The Geek The Geek is offline
 
Join Date: Sep 2003
Sounds like there is an issue with the 'file checker'. I should have anticipated this

Basically, the #1 issue with previous versions was people actually not uploading the files (if you can believe that) so I made a tiny bit of code that would check to make sure the files had been uploaded first. Ill go tweak that code and update it. Give me a few
Reply With Quote
  #17  
Old 20 Jan 2009, 17:12
sdebank sdebank is offline
 
Join Date: Jun 2006
Getting the missing files error too.
Reply With Quote
  #18  
Old 20 Jan 2009, 17:14
Emunator Emunator is offline
 
Join Date: Oct 2007
Originally Posted by SemperFideles View Post
I had 2.5RC1 already installed and successfully working. I uploaded the contents of the forum folder to my directory (did this twice) but when I try to install the product I receive this error:
Same problem here.
Reply With Quote
  #19  
Old 20 Jan 2009, 17:14
smirkley smirkley is offline
 
Join Date: Apr 2008
Thanks for the upgrade to 3.8

Always a great mod, love it!

I am hoping that this may help my previously reported issue with the ame cp links faulting out.

But first, I went to install, and I get this error...
It seems like you are missing some of the required AME files.
Please upload the contents of the upload/forums folder into your forums directory before installing this modification.
I am using a just downloaded copy of ame 2.5, and the files included were uploaded to my server and overwritten, but something seems to be missing.

Thanks again.


edit - I sure must type slow lol, everyone above beat me to it.
Reply With Quote
  #20  
Old 20 Jan 2009, 17:14
Emunator Emunator is offline
 
Join Date: Oct 2007
Originally Posted by The Geek View Post
Sounds like there is an issue with the 'file checker'. I should have anticipated this

Basically, the #1 issue with previous versions was people actually not uploading the files (if you can believe that) so I made a tiny bit of code that would check to make sure the files had been uploaded first. Ill go tweak that code and update it. Give me a few
Thanks, really like this product.
Reply With Quote
  #21  
Old 20 Jan 2009, 17:15
tei727's Avatar
tei727 tei727 is offline
 
Join Date: Feb 2006
Originally Posted by The Geek View Post
Check the permissions of the files you just uploaded. Soesnt sound like your sever has permissions to execute them
i'm pretty sure i did everything correctly. i'll wait and see what everyone else gets.

Reply With Quote
  #22  
Old 20 Jan 2009, 17:17
MarkJW's Avatar
MarkJW MarkJW is offline
 
Join Date: Nov 2006
Marked as installed, marked the old 2.5RC1 thread as uninstalled, waiting on these leetle bugs to get fixed before I actually install, lol.

Thanks in advance.
Reply With Quote
  #23  
Old 20 Jan 2009, 17:22
Mihalis Mihalis is offline
 
Join Date: Nov 2008
Originally Posted by SemperFideles View Post
I had 2.5RC1 already installed and successfully working. I uploaded the contents of the forum folder to my directory (did this twice) but when I try to install the product I receive this error:
Same here! Whats the problem?
Reply With Quote
  #24  
Old 20 Jan 2009, 17:28
phreebsd phreebsd is offline
 
Join Date: Jul 2005
waiting on fix. currently in mixed state of uploaded new files but have not imported product xml due to the "missing files.. make sure you upload them all" error
Reply With Quote
  #25  
Old 20 Jan 2009, 17:32
jack the lad jack the lad is offline
 
Join Date: Mar 2007
I cannot figure out where the "amecache-Index" folder/file goes, is it in the forum root directory?

I also get the file missing message, but I put that down to me ballsing up the upgrade

Nice mod though. Cheers.
Reply With Quote
  #26  
Old 20 Jan 2009, 17:33
tei727's Avatar
tei727 tei727 is offline
 
Join Date: Feb 2006
Originally Posted by jack the lad View Post
I cannot figure out where the "amecache-Index" folder/file goes, is it in the forum root directory?

I also get the file missing message, but I put that down to me ballsing up the upgrade

Nice mod though. Cheers.
i think that is correct...
Reply With Quote
  #27  
Old 20 Jan 2009, 17:33
Pure Dope Pure Dope is offline
 
Join Date: Dec 2006
Importing Product, Please Wait...

[:]





vBulletin Message


It seems like you are missing some of the required AME files.
Please upload the contents of the upload/forums folder into your forums directory before installing this modification.
Reply With Quote
  #28  
Old 20 Jan 2009, 17:40
WreckRman2 WreckRman2 is offline
 
Join Date: Dec 2001
Real name: David Smith
I uploaded the files and tried to upload the xml. This is an upgrade from previous. I got the following error:

It seems like you are missing some of the required AME files.
Please upload the contents of the upload/forums folder into your forums directory before installing this modification.

I did upload the files correctly. Just FYI.


-------------

I wiped out the check for the files in the xml and it installed ok.
Reply With Quote
  #29  
Old 20 Jan 2009, 17:40
redlabour's Avatar
redlabour redlabour is offline
 
Join Date: Mar 2004
Real name: André
Originally Posted by The Geek View Post
Ill go tweak that code and update it. Give me a few
We can wait.
Reply With Quote
  #30  
Old 20 Jan 2009, 17:41
jack the lad jack the lad is offline
 
Join Date: Mar 2007
Originally Posted by tei727 View Post
i think that is correct...
Do you know if I need the folder or just the Index file?

Thanks.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 03:57.

Layout Options | Width: Wide Color: