Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 23 May 2017, 23:34
chikuru chikuru is offline
 
Join Date: Nov 2011
Wrong reset pass link

the reset pass link is not correct:

reset-password?userid=467&amp%3Bactivationid=

what could be the possible cause of this?
Thanks!
Reply With Quote
  #2  
Old 24 May 2017, 04:20
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
What version of vB5 are you using?
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #3  
Old 24 May 2017, 05:05
chikuru chikuru is offline
 
Join Date: Nov 2011
Originally Posted by noypiscripter View Post
What version of vB5 are you using?
5.2.2
Reply With Quote
  #4  
Old 24 May 2017, 16:14
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
You are using an old, unsecure and unsupported version. I highly recommend you to upgrade to the latest 5.3.0. Your issue might have been fixed already.
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #5  
Old 24 May 2017, 16:16
chikuru chikuru is offline
 
Join Date: Nov 2011
Originally Posted by noypiscripter View Post
You are using an old, unsecure and unsupported version. I highly recommend you to upgrade to the latest 5.3.0. Your issue might have been fixed already.
Issue still happens in 5.3
Reply With Quote
  #6  
Old 24 May 2017, 20:14
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
Does it also happen when you try to do password reset in vbulletin.com?
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #7  
Old 24 May 2017, 21:15
chikuru chikuru is offline
 
Join Date: Nov 2011
Originally Posted by noypiscripter View Post
Does it also happen when you try to do password reset in vbulletin.com?
Nope it does not.

Weird test replaced & from the link. It worked when I replaced the red text with &
reset-password?userid=467&amp%3Bactivationid=
Reply With Quote
  #8  
Old 24 May 2017, 23:06
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
Do you have custom translation for lostpw_gemailbody in the Phrase Manager in AdminCP? The wrong password reset url might be in your custom translation?
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #9  
Old 25 May 2017, 05:10
chikuru chikuru is offline
 
Join Date: Nov 2011
This is the content of that phrase:

Dear {1},

You have requested to reset your password on {2} because you have forgotten your password. If you did not request this, please ignore it. It will expire and become useless in 24 hours time.

To reset your password, please visit the following page:
{4}

Your username is: {1}

To edit your profile, first login with the parameters above. Then go to this page:
{3}/settings/profile

All the best,
{2}


Is there any way to edit the {4} ? Where can I see that? Because thats the part that causes the issue..
Reply With Quote
  #10  
Old 26 May 2017, 16:15
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
If you said the issue doesn't occur in vbulletin.com, then the issue must be specific to your setup. Do you have third-party mods that might be causing this? Did you modify any vBulletin PHP file?
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #11  
Old 27 May 2017, 03:10
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
What is your database collation and charset? And what do you have set for admincp > Languages & Phrases > Language Manager > Edit Settings > HTML Character Set ?
__________________
Former vBulletin.org Staff Member

Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #12  
Old 27 May 2017, 19:59
chikuru chikuru is offline
 
Join Date: Nov 2011
Originally Posted by Lynne View Post
What is your database collation and charset? And what do you have set for admincp > Languages & Phrases > Language Manager > Edit Settings > HTML Character Set ?
What is your database collation and charset:
latin1_german2_ci

Languages & Phrases > Language Manager > Edit Settings > HTML Character Set:
UTF-8

Any thoughts?
Reply With Quote
  #13  
Old 28 May 2017, 02:18
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
What email client are you using to read the password reset email? It might be messing up the reset URL in the email. Can you try resetting password for another user from another email client?
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
  #14  
Old 28 May 2017, 10:47
chikuru chikuru is offline
 
Join Date: Nov 2011
Originally Posted by noypiscripter View Post
What email client are you using to read the password reset email? It might be messing up the reset URL in the email. Can you try resetting password for another user from another email client?
I already tried and same issue.. Is it possible that the reset link was affected when we import a language?
Reply With Quote
  #15  
Old 28 May 2017, 19:20
noypiscripter's Avatar
noypiscripter noypiscripter is offline
 
Join Date: Aug 2013
Does the issue also happen in the default English language?
__________________
Glenn Vergara, an ex-vB Developer, now a vB Mod Developer

GIPHY for vB5 | AutoLinker | Video Attachments Player | New Registered Users Module | Clear System Cache Cron | DragNDrop Upload | Topic AJAX AutoUpdate | Force Read Topic
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:46.

Layout Options | Width: Wide Color: