Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
  #31  
Old 24 May 2005, 16:03
MrToasty MrToasty is offline
 
Join Date: May 2004
Real name: Warren
After 2 days of usage, the verdict is brilliant! I couldn't be more happy, as I've been waiting forever to be able to merge these 2 babies together...

My old Gallery1 albums all imported accross beautifully... the permissions I'm able to set for different usergroups is excellent... I'm over the moon...

Cheers Whodah! This should be turned into an official integration hack as soon as Gallery2 becomes RC or full release.
Reply With Quote
  #32  
Old 24 May 2005, 16:53
whodah whodah is offline
 
Join Date: Feb 2004
i'm glad you like it!

as an update: sounds like the mod_rewrite redirection method in integration is becoming obsolete and they're working on a session/cookie based method for multi-directory, multi-embeded (cms, whatever) and even... mutli-site! integration...

it should be up on the CVS soon from what i read on the gallery forums.

for the random block: i had it up on our site, then it was erroring out. i think i was initializing it wrong... but i think i've got it straightened out. a couple more days of testing and i'll post it!

hey, anyone doing this w/ G2b3?

if so - do your users get logged out of G2 after you 'surf around' G2 a bit?

after about 5 navigations through G2, my IE users are getting logged out. my FF users stay logged in. i was wondering if anyone can replicate this?

Last edited by whodah; 25 May 2005 at 16:47. Reason: Automerged Doublepost
Reply With Quote
  #33  
Old 26 May 2005, 01:50
ZED28 ZED28 is offline
 
Join Date: Aug 2004
Whodah,

I just went live with my site today and the one problem I'm having is with the other Admin.

Anyone else who logs into the site, Gallery2 creates an account automatically and then permissions can be set on the individuals album. However, when the other admin logs in, he gets the following error message and an account is never created for him:-

line: 107, G2 did not return a success status. Here is the error message from G2:
Error (GALLERY_SUCCESS)
in at line 0


Any idea what this could be?

Thanks bud!
Reply With Quote
  #34  
Old 26 May 2005, 02:35
Zeoran Zeoran is offline
 
Join Date: Oct 2001
Not working

I followed the instructions as requested, but I can't seem to get mine working.

www.guardianbrotherhood.org
www.guardianbrotherhood.org/forums (vb3)
www.guardianbrotherhood.org/forums/gallery2.php

My gallery install is in www.guardianbrotherhood.org/forums/gallery

and when I go to the php it gives me:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Any ideas?

Ok... it looks like it's working now, but it's not picking up the color scheme/theme of my main vb site.

Also, I'm curious how I can control the permissions of users for the gallery????

It's also not letting me upload any pictures to any of the albums... the remote won't download, the xp tab doesn't work, even the java applet complains about something..

HELP!!!

My members have been begging for a picture gallery and I have been DESPERATELY trying to get one working that doesn't cost a fortune. I'd even be willing to pay someone to help me get this working right on my site... just PLEASE help.

Last edited by Zeoran; 26 May 2005 at 06:28. Reason: Automerged Doublepost
Reply With Quote
  #35  
Old 26 May 2005, 16:35
whodah whodah is offline
 
Join Date: Feb 2004
ZED28: will your 2nd admin be entering the gallery stictly from vB3? i.e. will NOT be entering it through the standalone version? (not to be confused w/ accessing, we're talking entering here)

if so (and hopefully how it is!!) - i'd visit yer G2, delete the 2nd admin. then have the 2nd admin log on to vB3, click yer gallery2.php integration file, the integration script will then create the 2nd admin user.

you'll then have to go in as the 1st admin and edit the 2nd admin's account to make them an admin as at this point, they'd just be a regular user.

Zeoran: can you post your gallery2.php file and gallery2 template?
Reply With Quote
  #36  
Old 26 May 2005, 16:45
Zeoran Zeoran is offline
 
Join Date: Oct 2001
quick rundown:

my main site is www.zeoran.com. I'm running vb and the gallery on www.guardianbrotherhood.org which is a sub-domain pointer off my main site. So the web for guardianbrotherhood.org is under /home/guardian/public_html/gb/. I installed the gallery under the forums directory which is at www.guardianbrotherhood.org/forums/gallery.

here is my gallery2.php


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and here is the template I created


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

All I want is the simple stuff. I want the user db for the gallery to be integrated with my vb install. I want the gallery to pickup the colors/theme of my vb install. And I need to know why none of the picture uploading features are working and how I can control permissions and stuff to the albums with vb users.

Thank you.
Reply With Quote
  #37  
Old 30 May 2005, 14:41
kompakt's Avatar
kompakt kompakt is offline
 
Join Date: Dec 2004
Real name: Ahmad
Originally Posted by Zeoran
I want the gallery to pickup the colors/theme of my vb install.
Edit the theme.css file in your gallery templates directory and change colors as you desire to match the theme of your site. You could check the style manager for your vb skin to see the html color codes used on your skin.
Reply With Quote
  #38  
Old 31 May 2005, 02:03
ZED28 ZED28 is offline
 
Join Date: Aug 2004
Whodah,

I'm still tinkering with the admin problem I was having and that's on the back burner right now, I haven't heard from the guy to know if it's still a problem.

But on a totally unrelated note; I have changed my theme quite a bit and of course, the standard theme that comes with Gallery is not suitable so I changed the values in the Gallery CSS (Matrix) to make it fit my vBulletin theme. Well then I get to asking myself what I'm going to do if I want a different skin? LOL

So I tried something that just seemed too easy for words, I copied the entire contents of the Matrix theme.css file from Gallery and apended it to the "Additional CSS Definitions" section of the Main CSS for my theme, deleted or renamed the original style.css file in Gallery and voila!

Switch themes in VB and the Gallery does the same!

Now of course, you do have to create a matching CSS file for Gallery to match your chosen theme but once you have done that, copy the modified CSS as stated above and that should work!
Reply With Quote
  #39  
Old 31 May 2005, 05:03
whodah whodah is offline
 
Join Date: Feb 2004
Zeoran: i'm not seeing the problem

ZED28:
admin issue: roger that!
css: nice!!!
Reply With Quote
  #40  
Old 02 Jun 2005, 03:23
whodah whodah is offline
 
Join Date: Feb 2004
JimBean: thought of you today when i read that they are implementing subdomain support. it's not there yet, but they are working on it...

more info here:
http://gallery.menalto.com/index.php...wtopic&t=30959
Reply With Quote
  #41  
Old 14 Jun 2005, 01:12
whodah whodah is offline
 
Join Date: Feb 2004
an update!

i'm running a nightly build (from June 2nd) w/ core: 0.9.22

this includes the new url rewrite module - which works!

i had to hardcode some links though as the gallery url rewrite takes over the vB relative links.

so i had to make the relative links 'static' in 1 template and hard code a phrase too...

the phrase i had to edit was:
private_messages_nav

from:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

the template i had to edit was: navbar

and i changed all links that looked like:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

to:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

basically added:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in front of all of the links in that page that actually go somewhere. (not the # links) there's like 20 of 'em.

you can also do random blocks and such. i'm not sure the cleanest way to do it... i've done it on our site, but it uses vbadvanced. basically, look in the gallery site admin under:
Blocks -> Random/Popular

and note the 'External Image Block' section.

at some point in yer code, you need to call a php variable to get yer random block. since we cannot do this directly from templates, we have to do it in one of the .php files and then reference the variable which introduces a level of difficulty. for instance, as that page indicates, the code:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

will generate a random image. as you cannot call php from our templates, i kinda kludged this together w/ vbadvanced's help.

you can then get real jiggy w/ it by calling those links in yer postbit (or postbit_legacy in our case) to produce things like each users latest album or each users random pic.

an example is here, note beneath the posters' avatar:
http://www.cvreefers.org/showthread.php?t=2614

however, each time u look up a random pic, i get a delay on a p4 3.06 w/ 1 gig of ram. so if u have 10 users browsing 17 posts w/ 10 random pic genreators at once... well... u get the idea. actually read that thread if you want to see the outcome...

so - i'm using a cron job and a hidden field to do the tricks on that page.

i hesitate to mention those above tricks because i know the first thing that's going to be asked is 'how did you do this?' and it's pretty entailed. to get the user's gallery links beneath each user involves naming an album identicle to that user, creating two hidden user profile fields, and setting up a cron job. for the daily random block, another hidden user profile field, and another cron job. i really doubt that i'm doing it 'the right way' nor the most eloquant nor the most effecient way. heck, i'm establishing my own mysql connection on those cron jobs and i'm sure i could mooch off of vB's connection if i researched how, heh! so i just wanted to show that it can be done if that makes sence! i'm sure someone more advanced then i could make it generically fit any vB install.
Reply With Quote
  #42  
Old 23 Jul 2005, 21:09
zylstra zylstra is offline
 
Join Date: Aug 2004
Originally Posted by whodah
b) the menu to the left to add/edit/delete items is not appearing for all users... again - i've yet to dig too deep into this.
whodah,

I just signed up for your forum at cvreefers.org and can't see the add/edit/delete menu. I thought you fixed it with post #12. Did you perhaps overwrite your last mods?

Thanks.
Reply With Quote
  #43  
Old 24 Jul 2005, 04:30
whodah whodah is offline
 
Join Date: Feb 2004
that all works fine now. i'd imagine it's cause you don't have permissions on any album to add things



i setup a test album w/ permissions for your account:
http://www.cvreefers.org/v/CVR_membe...c/whodah_test/
Reply With Quote
  #44  
Old 30 Jul 2005, 15:41
ZED28 ZED28 is offline
 
Join Date: Aug 2004
Whodah,

Thanks for the update! I DO watch this thread to keep abreast of your progress and try to implement your changes/suggestions as soon as I get the chance.

I've implemented the re-write module and have modified the links in VB so that the re-write doesn't screw them up, this all works as expected. I still have a nagging problem (and this is the only real reason I want re-write) where extra crap is tagged onto the end of the shorter URL's - after the jpg extension:-

http://www.gmlsxs.org/d/4376-2/DSCN2...4cfff638c4e698


Now if I view the Gallery in stand-a-lone mode, the link looks like this:-

http://www.gmlsxs.org//gallery2/d/4376-2/DSCN2202.JPG


Both of these links will work if you click on them, the downside for me is that when used inside VB, I can't get the URL's to appear without the crap at the end. Of course, if you simply copy up to the JPG extension, this works - I just don't wanna explain how to do that to all our members over and over and over... LOL

I looked at your Gallery implementation and noticed you have the same problem too.

I also installed the module for displaying the URL's for BB Code and HTML from Gallery's site. I noticed you were involved in that and I've had a few issued with that also (didn't generate the shorter URL's, still added the crap at the end anyways) so I may or may not use that.

Any help you could provide would be greatly appreciated. BTW, thanks for sticking with this, it's an excellent integration!

You can view my Gallery2 install using the following links (same Gallery install)

http://www.gmlsxs.org/gallery2.php? <-- Integrated
http://www.gmlsxs.org/gallery2/main.php <-- Stand-a-lone


An Update:

Whodah, stop the press! LOL The nice folk at Menalto's Gallery have clued me in on this problem, see the following (a simple fix!)

http://gallery.menalto.com/index.php...wtopic&t=33488

Thanks bud!

Last edited by ZED28; 30 Jul 2005 at 16:21. Reason: Automerged Doublepost
Reply With Quote
  #45  
Old 30 Jul 2005, 21:16
whodah whodah is offline
 
Join Date: Feb 2004
heya Zed28!

cool beans!

can you show me on my site an example of the issue you were talking about resolved by the cookie settings? i cannot find an example and would like to straighten it out on my site!

also - the URLs/BBCODE: VERY VERY VERY nifty module!! i'll be revisiting it again here shortly to add some other fixes. time has been short for me lately, heh!

cya, and thx!
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 17:30.

Layout Options | Width: Wide Color: