Register Members List Search Today's Posts Mark Forums Read

Reply
 
Article Options
  #46  
Old 22 Oct 2005, 22:00
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
You must use the Code as Product install Code.
Reply With Quote
  #47  
Old 22 Oct 2005, 23:34
harmor19 harmor19 is offline
 
Join Date: Apr 2005
Real name: Andrew Harmor
It was in a product but removed the plugin tags around it.

when I upload the product I get this error


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Attached Files
File Type: xml bitfield_testimonials.xml (336 Bytes, 17 views)
File Type: xml product-testimonials.xml (6.6 KB, 18 views)

Last edited by harmor19; 22 Oct 2005 at 23:39.
Reply With Quote
  #48  
Old 23 Oct 2005, 01:01
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
Did you create the product XML by hand?
There is almost no chance the product manager would generate smth. like that ...
Attached Files
File Type: xml bitfield_testimonials.xml (347 Bytes, 36 views)
File Type: xml product-testimonials_correct.xml (6.5 KB, 34 views)
Reply With Quote
  #49  
Old 23 Oct 2005, 01:19
harmor19 harmor19 is offline
 
Join Date: Apr 2005
Real name: Andrew Harmor
Well I took references frommy other product xml's.

Thanks.

Now I'm on to update my testimonials mod.

Last edited by harmor19; 23 Oct 2005 at 01:21.
Reply With Quote
  #50  
Old 28 Oct 2005, 23:32
akanevsky akanevsky is offline
 
Join Date: Apr 2005
Real name: Anton Kanevsky
Hi, this is the XML I'm trying to use:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

On save, it says "Warning: mysql_real_escape_string() expects parameter 1 to be string, array given in /includes/class_core.php on line 635... why?
__________________
I can no longer support any of my hacks. Please do not contact me for that. Feel free to create and post new versions of my hacks, as long as you give me credit for the original work.
Reply With Quote
  #51  
Old 28 Oct 2005, 23:36
harmor19 harmor19 is offline
 
Join Date: Apr 2005
Real name: Andrew Harmor
download the xml's Andreas did for me and look off of those.
Reply With Quote
  #52  
Old 28 Oct 2005, 23:39
akanevsky akanevsky is offline
 
Join Date: Apr 2005
Real name: Anton Kanevsky
I don't see any difference other than the group used, and I don't think that's what causes the problem.

Ok, figured that I needed to rebuild bitfields.. But it still does not save.
__________________
I can no longer support any of my hacks. Please do not contact me for that. Feel free to create and post new versions of my hacks, as long as you give me credit for the original work.

Last edited by akanevsky; 28 Oct 2005 at 23:46. Reason: Automerged Doublepost
Reply With Quote
  #53  
Old 28 Oct 2005, 23:56
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
vbulletin, NOT vBulletin - better yet use your own product id.
Reply With Quote
  #54  
Old 29 Oct 2005, 00:06
akanevsky akanevsky is offline
 
Join Date: Apr 2005
Real name: Anton Kanevsky
I changed the product ID to my own. There are no results though.

As I said, after sumbitting the usergroup options, it says "usergroup X saved", but then after I reload the page, the option is back to "off" (as it was originally)... My latest XML:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
I can no longer support any of my hacks. Please do not contact me for that. Feel free to create and post new versions of my hacks, as long as you give me credit for the original work.
Reply With Quote
  #55  
Old 29 Oct 2005, 00:17
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
Did you rebuild the bitfield cache?
Reply With Quote
  #56  
Old 29 Oct 2005, 00:18
akanevsky akanevsky is offline
 
Join Date: Apr 2005
Real name: Anton Kanevsky
Yes. Using the admincp navbar link in debug mode.

Figured: The problem was that I specified invalid decimal bitfield value. Now it is working (after I changed 0 to 1).
__________________
I can no longer support any of my hacks. Please do not contact me for that. Feel free to create and post new versions of my hacks, as long as you give me credit for the original work.

Last edited by akanevsky; 29 Oct 2005 at 00:29. Reason: Automerged Doublepost
Reply With Quote
  #57  
Old 29 Oct 2005, 16:38
Mr Blunt Mr Blunt is offline
 
Join Date: Jan 2004
I don't think '' and '0' are valid bitfield values.

1st bitfield should have value of 1
2nd should have 2
3rd should have 4
4th should have 8
5th should have 16
and so on....
Reply With Quote
  #58  
Old 29 Oct 2005, 17:25
akanevsky akanevsky is offline
 
Join Date: Apr 2005
Real name: Anton Kanevsky
Yes, I already figured that, thanks.
It should be mentioned in the first post though.
__________________
I can no longer support any of my hacks. Please do not contact me for that. Feel free to create and post new versions of my hacks, as long as you give me credit for the original work.
Reply With Quote
  #59  
Old 29 Oct 2005, 21:45
Andreas's Avatar
Andreas Andreas is offline
 
Join Date: Jan 2004
Real name: Andreas
I assumed everybody knows how the binary system works
Reply With Quote
  #60  
Old 29 Oct 2005, 22:12
akanevsky akanevsky is offline
 
Join Date: Apr 2005
Real name: Anton Kanevsky
Even if yes, it is not mentioned that XML uses binary data as the values. YOu did not specify what to put between the tags
__________________
I can no longer support any of my hacks. Please do not contact me for that. Feel free to create and post new versions of my hacks, as long as you give me credit for the original work.
Reply With Quote
Reply

Similar Article
Article Author Type Replies Last Post
Custom Usergroup/Forum Permissions joefitz vBulletin 3.5 Add-ons 8 14 Feb 2011 19:23



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Article Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 04:17.

Layout Options | Width: Wide Color: