Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs Details »
AME 2.5 - Media Embedding for posts, sigs, vm's, groups and blogs
Mod Version: 2.5.6, by The Geek (Coder) The Geek is offline
Developer Last Online: Jan 2019 I like it Show Printable Version Email this Page

vB Version: 3.8.0 Rating: (192 votes - 4.75 average) Installs: 1968
Released: 20 Jan 2009 Last Update: 09 Dec 2009 Downloads: 12886
Not Supported DB Changes Uses Plugins Template Edits Additional Files  

From the makers of the letters O and Yea comes the hottest 'must have mod' of the season: AME 2.5 - The Return of The Hot Mama.

Thanks everyone for making AME 2.5 Mod of the Month

AME is the multi award winning modification that smartly scans new and edited posts for URLs from a customisable variety of web sites (i.e. YouTube or Amazon or about 200 others). If it finds a match, AME will 'transform' the URL into inline embedded media without your users ever having to even think about it.

It was important for me to create a system that did not need updating (and subsequent reinstalling) every time one of the sites it supported decided to change the way it displayed its media (which is all the fricken time). Therefore I built a system in which the 'definitions' for each site could be imported, exported, tweaked and shared on a whim. This way, you only have to import the definitions that you want. It also allows the vB community to get creative and share definitions that I wouldn't of thought of!

Which sites are supported?

Included in the default installation is YouTube and Amazon. At time of posting this, I believe that there are over 180 sites supported that have been created by the vBulletin community. These range from sites that stream videos to Amazon referral links to locally hosted music and video files.

Check out the 'add ons' section of this post below to see availible add-ons.

For a total list of features and an FAQ, see click here.
For a post on troubleshooting, click here.

Though not tested on any version of vBulletin lower than 3.7.4, in theory it should work on versions 3.5 and higher (just dont quote this bit!).

Big thanks goes out to all those in the community that have supported this mod. Especially Digital Jedi who gives great support on this mod and has created over 160 definitions for this system alone!


Installation/Upgrade
  • Upload the contents of the forums folder into your forums directory and import the product-ame.xml file into your product manager (if upgrading, choose 'yes' to overwrite previous installation).
  • After installation, make sure that the system is on (admincp->AME CP->Settings)
  • Then you may want to try to rebuild old URLs via the tools option.

Change Log
nJoy

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	newpost.jpg
Views:	6637
Size:	26.4 KB
ID:	93148   Click image for larger version

Name:	newpost_result.jpg
Views:	9502
Size:	61.9 KB
ID:	93149  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Add-On Releases DJ's AMEs :: Media Definitions for AME 2.5 :: More Video, Twitter, Pinterest... Digital Jedi vBulletin 3.8 Add-ons 2086 05 Sep 2018 16:05
Add-On Releases Digital Sith's AMEs - ADULT Media Definitions Digital Sith vBulletin 3.6 Add-ons 66 08 Sep 2015 23:44
Show Thread Enhancements AME 2.0 -Auto Media Embedding for posts, blogs, visitor and group messsages The Geek vBulletin 3.7 Add-ons 954 25 May 2014 10:58
Add-On Releases DJ's AME (Auto Media Embedding) XML Media Definitions (Third Time's the Charm) Digital Jedi Modification Graveyard 828 10 Mar 2010 06:45

  #151  
Old 27 Jan 2009, 20:45
Deimos Deimos is offline
 
Join Date: Oct 2002
Does anyone else have problems with this plugin taking an AGE to embed a video?
For instance, when I embed a youtube video in a new thread, it takes upwards of 20 seconds for the post to submit
Any suggestions?
Reply With Quote
  #152  
Old 27 Jan 2009, 21:30
JorgeX JorgeX is offline
 
Join Date: Oct 2005
DId AME 2.0 automaccally updated to 2.5 on my forum? It says "Version: 2.5" when i installed the 2.02


Also when i post i get this message:



Warning: fetch_full_ameinfo([path]/amecache/findonly.php) [function.fetch-full-ameinfo]: failed to open stream: No such file or directory in [path]/includes/ame_bbcode.php on line 74

Warning: fetch_full_ameinfo([path]/amecache/findonly.php) [function.fetch-full-ameinfo]: failed to open stream: No such file or directory in [path]/includes/ame_bbcode.php on line 74

Warning: fetch_full_ameinfo() [function.include]: Failed opening '[path]/amecache/findonly.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in [path]/includes/ame_bbcode.php on line 74
Reply With Quote
  #153  
Old 27 Jan 2009, 22:58
jellybeanz jellybeanz is offline
 
Join Date: Sep 2003
I'm having issues getting my youtube links to embed automatically. It works fine when I enter a link using [ame]youtube link[/ame]. Posting other videos like gametrailers, photopost, and cnn videos autoembed with no issues.

I've removed the ame code, deleted/reuploaded all files, and uninstalled/reinstalled using rebuild with no luck. I'm not sure if it makes a difference but I'm using DJ's AME definitions.

Any help is appreciated.
Reply With Quote
  #154  
Old 27 Jan 2009, 23:53
fkatzenb fkatzenb is offline
 
Join Date: Dec 2005
Thanks for the great plug in. I have converted my old Goldbrick posts without issue. Awesome. Now for the problem. Before I had Goldbrick, I used an embedded thing that used the following as an example...
[YOUTUBE="Warrant - Uncle Tom's Cabin"]te1iSbyaR9I[/YOUTUBE]

Well now, I tried converting it and it finds posts, but says "huh... no changes?" The posts it lists are correct, but it doesn't change anything

Help? Thanks!
__________________
Frank Katzenberger
Turbo Mopar Forums
http://www.turbo-mopar.com
Reply With Quote
  #155  
Old 28 Jan 2009, 00:19
Phaedrus Phaedrus is offline
 
Join Date: Aug 2006
How is it I've missed this for so long? My word...
Reply With Quote
  #156  
Old 28 Jan 2009, 00:26
Digital Jedi's Avatar
Digital Jedi Digital Jedi is offline
 
Join Date: Oct 2006
Real name: Mark Daniel Martinez
Originally Posted by Deimos View Post
Does anyone else have problems with this plugin taking an AGE to embed a video?
For instance, when I embed a youtube video in a new thread, it takes upwards of 20 seconds for the post to submit
Any suggestions?
I've not encountered any slowdown with AME myself. In fact, it's faster then BBCode. Perhaps the issue is the YouTube site being slow at certain times?


Originally Posted by JorgeX View Post
DId AME 2.0 automaccally updated to 2.5 on my forum? It says "Version: 2.5" when i installed the 2.02


Also when i post i get this message:



Warning: fetch_full_ameinfo([path]/amecache/findonly.php) [function.fetch-full-ameinfo]: failed to open stream: No such file or directory in [path]/includes/ame_bbcode.php on line 74

Warning: fetch_full_ameinfo([path]/amecache/findonly.php) [function.fetch-full-ameinfo]: failed to open stream: No such file or directory in [path]/includes/ame_bbcode.php on line 74

Warning: fetch_full_ameinfo() [function.include]: Failed opening '[path]/amecache/findonly.php' for inclusion (include_path='.:/usr/lib/php:/usr/local/lib/php') in [path]/includes/ame_bbcode.php on line 74
Do you have any other admins that may have tried to upgrade the product? It can't update on it's own. Make sure ame_bbcode.php and all your AME files uploaded to the right place on the server.


Originally Posted by jellybeanz View Post
I'm having issues getting my youtube links to embed automatically. It works fine when I enter a link using [ame]youtube link[/ame]. Posting other videos like gametrailers, photopost, and cnn videos autoembed with no issues.

I've removed the ame code, deleted/reuploaded all files, and uninstalled/reinstalled using rebuild with no luck. I'm not sure if it makes a difference but I'm using DJ's AME definitions.

Any help is appreciated.
When you imported my definitions, did you remember to delete the stock YouTube definition first? Mine won't import on this new version if you don't, and the import process won't stop you if you imported a bunch of other defs successfully at the same time.


Originally Posted by fkatzenb View Post
Thanks for the great plug in. I have converted my old Goldbrick posts without issue. Awesome. Now for the problem. Before I had Goldbrick, I used an embedded thing that used the following as an example...
[YOUTUBE="Warrant - Uncle Tom's Cabin"]te1iSbyaR9I[/YOUTUBE]

Well now, I tried converting it and it finds posts, but says "huh... no changes?" The posts it lists are correct, but it doesn't change anything

Help? Thanks!
Have you checked the code in the non-converted posts to see if they in fact still have the [youtube] BBCode in them and that Goldbrick didn't do something funny upon uninstall?
__________________
Reply With Quote
  #157  
Old 28 Jan 2009, 00:45
jellybeanz jellybeanz is offline
 
Join Date: Sep 2003
Originally Posted by Digital Jedi View Post
When you imported my definitions, did you remember to delete the stock YouTube definition first? Mine won't import on this new version if you don't, and the import process won't stop you if you imported a bunch of other defs successfully at the same time.
Yes, I deleted the stock amazon and youtube definitions. The definition is fine and still works but manually only. Just trying to find out if there is something wrong with my board or installation.
Reply With Quote
  #158  
Old 28 Jan 2009, 01:33
Phaedrus Phaedrus is offline
 
Join Date: Aug 2006
I'm having database issues after loading this. When I try to save my Usergroup settings it gives me database errors. What is happening?

This is the MySql error:

MySQL Error : Unknown column 'ms_searchsocialgroups_permissions' in 'field list'

Last edited by Phaedrus; 28 Jan 2009 at 01:46.
Reply With Quote
  #159  
Old 28 Jan 2009, 02:12
Gladhatter Gladhatter is offline
 
Join Date: Oct 2008
Location: Clintwood VA
Real name: Charlie Swindall
Originally Posted by fkatzenb View Post
Thanks for the great plug in. I have converted my old Goldbrick posts without issue. Awesome. Now for the problem. Before I had Goldbrick, I used an embedded thing that used the following as an example...
[YOUTUBE="Warrant - Uncle Tom's Cabin"]te1iSbyaR9I[/YOUTUBE]

Well now, I tried converting it and it finds posts, but says "huh... no changes?" The posts it lists are correct, but it doesn't change anything

Help? Thanks!

Not sure but I would like to suggest the problem may be with the < ' > single quote.
__________________
Visit the SBS to learn about traditional hat making skills and the finest pure sterling beaver custom handmade bespoke commissioned hats in the universe. www.gladhatter.com.
Reply With Quote
  #160  
Old 28 Jan 2009, 03:22
Phaedrus Phaedrus is offline
 
Join Date: Aug 2006
Originally Posted by Phaedrus View Post
I'm having database issues after loading this. When I try to save my Usergroup settings it gives me database errors. What is happening?

This is the MySql error:

MySQL Error : Unknown column 'ms_searchsocialgroups_permissions' in 'field list'
Well, I just added that table field list where it kept trying to find it. It works.
Reply With Quote
  #161  
Old 28 Jan 2009, 04:06
Gladhatter Gladhatter is offline
 
Join Date: Oct 2008
Location: Clintwood VA
Real name: Charlie Swindall
Originally Posted by Phaedrus View Post
Well, I just added that table field list where it kept trying to find it. It works.

Have you read the bug list that is fixed in 3.81? I think you will find your answer there.
__________________
Visit the SBS to learn about traditional hat making skills and the finest pure sterling beaver custom handmade bespoke commissioned hats in the universe. www.gladhatter.com.
Reply With Quote
  #162  
Old 29 Jan 2009, 02:52
Armyqt Armyqt is offline
 
Join Date: Jan 2009
I installed this but I don't see an AME CP.
Reply With Quote
  #163  
Old 29 Jan 2009, 05:03
JulianD's Avatar
JulianD JulianD is offline
 
Join Date: Jan 2002
Real name: Julian Muņoz
My god, I can't believe there are such great modifications still depending on modifying the post table. Do you know what it takes to do an ALTER TABLE to a table with millions of records?
__________________
Julian D. Muņoz
Reply With Quote
  #164  
Old 29 Jan 2009, 05:29
Gladhatter Gladhatter is offline
 
Join Date: Oct 2008
Location: Clintwood VA
Real name: Charlie Swindall
Originally Posted by JulianD View Post
My god, I can't believe there are such great modifications still depending on modifying the post table. Do you know what it takes to do an ALTER TABLE to a table with millions of records?
Well I am going way out on a limb here and going to say that about millions of us have not a clue of what it takes to alter a table with millions of records.

I could suggest a small earth quake under the building with that table full or LP's or possibly 45's on it may well alter it.

Now I do have a couple sincere questions here however.
  1. Are you intimating by your post that altering a table with a mod is a poor coder choice of methodoloy?
  2. You seem to find favor with the mod and yet some slanting there is a bad method used in the fruition of making this all happen in heavily populated tables. What I am concerned about is really two fold.
  • One is if you think this is a poorly written program do you also have a solution to it or are you a problem only type coder that sees others mistakes but has no valid solution to share with the class?
  • Have I some how misunderstood your post and you find all things about this mod of a pleasing nature?
  • If the first assumption is the correct one, will you tell us your proposed solution for it?
  • If above is true, do you plan on releasing the "fix" for this and if so when is the anticipated release date?
  • Further and probably finally, do you have some mods you have created with similar complexity so we can see your brilliance in work and not just in word?
  • Really finally now, I am convinced this mod is a God send and a wonderful one that brings enjoyment to all that either know how to install it and negotiate the hurdles they run into or else the ones that choose a professional programmer to install it for them and they simply or complexly enjoy it period. Do you think you may be a bit harsh should you be judging the mod is poorly written and not offering any valid solutions for the fix of it and have coder as your title?
Just curious you please understand.

Oh and if you can make it work on wimp.com then I will join your cause! Help DJ and GEEK.
__________________
Visit the SBS to learn about traditional hat making skills and the finest pure sterling beaver custom handmade bespoke commissioned hats in the universe. www.gladhatter.com.
Reply With Quote
  #165  
Old 29 Jan 2009, 06:11
JulianD's Avatar
JulianD JulianD is offline
 
Join Date: Jan 2002
Real name: Julian Muņoz
I understand your sarcastic tone and let me tell you it's not my intention to criticize the author's work. I know his work because I used to be his customer. I haven't seen the source code to even understand how it works and I don't plan to do it.

My point is that not everyone has super fast arrays of hard disks to modify a big table in a reasonable amount of time. I'm sure there are other ways to approach the same solution. Saddly I don't have the time to do it right now.

My mysql server has spent over an hour altering that table. That's my point. There's nothing wrong in altering a table but the post table as well as the attachment table or the search table are usually very big tables on big forums. I think it's something to care about when developing the mod.

Any way, I'm not killing the alter table process. I'm sure it's a great product and I want to see it for my self. But I'm not even done installing it and I'm already thinking about the nightmare when I have to uninstall it in the future.
__________________
Julian D. Muņoz
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 23:02.

Layout Options | Width: Wide Color: