Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 25 Mar 2010, 03:19
nnStaff nnStaff is offline
 
Join Date: May 2009
Problem using construct_usercp_nav and phrases

I am tweaking an old plugin that worked just fine in 3.8.x, for 4.0. The plugin is running out of misc.php, and calling construct_usercp_nav. Strange thing though, about 1/3 of the phrases used to construct the menu are empty, so it's not constructing the full menu. I've double and triple-checked the code and it isn't setting $vbphrase anywhere, so I don't know if it's somehow not caching the phrases, or if they're somehow getting blanked out.

Is it possible I need to "enable" these phrases? How is it that some work and some don't?

--------------- Added 25 Mar 2010 at 03:22 ---------------

edit: here's a snapshot of what I'm talking about. If you compare that to a typical, admin usercp, it's missing several entries. If you look at the source code, all the code to generate the full menu is there, but there are blanks where the text should be, hence the vbphrase is not working

Last edited by nnStaff; 25 Mar 2010 at 03:22. Reason: Auto-Merged DoublePost
Reply With Quote
  #2  
Old 25 Mar 2010, 15:10
JulianD's Avatar
JulianD JulianD is offline
 
Join Date: Jan 2002
Real name: Julian Muņoz
Are you loading the correct phrase groups? I think there is a hook to do this.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Julian D. Muņoz
Reply With Quote
  #3  
Old 25 Mar 2010, 16:11
nnStaff nnStaff is offline
 
Join Date: May 2009
Originally Posted by JulianD View Post
Are you loading the correct phrase groups? I think there is a hook to do this.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
that's what I think I was doing wrong, but I didn't know the hook to try and add to $phrasegroups. Additionally, isn't it weird that it would load some and not others? Wouldn't they all be a part of the same group?
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 20:34.

Layout Options | Width: Wide Color: