Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 07 Oct 2019, 04:41
amart79196 amart79196 is offline
 
Join Date: Oct 2019
database migrating

Hi all, i have a very strange and difficult issue that i am trying to get working.

My site was hacked on September 25th 2019, i have a backup of it and the database. I store everything in the database. At the time of the hack, i was running 5.5.1.

Since then, i have completely reset the cpanel at my web hosting company starting 100% fresh and new. I downloaded 5.5.4 patch2 and installed it with a brand new database. I also went into the admincp and setup all the settings that needed to be setup for my site so i would have a completely new and fresh setup.

Now that I have that part completed, I wanted to get my content back online.

A few ways I thought of doing this was:
1. restore the old database
-I tried this and found that the database data would show up but for some reason my header logo would not allow me to put one up. it gave an error and asked to try again.
2. MY second idea was the export the database complete from the old forum and import it to the new database on the new forum.
-I tried this and also found similar issues.

So, a have a few MAIN questions:

1. By using the old ENTIRE database, by restoring it completely, does that effect any of the adminCP front end setting that I setup during my rebuild? Does it overwrite or change any of those setting that i setup? Any ideas as to what could be causing the logo header to disappear and not be allowed to upload the logo again to restore it?

2. Is there a way to just grab Threads/Posts/Images/attachments/Users/avatars and anything else you could suggest since maybe the complete database restore is messing things up?

If number 2 would be the best way, I would like to explore that and do that as i feel more confident that it would play better with the new forum, although i could be totally mistaken.

Many thanks in advance for all of your help!

Last edited by amart79196; 07 Oct 2019 at 04:57.
Reply With Quote
  #2  
Old 07 Oct 2019, 13:19
Dave Dave is online now
 
Join Date: Jun 2010
Real name: Dave
Generally what should work fine is:
1. Restore the database backup.
2. Upload the new forum files to the server.
3. Run the upgrade script.
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 21:35.

Layout Options | Width: Wide Color: