Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 18 Jun 2018, 07:10
msoms's Avatar
msoms msoms is offline
 
Join Date: Sep 2006
DB Transfer Encoding issues

Hello,

I am facing an issue that took a while for me now and am not moving any where and got stuck. I have vB 4.2.5 with DB size of around 6.5 GB. I am changing to a new server and I have already migrated all my other sites (wordpress based) with no issues at all and they work just the way they should.

I followed the normal mysqldump commands to backup and restore several times and in several types however, the site will always show strange text encoding.
Both servers use MySQL correct versions and PHP7.
I can't seem to figure out what is wrong exactly.

The old server was CENTOS 6 with CPANEL and the new server is DEBIAN 9 with ISPCONFIG ,does that have any issue? Does MariaDB in new server has an effect on normal mysql in old server? both server encoding is UTF-8

I am lost and already initated a support request with vb team but no response till now.


Can you please help?
Reply With Quote
  #2  
Old 18 Jun 2018, 08:48
Dave Dave is offline
 
Join Date: Jun 2010
Real name: Dave
Where does it show the strange text encoding? Do you have a screenshot?
Do posts also look messed up? If you check the post table in the database, does it look fine there?
__________________
https://technidev.com - security, development, exploits, vBulletin
dave[at]technidev[dot]com

Contact me for custom vBulletin 3/4 work & server/website management.
Reply With Quote
  #3  
Old 18 Jun 2018, 09:04
msoms's Avatar
msoms msoms is offline
 
Join Date: Sep 2006
The whole site encoding is messed up! Not a single line is showing correctly, however on the db side it is ok.

I tried changing the charset for the installed languages and I can see some changes in the messed up text but no luck in making it work.

I will arrange for a screen shot in the mean while
Reply With Quote
  #4  
Old 18 Jun 2018, 09:34
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
Is there a php.ini in the domains public_html folder, verify it dont have a charset setting in it.

Plesk is known to do that with their inserting a charset by default in an account.
Reply With Quote
  #5  
Old 18 Jun 2018, 09:58
msoms's Avatar
msoms msoms is offline
 
Join Date: Sep 2006
Originally Posted by snakes1100 View Post
Is there a php.ini in the domains public_html folder, verify it dont have a charset setting in it.

Plesk is known to do that with their inserting a charset by default in an account.
No there isn't, I am using ISPConfig 3 control panel not Plesk.
__________________
Regards,
Mohammed
msoms-anime.net
Reply With Quote
  #6  
Old 19 Jun 2018, 03:39
webmastersun's Avatar
webmastersun webmastersun is offline
 
Join Date: Oct 2013
Originally Posted by msoms View Post
I followed the normal mysqldump commands to backup and restore several times and in several types however, the site will always show strange text encoding.
There are some works to do before moving your database to a new server that support and keep same encode, that is:
- Select utf8 unicode ci for your database.
- Enable force to use utf8 in your config file
- Change encode to utf8 in your tool/program that you are using to move your database.

This will help you to avoid errors about special characters/symbol when moving vB databases.
__________________
The best webmaster forum & internet marketing forum for webmasters and internet marketers.
Reply With Quote
  #7  
Old 19 Jun 2018, 08:41
snakes1100 snakes1100 is offline
 
Join Date: Dec 2001
Real name: Anthony
Originally Posted by msoms View Post
No there isn't, I am using ISPConfig 3 control panel not Plesk.
I didnt say you was using plesk.
Reply With Quote
Reply


Tags
database, encoding, issue, server


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 17:42.

Layout Options | Width: Wide Color: