Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Usergroup Legend with Links To FAQ Details »
Usergroup Legend with Links To FAQ
Mod Version: 1.3, by MarkFL (Coder) MarkFL is offline
Developer Last Online: May 2020 I like it Show Printable Version Email this Page

vB Version: 4.x.x Rating: (4 votes - 5.00 average) Installs: 24
Released: 24 Dec 2015 Last Update: 02 Jan 2017 Downloads: 202
Not Supported Uses Plugins Translations  

Overview:

This product allows you to display a legend of selected usergroups in your WGO block, directly below the list of users who have visited the site recently. You may link each usergroup name to an FAQ item if you have such items defined to describe certain usergroups. You may choose to strip the trailing "s" from the usergroup names in case the usergroup names are plural, but you want the singular to show in the legend. You may choose to simply delimit the list with commas, or choose one from 10 special characters, or enter you own custom character(s). You may choose the size of the delimiter as a percentage of the default font-size. You may assign any custom CSS to the legend's usergroup list.



Updates:

Version 1.1:
  • Added setting for the control of the delimiter CSS.

Version 1.2:
  • Legend is only visible for users that can either see who is online or can see who has visited.

Version 1.2.1:
  • Fixed bug with diamond delimiter.

Version 1.3:
  • Added setting to allow for image as custom delimiter.

Compatibility:

Tested and working on VB 4.2.x and should work on all 4.x versions of vBulletin.

Backup/Warning:

This product does not alter your database, however it is always good practice to make regular backups and you should make a backup before installing ANY new mod.

As always, products are USE AT YOUR OWN RISK. I will provide support and do my best to help but no absolute guarantee is offered.

To Install:
  1. Download and extract the attached .zip file.
  2. Follow AdminCP -> Plugins & Products -> Manage Products -> Add/Import Product.
  3. Click on "Choose File" and browse to the product .xml file that was packaged in the .zip file.
  4. Click "Import."
  5. You MUST enable the product in the settings before it will function.
  6. Configure the remaining settings to your liking. Each setting has a detailed explanation of its use.



Support for this product can be found here:

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	markfl_usergroup_legend.png
Views:	821
Size:	17.4 KB
ID:	153878   Click image for larger version

Name:	markfl_usergroup_legend_acp.jpg
Views:	358
Size:	85.7 KB
ID:	155632  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
[RELEASE v.2.x.x] Additional FAQ Hack (FAQ edit) Stasik vBulletin 2.x Full Releases 29 09 Sep 2001 00:31

  #31  
Old 31 Dec 2016, 01:10
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
What does your complete "FORUMHOME" template have?
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #32  
Old 31 Dec 2016, 01:18
Snowhog's Avatar
Snowhog Snowhog is offline
 
Join Date: Oct 2011
Real name: Paul L
I think I "see" my problem.

My modification placed my legend below Currently Active Users. I keep Total members that have visited the forum in the last 24 hours: minimized, so I wouldn't have seen your legend. << Update: Not true. I just didn't notice the new 'section'. ;/

If I want your legend to show in place of mine; below Currently Active Users; what change to the .xml would I have to make?
__________________
"It is a capital mistake to theorize in advance of the facts." - Sherlock Holmes
Kubuntu Forums . Net | ZB BLOCK | StopForumSpam

Last edited by Snowhog; 31 Dec 2016 at 01:41.
Reply With Quote
  #33  
Old 31 Dec 2016, 01:33
Snowhog's Avatar
Snowhog Snowhog is offline
 
Join Date: Oct 2011
Real name: Paul L
Okay, reloaded the MOD. Expanding Total members that have visited the forum in the last 24 hours: now shows the Usergroup Legend, but doesn't show anything but the Legend Delimiter I selected (Diamond).
Attached Images
File Type: jpg MarkFLMODresults.jpg (41.1 KB, 10 views)
__________________
"It is a capital mistake to theorize in advance of the facts." - Sherlock Holmes
Kubuntu Forums . Net | ZB BLOCK | StopForumSpam
Reply With Quote
  #34  
Old 31 Dec 2016, 01:36
Snowhog's Avatar
Snowhog Snowhog is offline
 
Join Date: Oct 2011
Real name: Paul L
Originally Posted by MarkFL View Post
What does your complete "FORUMHOME" template have?
Complete contents of the template (after reinstalling your MOD and leaving my modification in place):

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
"It is a capital mistake to theorize in advance of the facts." - Sherlock Holmes
Kubuntu Forums . Net | ZB BLOCK | StopForumSpam
Reply With Quote
  #35  
Old 31 Dec 2016, 01:46
Snowhog's Avatar
Snowhog Snowhog is offline
 
Join Date: Oct 2011
Real name: Paul L
Originally Posted by Snowhog View Post
Okay, reloaded the MOD. Expanding Total members that have visited the forum in the last 24 hours: now shows the Usergroup Legend, but doesn't show anything but the Legend Delimiter I selected (Diamond).
Doh!! What a dumb a I am! Usergroup List has to be populated!!
__________________
"It is a capital mistake to theorize in advance of the facts." - Sherlock Holmes
Kubuntu Forums . Net | ZB BLOCK | StopForumSpam
Reply With Quote
  #36  
Old 31 Dec 2016, 10:12
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Glad you got it sorted out!
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #37  
Old 01 Jan 2017, 16:49
Snowhog's Avatar
Snowhog Snowhog is offline
 
Join Date: Oct 2011
Real name: Paul L
How do you add a Custom Delimiter? I tried pointing to a .png image I have in /images, but that doesn't work; it results in the path being displayed in the legend and not the image. Does this 'option' use ASCII values only, or??
__________________
"It is a capital mistake to theorize in advance of the facts." - Sherlock Holmes
Kubuntu Forums . Net | ZB BLOCK | StopForumSpam
Reply With Quote
  #38  
Old 01 Jan 2017, 17:34
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Yes, it's set up to use characters, not images.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #39  
Old 01 Jan 2017, 19:45
Snowhog's Avatar
Snowhog Snowhog is offline
 
Join Date: Oct 2011
Real name: Paul L
Okay. Thank you.
__________________
"It is a capital mistake to theorize in advance of the facts." - Sherlock Holmes
Kubuntu Forums . Net | ZB BLOCK | StopForumSpam
Reply With Quote
  #40  
Old 01 Jan 2017, 19:47
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Originally Posted by Snowhog View Post
Okay. Thank you.
It's on my to-do list to allow custom images as delimiters...should have an update on this pretty soon.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #41  
Old 02 Jan 2017, 12:28
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
Update - Version 1.3:
  • Added setting to allow for image as custom delimiter.
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #42  
Old 06 Jun 2017, 05:13
JARNAR JARNAR is offline
 
Join Date: Apr 2017
Hello Mark,

How do you add a separator between the names?

As you can see (attached image), the two texts are barred and it doesn't look good:
Attached Images
File Type: jpg Screenshot (65).jpg (11.2 KB, 9 views)

Last edited by JARNAR; 06 Jun 2017 at 05:29.
Reply With Quote
  #43  
Old 06 Jun 2017, 05:32
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
You can add CSS to the delimiters (separators)...try something like:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in the setting labeled "Additional Delimiter CSS."
__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
  #44  
Old 06 Jun 2017, 06:32
JARNAR JARNAR is offline
 
Join Date: Apr 2017
Originally Posted by MarkFL View Post
You can add CSS to the delimiters (separators)...try something like:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

in the setting labeled "Additional Delimiter CSS."

The barrier remains above the separator(screen 1):

How to get the not-bold separators (like a Boofo's Legend; screen 2)???
Attached Images
File Type: jpg Screenshot (66).jpg (7.8 KB, 7 views)
File Type: png screen62.png (8.5 KB, 6 views)
Reply With Quote
  #45  
Old 06 Jun 2017, 06:39
MarkFL's Avatar
MarkFL MarkFL is offline
 
Join Date: Feb 2014
Real name: Mark
If you want the separator to not be bold, then add the delimiter CSS:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

__________________
Former vBulletin.org Staff Member



Support for my products (as well as updates/new product publishing) has been moved to MHB - vBulletin Products and TAZ - Add-ons
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 02:32.

Layout Options | Width: Wide Color: