Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Embed XHTML valid YouTube and Google Video into your posts Details »
Embed XHTML valid YouTube and Google Video into your posts
Mod Version: 2.2.0, by Viper007Bond (Member) Viper007Bond is offline
Developer Last Online: Dec 2017 I like it Show Printable Version Email this Page

This modification is in the archives.
vB Version: 3.6.8 Rating: (73 votes - 4.74 average) Installs: 1039
Released: 05 Nov 2006 Last Update: 24 Oct 2007 Downloads: 4177
Not Supported Uses Plugins Additional Files Re-usable Code  

==============================
DON'T FORGET TO CLICK INSTALL!
==============================


Just thought I'd share what I did to allow my users to embed YouTube and Google Video videos into posts on my forum. This is my very first mod I've made since switching to vB, so forgive me if I screwed something up.


Demo:

http://forums.finalgear.com/test-for...-thread-14892/

The black bar will be different for you as it'll match your theme (it uses the same style as the whole quick reply box).


Upgrading from v1.x:

Just remove the plugin you added before (manage plugins -> delete) and then continue on to the installation instructions.

If you already have v2.x installed, you do NOT need to do this.


Installation:

Download and install the attached product. It will automatically create the new custom BBCode and add in some filtering plugins.

Save the two attached images and upload them to /images/editor/.


Usage:

Here's some examples:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Using vBAdvanced? It lacks the hook this plugin uses apparently, so if you wish to use this plugin with it, you need to use only the video ID and NOT the full URL for it to display correctly. Nothing I can do about it, it's vBAdvanced's fault.


How do I customize the look of the new box thingies?

Just edit the new custom BBCode items. It's in the admin area, near the bottom.

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
  #241  
Old 30 Mar 2007, 04:42
KipLarson KipLarson is offline
 
Join Date: Jul 2005
So there is no way to get it to work on vBadvanced? i.e. if I make a post that goes into the news module on the front page (and I put a youtube video in it) the youtube video will not show up on my main page?
Reply With Quote
  #242  
Old 30 Mar 2007, 13:02
icemanic icemanic is offline
 
Join Date: Jun 2006
Originally Posted by TrekkerOfFiles View Post
I installed this but it only has the Google icon, no YouTube icon.
me too!!!

anyone know Y ??????
Reply With Quote
  #243  
Old 30 Mar 2007, 22:53
CADguru CADguru is offline
 
Join Date: Nov 2002
Originally Posted by icemanic View Post
me too!!!

anyone know Y ??????
Just right click and save the icon from the first post and then upload to the /images/editor folder.

I used the modified file from confus on previous post #232 and it works perfectly (3.6.4)
Reply With Quote
  #244  
Old 01 Apr 2007, 07:20
LateralG LateralG is offline
 
Join Date: Aug 2006
installed! and..op.. been a fan for "finalgear" for a while!
Reply With Quote
  #245  
Old 01 Apr 2007, 07:23
v12kid's Avatar
v12kid v12kid is offline
 
Join Date: Feb 2006
Real name: Matt
installed and working, thanks!
Reply With Quote
  #246  
Old 02 Apr 2007, 17:07
Annie^.^ Annie^.^ is offline
 
Join Date: Sep 2005
Originally Posted by GrendelKhan{TSU View Post
<< installed
working great in 3.6.0 and 3.6.5
thanks and great job!!


yah me too!! would love and appreciate if someone can say how to get this working in the QR box.

Yes I was looking for the same thing but I was dissapointed that this functions is not available. I'm not a programmer but i did some digging in the codes and I was able to make it appear in the Quick Reply ......


Template to edit
Show Thread Templates ---> showthread_quickreply

Find:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

After add:

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Make sure your images are in the your custom style Editor folder too
I hope this helps.
__________________
Hi Guys I'm NEW!

Don't click!! :devious:

Last edited by Annie^.^; 02 Apr 2007 at 17:22. Reason: code mistake
Reply With Quote
  #247  
Old 10 Apr 2007, 01:42
mlk_f1 mlk_f1 is offline
 
Join Date: Feb 2007
Disable in Signature

Anyone find out how to disable this feature in the signature posting editor yet?
Reply With Quote
  #248  
Old 10 Apr 2007, 04:51
rknight111 rknight111 is offline
 
Join Date: Oct 2006
I installed on my board today, I run 3.6.5 and It works with no problems. I have one question when people go on Youtube or Google even if there is 3 or 4 people at the same time does my board slow down..

Great Mod..

RON
Reply With Quote
  #249  
Old 12 Apr 2007, 01:58
Viper007Bond's Avatar
Viper007Bond Viper007Bond is offline
 
Join Date: Oct 2006
Originally Posted by rknight111 View Post
I have one question when people go on Youtube or Google even if there is 3 or 4 people at the same time does my board slow down..
No, nothing is being loaded off your server but a few lines of HTML. The video is being streamed off their servers.
Reply With Quote
  #250  
Old 12 Apr 2007, 19:09
qcho qcho is offline
 
Join Date: Apr 2007
Works Great!!! Thanks !!
Reply With Quote
  #251  
Old 14 Apr 2007, 08:48
tehPARADOX tehPARADOX is offline
 
Join Date: Feb 2007
Originally Posted by RidinHighSpeeds View Post
Now if I submit my reply without entering in a title within the tags, it does not display the video.
I am having this particular problem, & although you've replied to it; it didn't really address how to fix this issue.

Perhaps you or the plugin forgot to add in the custom BB code for YouTube Video with No Title, such as the Google's Google Video with No Title BB code. So posting a youtube video without title will not display.

EDIT: Did a complete uninstall and reinstall, now missing custom bb code is added. Not sure why it didn't have it in the first place, so please disregard this post.
__________________

Last edited by tehPARADOX; 14 Apr 2007 at 08:53.
Reply With Quote
  #252  
Old 15 Apr 2007, 22:10
yaworski yaworski is offline
 
Join Date: Feb 2006
This is great but you should consider adding something like this:
Add this to the <tr> where the flash object is in.

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

and add this just after that one (that with flash object)

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

I tested it on FF2.0 and IE7 and this works good. Don't know if it works on IE6 yet, because I don't have it anymore. Opera should be fine.

I checked this on FF with Temper Data extension (shows requests that are made by FF) and the flash is not loaded when it is not displayed (display: none) and loads just after clicking on the predefined text. I know that not everyone will want that change so maybe you could add this as an alternative version? This would save users some bandwidth when they open thread with many videos (not everybody wants to watch all the videos).

----edit----

Oh and one more thing. I think that using opaque wmode in flash is slightly faster than transparent (it doesn't need to check if flash has transparent parts). This still works like transparent in context of dynamic html (works well with z-index).

Last edited by yaworski; 15 Apr 2007 at 22:39.
Reply With Quote
  #253  
Old 17 Apr 2007, 18:21
taumau taumau is offline
 
Join Date: Aug 2006
How about DailyMotion videos?
Reply With Quote
  #254  
Old 19 Apr 2007, 15:25
Viper007Bond's Avatar
Viper007Bond Viper007Bond is offline
 
Join Date: Oct 2006
Originally Posted by taumau View Post
How about DailyMotion videos?
Sadly the embed code has nothing in common with the URL in your address bar, so it makes it rather hard for the average user.
Reply With Quote
  #255  
Old 21 Apr 2007, 07:14
Da`Nacho Da`Nacho is offline
 
Join Date: Mar 2002
Great work, but you need to make this more aware of vBulletin's NOPARSE bbCode.

I've noticed from your example page that you don't seem to be aware of it either. (You've got spaces in your example bbcode to avoid parsing instead). If you wrap code in [noparse][/noparse] tags then vBulletin will not parse any bbCode commands inside them. This was added in 3.5.x and up. It's VERY handy for showing examples to your forum members!

I've noticed (when citing examples for the members of my forum) that if you wrap your bbcode (gvideo] or [youtube] in noparse tags, and you have a Youtube or Google URL inside, the Google Video or Youtube document id will still be parsed out of it and displayed instead of the entire URL.

so for example:

[noparse][youtube]http://www.youtube.com/watch?v=XhgVIbO83o4[/youtube][/noparse]

will actually display

[noparse][youtube]XhgVIbO83o4[/youtube][/noparse]
__________________
http://www.candidforums.com - Geeks ARE hot.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 12:49.

Layout Options | Width: Wide Color: