Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Thread Thumbnails Details »
Thread Thumbnails
Mod Version: 3.1.0, by Null Parameter (Member) Null Parameter is offline
Developer Last Online: Apr 2014 I like it Show Printable Version Email this Page

vB Version: 4.0.x Rating: (29 votes - 4.76 average) Installs: 237
Released: 03 Mar 2010 Last Update: 30 Apr 2010 Downloads: 1614
Not Supported DB Changes Uses Plugins Auto-Template Translations  

Thread Thumbnails
Created By: Null Parameter

The Thread Thumbnails mod allows users of a forum to specify, in several possible ways, a thumbnail for their thread to be displayed on Forumdisplay thread list.

I had created the mod for vB 3.8, but people we're crying out for a ported version to vB4, and, thanks to help from several of the members, here it is!


Description of Features

Thumbnails are displayed on the Forumdisplay next to the threadicon.
In the ACP Options, assuming you are using the Auto-Template Edits, you can choose which side of the icon to display it on.

Forum Display Screenshot


When submitting a new thread or editing the first post of a thread, a thumbnail can be specified directly if the User Entered URL option is chosen in the ACP. Another option is to Require the thumbnail. If the thumbnail isn't required, it may be left blank by the user, and it can either not be shown at all on forumdisplay or be replaced by a default thumbnail image specified in the ACP.

New Thread Screenshot

Edit Post Screenshot


All available options in the ACP include...
  • Turn Off/On Thumbnails
  • Turn Off/On Auto-Template Edits
  • Which forums to use thumbnails in
  • Turn Off/On thumbnails on sticky threads
  • Require thumbnails (doesn't work with attachment option)
  • Choose to retrieve thumbnails from one of the following
    • User Entered URL
    • First Attachment
    • First Image in Post
  • Choose where thumbnail is displayed in threadbit (relies on Auto-Template Edits)
  • Thumbnail CSS Style
  • Specify No Thumbnail Replacement Image
ACP Options Screenshot


This version is also now using phrases, so it can more easily be translated!


Installation

Install the product XML file. That's it!

If you have a highly customized style, there is a chance that the auto-template edits will not work. In that case, you will need to make the template edits manually. See the included README for more details.


Thumbnail Style

The style for thumbnails is specified in the ACP. It is used to choose exactly how thumbnails will be displayed, including width, height, margins, borders and many other attributes.

The style is specified in CSS, and is applied directly to the HTML img tag.

Here are some examples of possible thumbnail styles, along with a description of what they will do. If you don't know much about CSS, you can learn more here.
  • Every thumbnail will have a width of 100 pixels, but be constrained to being a maximum of 150 pixels in height
    • width:100px;max-height:150px;
  • Every thumbnail will have a width of 120 pixels and have a margin of 3 pixels around the thumbnail, so that it doesn't touch any of the other elements in the threadbit
    • width:120px;margin:3px;
  • Thumbnails aren't allowed to exceed 150 pixels in either dimension, and are also mildly transparent
    • max-width:150px;max-height:150px;opacity:0.8;filter:alpha(opacity=80);
Note: Using CSS positioning attributes (i.e. position, float, clear, etc.) could mess up the threadbit structure, so beware.


FAQs

The version of this mod for vB 3.8 showed thumbnails in the search results. Where did they go?
The search system between vB 3.x and vB4 changed significantly. I didn't have the time to figure out the complexity of it, and was unable to find any examples of other mods that integrated into the search results.

If you know how this is done, feel free to contact me and we can work to get this feature back in!
Does this mod work for RTL Languages, such as Arabic?
There is a separate product XML file available for download that has the appropriate changes to support RTL languages.
When I choose the First Image in Post option, no thumbnails show up in my current threads. Why?
Thumbnails are only updated when a new thread is created or when the first post is edited. Parsing through every forum/thread whenever the options are changed could be disastrous for performance.

Luckily, a user of this mod, megamoose, created a script that you can use to help this out. I want this method to be known, but because I didn't write this, I make no promises that it will work.

Originally Posted by megamoose View Post
This should enable batch processing. I have tested it.
Change the $STEP_AMOUNT at the top to something lower if you still get errors
Remember this is for vB version 3.8
Always backup your data before running scripts like these

TO THOSE WHO HAVEN'T BEEN FOLLOWING THE CONVERSATION:
This script will go through all your existing posts and give them thumbnails, based on the First IMG in post option.


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.
Translations

Arabic

Versions

v3.1
  • Fix for Required Thumbnails
  • New feature to automatically use ALL Forums
v3.0
  • Support for vB4!
  • Use Phrases
  • Option to make Thumbnails Required
  • Option to select where to show the thumbnail on Forumdisplay
  • Option to specify the CSS Style of thumbnail images
Mod Support

I am fully willing to support this mod and continue to add new feature to it when they are desired enough to make them applicable to the product as a whole. The issue is that I do not have access to a vB4 installation, and therefore cannot develop.

Several people were gracious enough to offer up a test installation for me to use, and that is how this mod exists today. If any new features/fixes are wanted, other people will need to be just as gracious.

Also, since I don't own a vB4 instance, I'm supporting this strictly out of the kindness of my heart. So, if you wish to Support me as a developer, it would be much appreciated.

Enjoy!

Download Now

Only licensed members can download files, Click Here for more information.

Screenshots

Click image for larger version

Name:	forumdisplay.png
Views:	7930
Size:	148.2 KB
ID:	113497   Click image for larger version

Name:	editpost.png
Views:	2908
Size:	24.6 KB
ID:	113498   Click image for larger version

Name:	newthread.png
Views:	2831
Size:	36.1 KB
ID:	113499   Click image for larger version

Name:	adminoptions.jpg
Views:	2309
Size:	121.5 KB
ID:	113500  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
New Posting Features Thread Thumbnails Null Parameter vBulletin 3.8 Add-ons 349 14 Feb 2015 03:53

Comments
  #2  
Old 03 Mar 2010, 19:37
Aclikyano Aclikyano is offline
 
Join Date: Apr 2006
thanks ill check it out!
Reply With Quote
  #3  
Old 03 Mar 2010, 19:41
Aceman's Avatar
Aceman Aceman is offline
 
Join Date: Mar 2002
not first.. but AWESOME!
__________________
www.scifi-meshes.com (Vb4.0)
www.military-meshes.com (Vb3.8)
Reply With Quote
  #4  
Old 03 Mar 2010, 20:06
Xtrigit's Avatar
Xtrigit Xtrigit is offline
 
Join Date: Jan 2010
OMG!!!!!!! Thank you so much! This is the ONLY MOD that made me downgrade to 3.8.4. I will test it later this week and see how it goes.
Reply With Quote
  #5  
Old 03 Mar 2010, 20:43
kalisekj kalisekj is offline
 
Join Date: Dec 2006
Awesome A Must Have for me and most of my sites. Thank You! Now To Pray it works.
Reply With Quote
  #6  
Old 03 Mar 2010, 21:04
kalisekj kalisekj is offline
 
Join Date: Dec 2006
OK First Bug as I can see now, I changed to before thread icon and now have 2 pics on the forum display page 1 before thread icon and 1 after thread icon. LOL

VBoptimize Users You Must Disable Cache Styles (Set It To No) then the thumbnails will work as needed. Also You need to Disable vB Optimise: Cache Templates so that you do not get multiple Thumbnails on Forum Thread Display. This is just a small part of vboptimize that is well worth turning off to get thumbnails to work.

Last edited by kalisekj; 03 Mar 2010 at 21:44.
Reply With Quote
  #7  
Old 03 Mar 2010, 21:11
Null Parameter's Avatar
Null Parameter Null Parameter is offline
 
Join Date: Jun 2008
Originally Posted by kalisekj View Post
OK First Bug as I can see now, I changed to before thread icon and now have 2 pics on the forum display page 1 before thread icon and 1 after thread icon. LOL

VBoptimize Users You Must Disable Cache Styles (Set It To No) then the thumbnails will work as needed. This is just a small part of vboptimize that is well worth turning off to get thumbnails to work.
LOL, I was just about to post that when you edited it in. vB Optimize goes behind vB's caching and caches the templates on it's own. This leads to cached templates receiving multiple edits when switching between Before/After Thread Icon.
Reply With Quote
  #8  
Old 03 Mar 2010, 21:11
akvaryumforum akvaryumforum is offline
 
Join Date: Mar 2007
No Thumb selection not work. I just links to /attachment.php?attachmentid=&stc=1&thumb=1 al no thumbs.
Reply With Quote
  #9  
Old 03 Mar 2010, 21:16
Null Parameter's Avatar
Null Parameter Null Parameter is offline
 
Join Date: Jun 2008
Originally Posted by akvaryumforum View Post
No Thumb selection not work. I just links to /attachment.php?attachmentid=&stc=1&thumb=1 al no thumbs.
Ahh, nice catch. I have a separate code path for the attachments part. I'll add that in right away.
Reply With Quote
  #10  
Old 03 Mar 2010, 21:17
Deceptor's Avatar
Deceptor Deceptor is offline
 
Join Date: Dec 2008
Originally Posted by Null Parameter View Post
LOL, I was just about to post that when you edited it in. vB Optimize goes behind vB's caching and caches the templates on it's own. This leads to cached templates receiving multiple edits when switching between Before/After Thread Icon.
Anything I can do to resolve that?
Reply With Quote
  #11  
Old 03 Mar 2010, 21:27
Null Parameter's Avatar
Null Parameter Null Parameter is offline
 
Join Date: Jun 2008
Originally Posted by Null Parameter View Post
Ahh, nice catch. I have a separate code path for the attachments part. I'll add that in right away.
I uploaded a new version with this change. Go try it now, the First Attachment + No Thumbnail Image combo should work now.

Originally Posted by Deceptor View Post
Anything I can do to resolve that?
I'm not really sure, because I have no idea how vB Optimize works.
I was basing that answer/guess solely on the description of the mod. It really depends upon when and how the template caching is done vs how and when I do the auto-edits.
Reply With Quote
  #12  
Old 03 Mar 2010, 21:29
akvaryumforum akvaryumforum is offline
 
Join Date: Mar 2007
The problem solved, now it's workin like a charm for me.
Reply With Quote
  #13  
Old 03 Mar 2010, 21:33
Null Parameter's Avatar
Null Parameter Null Parameter is offline
 
Join Date: Jun 2008
Originally Posted by akvaryumforum View Post
The problem solved, now it's workin like a charm for me.
Good to hear! Let me know if you see anything else.
Reply With Quote
  #14  
Old 03 Mar 2010, 21:45
kalisekj kalisekj is offline
 
Join Date: Dec 2006
deceptor read my thread above It tells what options to turn off in vboptimize to get the thumbnails to show properly.
Reply With Quote
  #15  
Old 03 Mar 2010, 21:57
Deceptor's Avatar
Deceptor Deceptor is offline
 
Join Date: Dec 2008
Originally Posted by Null Parameter View Post
I uploaded a new version with this change. Go try it now, the First Attachment + No Thumbnail Image combo should work now.


I'm not really sure, because I have no idea how vB Optimize works.
I was basing that answer/guess solely on the description of the mod. It really depends upon when and how the template caching is done vs how and when I do the auto-edits.
The cache doesn't intrude really, it basically stops vBulletin from querying templates. The templates are still placed in the array as they normally would.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 07:36.

Layout Options | Width: Wide Color: