Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #16  
Old 28 May 2010, 16:51
vauge vauge is offline
 
Join Date: Oct 2004
PHP Version 5.2.9
Mysql 5.0.90
Apache 2.0

Using CPanel.
=======
root@server [/usr/local/sphinx/cron]# ./delta_norotate.sh
Sphinx 0.9.8-id64-release (r1371)
Copyright (c) 2001-2008, Andrew Aksyonoff

using config file '/usr/local/sphinx/etc/vbulletin-sphinx.php'...
ERROR: invalid token in /usr/local/sphinx/etc/vbulletin-sphinx.php line 1 col 1.
ERROR: invalid token in /usr/local/sphinx/etc/vbulletin-sphinx.php line 1 col 1.
FATAL: failed to parse config file '/usr/local/sphinx/etc/vbulletin-sphinx.php'.
Sphinx 0.9.8-id64-release (r1371)
Copyright (c) 2001-2008, Andrew Aksyonoff
==

Please help, really do not want to spend 8 hours reindexing for the default search.
__________________
Forum
Political Forums
Reply With Quote
  #17  
Old 28 May 2010, 21:43
CarlitoBrigante's Avatar
CarlitoBrigante CarlitoBrigante is offline
 
Join Date: Nov 2002
Vauge, your error is caused by the php path on top of vbulletin-sphinx.php file. If you are unsure about your php path, you can ask your host or check with the "which" command via linux.

The most serious error is the one being caused during cronjobs, so far we were unable to pinpoint an obvious cause. It seems that some of those having the problem are using RAID; I would like to know if others have a similar configuration as well.

By the way, terrific forum.
__________________
Yes, that's only a nickname! - MagnetiCat.com - Professional development and administration, disaster recovery (also in desperate situations), PHP and Mobile App development.
Reply With Quote
  #18  
Old 28 May 2010, 23:46
pete_brady pete_brady is offline
 
Join Date: Mar 2002
Originally Posted by vauge View Post
PHP Version 5.2.9
Mysql 5.0.90
Apache 2.0

Using CPanel.
=======
root@server [/usr/local/sphinx/cron]# ./delta_norotate.sh
Sphinx 0.9.8-id64-release (r1371)
Copyright (c) 2001-2008, Andrew Aksyonoff

using config file '/usr/local/sphinx/etc/vbulletin-sphinx.php'...
ERROR: invalid token in /usr/local/sphinx/etc/vbulletin-sphinx.php line 1 col 1.
ERROR: invalid token in /usr/local/sphinx/etc/vbulletin-sphinx.php line 1 col 1.
FATAL: failed to parse config file '/usr/local/sphinx/etc/vbulletin-sphinx.php'.
Sphinx 0.9.8-id64-release (r1371)
Copyright (c) 2001-2008, Andrew Aksyonoff
==

Please help, really do not want to spend 8 hours reindexing for the default search.
http://www.vbulletin.org/forum/showp...96&postcount=6
__________________
thumped.com
Reply With Quote
  #19  
Old 29 May 2010, 00:52
vauge vauge is offline
 
Join Date: Oct 2004
This is very strange, which was the first thing I ran.

root@server [/usr/local/sphinx/cron]# which php
/usr/local/bin/php

root@server [/usr/local/sphinx/cron]# head ../etc/vbulletin-sphinx.php

Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

--------------- Added 29 May 2010 at 00:58 ---------------

More craziness, if I change it to "/usr/bin/php" - I get the following...

root@server [/usr/local/sphinx/cron]# ./delta_norotate.sh

using config file '/usr/local/sphinx/etc/vbulletin-sphinx.php'...
ERROR: invalid section type 'X-Powered-By' in /usr/local/sphinx/etc/vbulletin-sphinx.php line 1 col 13.
ERROR: invalid section type 'X-Powered-By' in /usr/local/sphinx/etc/vbulletin-sphinx.php line 1 col 1.
FATAL: failed to parse config file '/usr/local/sphinx/etc/vbulletin-sphinx.php'.
Sphinx 0.9.8-id64-release (r1371)
Copyright (c) 2001-2008, Andrew Aksyonoff
__________________
Forum
Political Forums

Last edited by vauge; 29 May 2010 at 00:59. Reason: Auto-Merged DoublePost
Reply With Quote
  #20  
Old 12 Jun 2010, 00:18
sybakaos sybakaos is offline
 
Join Date: Mar 2006
I'm trying to install sphinx but I'm experiencing the following error as some other people did previously as well.

ERROR: invalid token in /usr/local/sphinx/etc/vbulletin-sphinx.php line 1 col 1.

I've tried all available PHP paths and I did refer to the correct $myforumpath... I have even reconfigured PHP using suexec, dso etc. Any ideas on how to solve this or perhaps there's an alternative?
Reply With Quote
  #21  
Old 20 Jul 2010, 18:15
lazyllama lazyllama is offline
 
Join Date: May 2007
I just had this error, and in my case it seems to be nothing to do with the config file, despite the error.

I closed the boards using the AdminCP and ran delta.sh and got the above error about Invalid Token. I opened the boards and ran delta.sh and it ran just fine.

I hope that might help someone.
Reply With Quote
  #22  
Old 12 Dec 2010, 08:36
nrrdot nrrdot is offline
 
Join Date: Feb 2010
Anyone ever get this to work? I just did everything as instructed and it does the same thing.
Reply With Quote
  #23  
Old 12 Dec 2010, 10:08
ThorstenA's Avatar
ThorstenA ThorstenA is offline
 
Join Date: Nov 2004
Originally Posted by nrrdot View Post
Anyone ever get this to work? I just did everything as instructed and it does the same thing.
I couldn't and deinstalled vbulletin sphinx search.
Reply With Quote
  #24  
Old 12 Mar 2011, 07:02
intensecool intensecool is offline
 
Join Date: Feb 2007
Ok, can anyone tell me one thing :

here are my board stats :


I am willing to install SPHINX on my board, but my board is split on 2 servers, one is with files other is having database.
Can you guys confirm to me on which server should i install this thing webserver or database server.

I am confused and secondly which page steps are correct to follow, i will follow this one.
http://www.vbulletin.com/forum/showt...-vBulletin-4.0

Please confirm quickly.

And one more thing, i dont want to close the board, just turn off the search during installs is it possible
Reply With Quote
  #25  
Old 12 Mar 2011, 18:59
Lynne's Avatar
Lynne Lynne is offline
 
Join Date: Sep 2004
Real name: Lynne
I installed it on my webserver.
__________________
Try a search before posting for help. Many users won't, and don't, help if the question has been answered several times before.
W3Schools -
Online vBulletin Manual
If I post some CSS and don't say where it goes, put it in the additional.css template.
I will NOT help via PM (you will be directed to post in the forums for help.)
Reply With Quote
  #26  
Old 15 Mar 2011, 07:29
intensecool intensecool is offline
 
Join Date: Feb 2007
Not working at all.
I tried everything fine, but when it stats indexing , it stops at 73000 thread.
Waited for 2 hours , nothing happened. tried a reinstall still same step stuck up.

Any ideas why this is happening and i am on VBULLETIN 4.1.1
I think this is the issue.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 01:36.

Layout Options | Width: Wide Color: