Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
Thread Thumbnails V4 *Upgraded* Details »
Thread Thumbnails V4 *Upgraded*
Mod Version: 4.0 Rev 1., by fxwoody (Member) fxwoody is offline
Developer Last Online: Jan 2016 I like it Show Printable Version Email this Page

vB Version: 4.1.4 Rating: (11 votes - 4.82 average) Installs: 88
Released: 03 Jun 2011 Last Update: 31 Jul 2011 Downloads: 731
Not Supported Uses Plugins Template Edits Additional Files Translations  

Thread Thumbnails V4 Rev 1.1

Description of the main feature:

The Thread Thumbnails V4 plugin is an extra image that will be displayed onto the Forumdisplay Threadlist of specified Forums and subForums.
The user will either have the possibility to add manually or automatically (option setup) the image of is choice to be shown as a Thumbnail.

This mod was originally created by Null Parameter for 3.8 and 4.0, but, for several reasons and many hours of trying to make the mod stable and fully working in vB 4.1.x, i'ved reworked the script and put it in an easier approach.


Functions:

When submitting a New Thread or editing an existing Thread, you can select the option for:
  • User Entered URL
  • First Attachment
  • First Image In Post

When making a new post, the user will either have to input the URL for the thumbnail (User Entered URL option) or the thumbnail will be automatically displayed if the "FIRST" image or attachment option is selected.

To edit a thumbnail, if the "User Entered URL" is selected, a text box will be shown in the editor for them or staff to edit it.( I will try to add the editing option from the quickedit box in the future releases)

If other options are selected, the thumb will be automatically updated when the first image is replace, either from the post or the attachment.

Notes:
For the attachment editing, you will have to delete the first image and then reload it last for the plugin to work. The sequence of attachment doesn't get automatically changed when transferring attachment inside the vBulletin attachment options!
This is part of vBulletin, not the plugin.

For the first image in post option, you can edit directly from the quickeditor in order to replace the thumb.

What's new:

I'ved included an image folder with two thumbnail style for your board, you can easily select the one you need by replacing the name of the thumb in the ACP "Thread Thumbnails Options" from "No Thumbnail Replacement Image"

Thumbnail choice:
  • nothumb.jpg
  • nothumb1.jpg


Installation:

Upload the "thumbs" folder into: images->misc->
Import XML file from your ACP Manage Products

You will have to make some manual modifications in you forum's skin in order for the plugin to work well.

Every template mods are included in the Text file of the attachment.
Follow the instructions and you shouldn't have any problems.

Version:
v4.0
-------------
  • Support for vB4
  • Removed the Automatic Template Edits
  • Use Phrases
  • Option to make Thumbnails Required (fully upgraded)
  • Option to specify the CSS Style of thumbnail images
  • New Thumb images added
  • Thumb Editing upgraded
  • Megamoose PHP script included in folder

V4.0 Rev1.0 *Updated to 4.1.5*
V4.0 Rev1.1 Changed Selection option

Enjoy the plugin and don't forget to CLICK INSTALLED !

Download Now

Only licensed members can download files, Click Here for more information.

Addons

Supporters / CoAuthors

Screenshots

Click image for larger version

Name:	cover.jpg
Views:	818
Size:	112.8 KB
ID:	129704   Click image for larger version

Name:	cover1.jpg
Views:	1954
Size:	68.3 KB
ID:	132225  

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Forum Display Enhancements Thread Thumbnails Null Parameter vBulletin 4.x Add-ons 296 03 Nov 2017 16:16

  #16  
Old 18 Jun 2011, 10:17
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
Originally Posted by mwink View Post
We don't get it to work. It seems installed ok, it shows thread thumbnail options in the admin, I checked the settings, they are also ok. But I just don't get it working. Nothing happens when I make a post... Any suggestions? Thanks!
Did you upload all the files, made the changes in the templates?

Most important did you add {vb:raw thread.thumbnail} in the threadbit under the right code?

Lots of possibilities, why it would not work mwink.
Reply With Quote
  #17  
Old 18 Jun 2011, 13:02
mwink mwink is offline
 
Join Date: Mar 2008
Thanks a lot for the quick response. It is working now! Only... we have 2 thumbnails now, 1 before and 1 after the thread icon. Any ideas?

Thanks again!
Reply With Quote
  #18  
Old 18 Jun 2011, 14:35
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
Yes it's for the 3D effect! lolll just kidding

look in the options and see where the thumbnail location is set to! It should be "After Threadicon"
The location of the thumb is placed with the {vb:raw thread.thumbnail}! If you have a custom template, you might have to play with the location in the script!
But in general, it shouldn't be a problem of script, mostly options
Reply With Quote
  #19  
Old 22 Jul 2011, 05:54
radiofranky radiofranky is offline
 
Join Date: Jun 2011
Hi,
I was wondering if you could help me make it work on vbadvanced "recent post module".
I tried to edit the template by inserting the code but it seems like the img url variable is not being passed.

thanks
Reply With Quote
  #20  
Old 22 Jul 2011, 18:50
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
i will try to help you out but i have not vbadvanced installed on my site

The script should be added like in a normal state from the templates...i assume
Let me check it out in my test site to see
Reply With Quote
  #21  
Old 23 Jul 2011, 00:26
radiofranky radiofranky is offline
 
Join Date: Jun 2011
thanks very much.
Reply With Quote
  #22  
Old 23 Jul 2011, 03:49
radiofranky radiofranky is offline
 
Join Date: Jun 2011
Originally Posted by fxwoody View Post
i will try to help you out but i have not vbadvanced installed on my site

The script should be added like in a normal state from the templates...i assume
Let me check it out in my test site to see
In your regular edit, you have edited 3 different files. However, in vbadvanced theren't those files.

I only added the code to "adv_portal_recthreads_lean" and is returns nothing.

thanks
Reply With Quote
  #23  
Old 30 Jul 2011, 20:34
trackpads's Avatar
trackpads trackpads is offline
 
Join Date: Aug 2003
Real name: Jason
With 4.1.5 when you install this mod it will tall you it is unsupported. I edited the XML to change the version to 4.2 or something and installed it anyway and it works like a charm. I apprecaite all of your work, thanks alot!!

-Jason
Reply With Quote
  #24  
Old 31 Jul 2011, 08:25
james7zt james7zt is offline
 
Join Date: Jul 2011
hello fxwoody, would you please make it works with vb 4.1.5 I dont have xml editor tool and had never done it before ...
thank you much.
Reply With Quote
  #25  
Old 31 Jul 2011, 15:57
trackpads's Avatar
trackpads trackpads is offline
 
Join Date: Aug 2003
Real name: Jason
Just use notepad and it will be fine.
Reply With Quote
  #26  
Old 31 Jul 2011, 18:24
TEMPESTADE TEMPESTADE is offline
 
Join Date: Dec 2010
works fine with vb 4.1.5 tanks
Reply With Quote
  #27  
Old 31 Jul 2011, 21:48
fxwoody's Avatar
fxwoody fxwoody is offline
 
Join Date: Jun 2010
@james7zt : the adjustment as been done
Reply With Quote
  #28  
Old 01 Aug 2011, 02:28
james7zt james7zt is offline
 
Join Date: Jul 2011
Thumbs up 5 stars!!!

Originally Posted by fxwoody View Post
@james7zt : the adjustment as been done
thank you so much!!!! 1000000000000000000 times it working great!!! i love it.
regards,
Reply With Quote
  #29  
Old 02 Aug 2011, 18:40
Chris Ober Chris Ober is offline
 
Join Date: May 2006
Can it be easily modified to add an option to show thumbs for both First Attachment OR
First Image In Post instead of only one or the other? That way if a person uploads an attachment or enters with the IMG tags, a thumbnail is created instead of only creating for the setting it's on.

Last edited by Chris Ober; 02 Aug 2011 at 19:48.
Reply With Quote
  #30  
Old 04 Aug 2011, 12:42
misericorde misericorde is offline
 
Join Date: May 2011
Thank you so much for this update

Installed and working
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 18:21.

Layout Options | Width: Wide Color: