Register Members List Search Today's Posts Mark Forums Read

Reply
 
Mod Options
IE11 browser detection and fixes Details »
IE11 browser detection and fixes
Mod Version: 1.01, by Zachery (Coder/Designer) Zachery is offline
Developer Last Online: May 2017 I like it Show Printable Version Email this Page

vB Version: 4.2.1 Rating: (1 vote - 5.00 average) Installs: 21
Released: 17 Oct 2013 Last Update: Never Downloads: 0
Not Supported Code Changes  

IE11 gets along pretty well with vB4, though file downloads get a bit wonky due to some changes in how IE is detected.

Please note, that 4.2.2 and beyond ALREADY includes these changes.


In includes/functions.php find:




Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.


Add above:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.



Next, find:


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

And replace it with


Block Disabled:      (Update License Status)  
Suspended or Unlicensed Members Cannot View Code.

Download Now

Only licensed members can download files, Click Here for more information.

Show Your Support

  • To receive notifications regarding updates -> Click to Mark as Installed.
  • If you like this modification support the author by donating.
  • This modification may not be copied, reproduced or published elsewhere without author's permission.
Similar Mod
Mod Developer Type Replies Last Post
Integration with vBulletin Mobile Device & Browser Detection (Adapted by BOP5) BirdOPrey5 vBulletin 4.x Add-ons 37 28 Jan 2017 00:01
Miscellaneous Hacks IE11 browser detection and fixes Zachery vBulletin 3.8 Add-ons 39 06 Feb 2014 19:44

Comments
  #2  
Old 15 Nov 2013, 17:23
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
Thanks for posting the fix!
Reply With Quote
  #3  
Old 20 Nov 2013, 19:26
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
Updated the detection code to better handle an IE10 case.
__________________
Looking for ImpEx?
Reply With Quote
  #4  
Old 10 Dec 2013, 02:25
dewebguy dewebguy is offline
 
Join Date: Dec 2013
Thanks for this! It worked great!
Reply With Quote
  #5  
Old 27 Dec 2013, 19:05
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
my users are still reporting problems with IE11. Is there anything else that can be done short of updating ckeditor or just disabling it when IE11 is used?
Reply With Quote
  #6  
Old 27 Dec 2013, 19:10
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
What problems? You need to be specific
__________________
Looking for ImpEx?
Reply With Quote
  #7  
Old 27 Dec 2013, 19:15
tbworld tbworld is offline
 
Join Date: Oct 2008
Originally Posted by tpearl5 View Post
my users are still reporting problems with IE11. Is there anything else that can be done short of updating ckeditor or just disabling it when IE11 is used?
Your statement is to broad in scope. It would be helpful if you could list some of the problems your users are having. Thanks
Reply With Quote
  #8  
Old 27 Dec 2013, 19:31
tpearl5's Avatar
tpearl5 tpearl5 is offline
 
Join Date: Nov 2001
Real name: John
They are reporting that the image dialog doesn't work, copy/paste doesn't work, can't insert the cursor into reply box or reply at all in some cases, or the site just causes the browser to crash.
Reply With Quote
  #9  
Old 27 Dec 2013, 23:49
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
Make sure your IE11 users are using the editor in Standard, not Advanced mode. The Advanced WYSIWYG editor doesn't detect/function correctly for IE11.
__________________
Looking for ImpEx?
Reply With Quote
  #10  
Old 02 Feb 2014, 17:45
griffinpower griffinpower is offline
 
Join Date: Feb 2011
So when I make the above changes I get a blank page in IE11 and it never loads the forum. Any ideas what it may be?
Reply With Quote
  #11  
Old 02 Feb 2014, 22:21
Zachery's Avatar
Zachery Zachery is offline
 
Join Date: Jul 2002
Real name: Zachery Woods
I'd suggest you redo the changes carefully.
__________________
Looking for ImpEx?
Reply With Quote
  #12  
Old 12 Aug 2015, 17:18
Stratis's Avatar
Stratis Stratis is offline
 
Join Date: Jan 2010
Real name: Stratis
For me in vb4.2.0pl4 i have white page when upload images.
The only way to fix this so far is
<meta http-equiv="X-UA-Compatible" content="IE=9" />
in headinclude

Hoped this will fix and other little problems.
Any way thanks Zachery
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Mod Options

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


New To Site? Need Help?

All times are GMT. The time now is 09:24.

Layout Options | Width: Wide Color: