Register Members List Search Today's Posts Mark Forums Read

Reply
 
Thread Tools
  #1  
Old 12 May 2004, 13:43
*****Sniper *****Sniper is offline
 
Join Date: Apr 2004
insert into user table problem

I am importing the moderators data from an old forum to vb3.

this is my insert statement
"INSERT INTO
user (userid, usergroupid, membergroupids, displaygroupid, username, email, usertitle, reputation, reputationlevelid, timezoneoffset, options, startofweek, passworddate, joindate )
VALUES ('".$row2['id_comm']."', '$userGroupid', '$memberGroupid', '$displayGroupid', '".$row1['username']."', '$email', '$userTitle', '$reputation', '$reputationid', '$timeZone', '$options', '$startWeek', '$passwordDate', '$joinDate' )";

[do you need to see what i values i put in for all the constants?]


i did this for a couple of results just to check if it worked.
it did the insert correctly, and the usernames and their respective emails showup when I look at all the users present in the admincp.
but (you knew this was coming) when i click on the username (to modify the profile or something) it does nothing. when i look at the bottom of the screen it says

/admincp/user.php?do=edit&userid=

there is no userid (whereas for test subjects the userid shows up)
what do i do? is the userid number a problem. (i inserted thru admincp about 6 users, so have userids 2-7 filled when i insert thru the script to the database the userid are 5697988 & 3479651 this shouldnt be a problem tho in the database it says int(10)
Reply With Quote
  #2  
Old 12 May 2004, 13:56
NTLDR's Avatar
NTLDR NTLDR is offline
 
Join Date: Apr 2002
Real name: Lee Botley, BSc (Hons)
Entries also need to be inserted into the userfield and usertextfield for each user added. Try the Fix Broken Profile option under Update Counters which should repair them.
__________________
Lee Botley, BSc (Hons) - vBulletin.org Moderator
http://www.thesistersthree.com/lee/sigs/signature.ts3
The Sisters Three Charmed Discussion Forums

WinterDir .:. vBindex v2.1 for vB2 .:. vBindex v3.0.0 RC5 for vB3
Reply With Quote
  #3  
Old 12 May 2004, 14:06
*****Sniper *****Sniper is offline
 
Join Date: Apr 2004
yes that did work, thanx a bunch! you think it will work when i import all 500 users??? it'll do it for all of them?

-update-
actually i just checked out the tables and i can do it myself! thanx again!

Last edited by *****Sniper; 12 May 2004 at 14:10.
Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


New To Site? Need Help?

All times are GMT. The time now is 09:29.

Layout Options | Width: Wide Color: